Hello everyone,

First off Merry Christmas!

I installed megasync by They provide an RPM (v.13.12) on their website for opensuse leap 42.1 which I’ve read also works on Tumbleweed. The installation completed successfully with no error messages.

Now when I try to run ‘megasync’ I get the following error:

megasync: symbol lookup error: megasync: undefined symbol: _ZN8CryptoPP15DEFAULT_CHANNELE

I then ran the following to get the C++ form of the undefined symbol:

 $ echo _ZN8CryptoPP15DEFAULT_CHANNELE|c++filt

I already have libcryptopp 5.6.2-10.2 installed as per the megasync requirements so I don’t really understand what the problem is. Leap 42.1 also has the same version for this library.

I also tried uninstalling/installing megasync and libcryptopp. The installation completes without a problem again but I get the same error when I try to run the application.

Does anyone have any idea as to what the problem may be?

Thank you.

looks like you installed the 13.x version, the Mega people do have a TW (LEAP too) repo it’s their website that hasn’t been updated with propper links do this

zypper ar -f mega
zypper ref
zypper in -f megasync

if the above does not work you should do a dup to force package change

zypper dup --from mega

for LEAP users who found this with google to get mega do

zypper ar -f mega
zypper ref
zypper in megasync 

for gnome users who want the shell extension get

zypper in nautilus-megasync

Thank you @I_A what you suggested worked like a charm.

Thanks again!

good to hear mega is a cool service