mate-terminal crash with: Settings schema '' is not installed


I just installed openSuSE leap and used mate-terminal on openSuSE 13.2 with no problems.
The instalation process works just fine but when I try to launch the terminal I the the following message:

ff@hope:~/Projetos> mate-terminal

(mate-terminal:2411): GLib-GIO-ERROR **: Settings schema ‘’ is not installed

Trace/breakpoint trap

Have googled the error with no lucky. Hope someone can help.
Thanks in advance.

Best regards,


  1. When you installed openSUSE, did you install a different Desktop first, and then installed MATE or did you install MATE Desktop as the first (and maybe only) Desktop?

  2. If you installed a differernt Desktop first (eg KDE Plasma), did you try to launch your MATE Terminal from within that other Desktop when that error was displayed? If this is what you did, what happens if you logout, select the MATE Desktop and log back in?


Hi Tsu,

Thanks for you answer and I’m really sorry about the poor description of my environment.

On openSuSE 13.2 I used gnome as installed desktop and also installed Cinnamon 2 as my default desktop. I didn’t have MATE Destktop installed just installed mate-terminal and whatever dependencies Yast told me to and it used it on Cinnamon work just fine.

On Leap I have the same situation. Gnome installed as primary desktop and Cinnamon 2 on top of it. I only use Cinnamon, same situation as I had on openSuSE 13.2. Again I don’t have the full MATE Desktop installed as I didn’t before, just mate-terminal and whatever Yast asked to install too.

I can run a test installing the full MATE Desktop to see if the terminal works fine with that but I really think it would be nice to address the bug where you select to install a program and something crash instead of just try to make things work.

Also on the directory /usr/share/glib-2.0/schemas/ where several org.mate.*.xml are located there is no file named ‘’.

I’m going to check if installing full mate desktop makes things work and get back to you in a few minutes.

Thanks for you help.

Best regards,


I tend to use a Terminal designated to run within a Desktop only if that Desktop is also installed (may not be currently used but must be installed).


Hi Tsu,

just installed the full Mate Desktop environment. After the installation I run mate-terminal and it opened without complaining. On the directory /usr/share/glib-2.0/schemas/ still no file named

ff@hope:~> sudo find / | grep

finds no file with that name.

Even before installing the full MATE Desktop there was a file named /usr/share/glib-2.0/schemas/org.mate.terminal.gschema.xml. Before posting this I tried to symlink it to and and mate terminal still didn’t work.

Installing the full Desktop solved the problem but the dependency problem still around if you just choose to install mate-terminal.

I’m at your service if you wish to find the root of this. If not, lets call this “solved”.

Thanks for you help.

Best Regards,