manually install NVIDIA driver

I have recently compiled a new kernel, not really an upgrade or mod, just a vanilla build. I can boot into the new kernel from GRUB (using failsafe, I
fcked something up with the desktop and KDE will no longer load in it, but failsafe
is ok). obviously, failsafe sets nomodeset by default, so that is not the problem,
but I am stilling passing nomodeset in the f
cked desktop.

Anyways, I’m fine with using the failsafe for the moment, but I am noticing the
nvidia driver I had previously installed is not loading in the new kernel. when I
try to install this driver from Yast it claims it is already installed, but I assume
being as I have compiled a new kernel that I will have to manually install this driver

Here are the steps I’m taking followed by the error I am receiving:

  1. Start terminal and login as su.
  2. Use init 3 to temporarily disable X (as required by installer).
  3. Login as root again.
  4. cd to dir containing NVIDIA-Linux-* driver installer.
  5. Use sh to execute it (I have tried the --kernel-source-path option).
  6. Follow the prompts from the NVIDIA installer.

Following the installer’s prompts, it claims that it will need to compile a module to
match my kernel interface (after it cannot find one online). The final error I am
presented with resembles this:

ERROR: Unable to determine the version of the kernel sources located in ‘lib/modules/2.6.34custom-12-desktop/source’.

The rest of the error goes on about making sure kernel-source and kernel-devel is installed, which I’m sure Yast installed to /usr/src/linux-*. I don’t know where this lib/modules directory is coming from, but I do know that I used Yast to install the kernel-source and it put it in /usr/src.

I have the appropriate kernel-sources and kernel-devel, gcc, and make installed. I
have copied the file config-2.6.34-12-desktop from /boot to /usr/src/linux-2.6.34-12/.config, although I’m not sure if this was the proper config file (it looked like a make config file from its contents).

Seems as though I have missed or messed up a config file somewhere. When I tried passing the --kernel-source-path with /usr/src/linux-2.6.34-12 as the directory, I get the same error.

It’s probably a simple fix, could anyone please be of some assistance here?