"man" returns always No manual entry

Hi guys,
Im playing with my raspberrypi 2 and i have installed the JEOS OpenSuse version(openSUSE-Tumbleweed-ARM-JeOS-raspberrypi.armv6l-2016.06.09-Build2.3.raw), so far so good, my only problem is:
(1) “man” returns always No manual entry for xxx,
(2)rpm -q man returns man-2.7.1-3.2.armv7hl and
(3)rpm -q man-pages returns man-pages-4.06-1.1.noarch
(4) $MANPATH is set to /usr/local/man:/usr/share/man:/usr/share/man[FONT=inherit]
What could be the problem / what could i further investigate?[/FONT]
[FONT=inherit]Thanks in advance and keep up with the good work
[/FONT]

Please always illustrate your story with exact computer examples:

henk@boven:~> man xxx
Er is geen pagina over xxx
henk@boven:~> echo $MANPATH
/usr/local/man:/usr/share/man:/opt/kde3/share/man
henk@boven:~>

This to avoid you jumping to conclusions and we not seeing it. I do not say that that is the case here, or that you would mislead us on purpose, but when you show us what you see, that will avoid confusion.

I have once seen that expressed here rather bluntly: we do not believe people, we believe computers.

As you see, I also have no man page for xxx. That is about the only conclusion I can come to after the information you provide. :wink:

Sorry about that:
I’ve actually just realised that “man” is just working fine lol! i installed gcc and did man gcc and it worked, so what made me thought man wasn’t working is because i tried with common commands. For instance:


david@Homeserver:~> man cp
No manual entry for cp

david@Homeserver:~> man ls
No manual entry for ls
david@Homeserver:~> man gcc


GCC(1)                                      GNU                                     GCC(1)



**NAME**
       gcc - GNU project C and C++ compiler

**SYNOPSIS**
       gcc **-c**|**-S**|**-E**] **-std=**standard]
           **-g**] **-pg**] **-O**level]
           **-W**warn...] **-Wpedantic**]
           **-I**dir...] **-L**dir...]
           **-D**macro=defn]...] **-U**macro]
           **-f**option...] **-m**machine-option...]
           **-o **outfile] @file] infile...

       Only the most useful options are listed here; see below for the remainder.  **g++**
       accepts mostly the same options as **gcc**.

**DESCRIPTION**
       When you invoke GCC, it normally does preprocessing, compilation, assembly and
       linking.  The "overall options" allow you to stop this process at an intermediate
       stage.  For example, the **-c **option says not to run the linker.  Then the output
       consists of object files output by the assembler.

       Other options are passed on to one or more stages of processing.  Some options
       control the preprocessor and others the compiler itself.  Yet other options control
       the assembler and linker; most of these are not documented here, since you rarely
       need to use any of them.



My next question is what package should i install for the common commands to be displayed ls, cp etc.

Solution found:
man-pages-posix was not installed.

Nice you found it yourself.

But you see how important it is to post real computer facts. Then we can start from that to find a solution instead of from some vague general remark.

As you’ve noticed, “JEOS” means “Just Enough OS” which means it’s an image of openSUSE stripped down to its bare functionality, in the case of embedded devices so that the OS can fit into very limited resources (in this case minimal disk space). Compared to a “normal” OS, that means you probably won’t already have various networking tools, extra file system utiities… and no help files of any type including MAN pages.

You can either install the MAN pages as you’ve discovered, or probably a better solution is to read the MAN pages on a laptop or desktop.

TSU

Yes :wink: Note taken next time there will be improvement.

@TSU i know what JEOS is, i just didn’t know how thin the system was :), I assumed man-pages were default like bread and butter