Man pages apparently not installing correctly (MicroOS)

Not sure if I found a bug or if I’m missing something about how MicroOS works.

ansible@homeserver:~> zypper se --installed-only '/man-pages|coreutils-doc/'
Loading repository data...
Reading installed packages...

S  | Name          | Summary                                  | Type
---+---------------+------------------------------------------+--------
i+ | coreutils-doc | Documentation for the GNU Core Utilities | package
i+ | man-pages     | Linux  Manual Pages                      | package
ansible@homeserver:~> echo $MANPATH
/usr/local/man:/usr/share/man
ansible@homeserver:~> man ls
No manual entry for ls
ansible@homeserver:~> rpm -ql coreutils-doc | grep ls
/usr/share/info/coreutils.info.gz
/usr/share/man/man1/false.1.gz
/usr/share/man/man1/ls.1.gz
ansible@homeserver:~> find /usr/ -name 'ls.1.gz'
ansible@homeserver:~> ls -l /usr/share/man/man1/
total 0

There are zero files installed in all of /usr/share/man and the coreutils-doc and man-pages packages are shown as installed. Tried re-installing using the transaction-update shell to remove and then reinstall and reboot. Still no files. Also tried running (inside a transactional-update shell) # mandb -c /usr/share/man and got

..... (lots of output)
300 man subdirectories contained newer manual pages.
0 manual pages were added.
0 stray cats were added.  
ansible@homeserver:~> cat /etc/os-release
NAME="openSUSE MicroOS"
# VERSION="20230119"
ID="opensuse-microos"
ID_LIKE="suse opensuse opensuse-tumbleweed"
VERSION_ID="20230119"
PRETTY_NAME="openSUSE MicroOS"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:microos:20230119"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"
DOCUMENTATION_URL="https://en.opensuse.org/Portal:MicroOS"
LOGO="distributor-logo-MicroOS"

Any ideas? Thanks!

Using a search machine throws this:

MicroOS is not designed to ship man pages for standard commands as the OS is intended for specialized usecases for experienced admins.

Yep, understand that it doesn’t come installed. You should be able to install any package inside the transactional-update shell though, right? I’ve installed other packages using both ansible and inside transaction-update shell and have had no issues. From my group_vars/suse file:

suse_packages:
  - acl
  - fd
  - firewalld-bash-completion
  - fuse
  - golang-github-prometheus-node_exporter
  - "{{ python_version}}-podman"
  - "{{ python_version}}-podman-compose"
  - "{{ python_version}}-toml"
  - "{{ python_version}}-xdg"
  - policycoreutils-python-utils
  - postfix
  - restic
  - restic-bash-completion
  - ripgrep
  - setroubleshoot-server
  - smartmontools

The link you provided was for a web-based documentation server, not the actual man-pages.

But you did read it?

openSUSE MicroOS has one deficit since the beginning: the documentation will not be installed on the system.

And again a search machine throws:
https://www.reddit.com/r/openSUSE/comments/jqw7ax/silly_question_regarding_man_in_microos/

So check /etc/zypp/zypp.conf for rpm.install.excludedocs

1 Like

Ahhh, that’s the missing piece (rpm.install.excludedocs). New to Suse and didn’t realize it worked that way. Thanks!