Make command not found

I have a fresh install of 11 RC1 from the KDE CD.

I was trying to install a suitable Atheros madwifi driver, but when I type make I get:

bash: make: command not found

What gives?

you will need to install it, go to install software and search for make.

Catch 22 eh? No wireless driver, no network, no make, can’t install make, can’t install wireless etc etc…

I do wish that it was easier to get the atheros drivers I need installed on Suse… other distros work out of the box…

Are you root?

Oh yeah… didn’t get caught out by that one.

go to 10.3 choose the madwifi repository and it works out the box.

if atheros isn’t working out of the box it would likely be due to the fact that you are using a RC1 of OpenSuse and maybe the repository for madwifi hasn’t been updated to that kernel yet.

I had a problem with make, was trying to install the Nvidia driver and it told me I needed make. I looked in software updates and make was already installed. Tried to reinstall it but no luck.

I’ve since reinstalled the whole OS so will try again later and see if it works.

In addition to make, have you also installed gcc, gcc++, gcc42, gcc42++ ? (or is it 43 instead of 42 ? … maybe I’m getting confused with the answer to life, the universe and everything?).
Answer to Life, the Universe, and Everything - Wikipedia, the free encyclopedia

Don’t forget you need the Kernel sources to be installed too. (Technically just the headers).

Under Yast select the patterns option (instead of search).

Select the following under development:

Base Development - Includes make etc
C/C++ - gcc & g++ etc (compilers)
Kernel Devel - Kernel sources (allows you to build kernel modules).

This is really the best way to make sure all the right tools are installed, for now and in the future.



If you don’t have network access, you will find make, and the other basic dev packages, on the installation media you used.

As others have said, you’ll probably need make, gcc, kernel-hearers, gcc++, gcc42, and gcc42++

Gary M wrote:
> Catch 22 eh? No wireless driver, no network, no make, can’t install
> make, can’t install wireless etc etc…
> I do wish that it was easier to get the atheros drivers I need
> installed on Suse… other distros work out of the box…
Wired connection could get you online for that, otherwise you will need
to wait for the DVD GM release.

My printer requires me to “make” its driver, and so I installed the kernel sources and syms, and make. However, when I went to install gcc, I got this:

YaST2 conflicts list - generated 2008-06-14 19:19:47

gcc-4.3-39.x86_64 requires gcc43, but this requirement cannot be provided
uninstallable providers: gcc43-4.3.1_20080507-6.i586[]
] Ignore some dependencies of gcc
] do not install gcc-4.3-39.x86_64
] downgrade of cpp43-4.3.1_20080507-6.1.x86_64 to cpp43-4.3.1_20080507-6.x86_64

YaST2 conflicts list END

This did not happen to me with my previous PC in 10.3, which was also an AMD64. I toyed with the downgrade option offered, but when I saw that the selected resolve option involved changing the installed kernel headers, I thought I better check here first to be on the safe side. Am I OK to accept the downgrade option to resolve the dependency problem, or am I stuck without gcc?

I’m surprised to see a dependency problem installing gcc. This is pretty fundamental. Was your PC on the Internet when you attempted this? Are you certain you have your repositories (for your software package manager YaST/Zypper) setup correctly?

I was VERY surprised too. I’ve never had a dependency conflict with any distro installation in all the time I’ve been using Linux. The repos were setup on the system’s recommendation, immediately after install. I selected all the repos it said I had to, in addition to packman and Videolan.

OK, and you never added any extra other than OSS, NonOSS, Updates, Packman and videlan?

Try installing only each app one at a time ,… ie gcc, … then if successful gcc++, …etc … the dependency sorting may require you to install multiple apps at a time, but do not do more than necessary. See if that works.

Thanks for the suggestion. It’s Sunday afternoon here now, and I think I’m just going to take the lazy way out and do a fresh install from the DVD ISO once I’ve downloaded it. Playing with the RCs was always just to find any potential booby traps, and I think it’s worked. Like learning to give KDE 4 a miss for now.

openSUSE has patterns which are nice. Enable kernel development and you’ll get all the packages you need to compile for the kernel.

Thanks. I’ll definitely do that when installing anew from the DVD on Friday.