Madwifi-kmp issues With 11.0

I seem to be unable to set up my Atheros wireless card with OpenSUSE 11.0(final release x-86).

uname -r shows:

I have set up all repositories in YAST and have attempted to install madwifi and madwifi-kmp-pae, without success with both YAST and 1-click-install.

I am able to install madwifi 0.9.4-1-i586. I get an error, however, when attempting to install madwifi-kmp-pae. The version available there is madwif-kmp-pae 0.9.4_2.6.25_26-1-i586 from 11.0

When attempting to install madwifi-kmp-pae I receive the following error message:
"nothing provides kernel(vmlinux)=1f623d7fcfa1b112 needed by madwifi-kmp-pae 0.9.4_2.6.25_26-i586.

Looks like a conflict here. Any help or information would be appreciated.


I’m curious about this, as my wife’s 10.3 pc has an atheros and she uses madwifi, and I am thinking of updating her PC from 10.3 to 11.0, to obtain the better tablet support that comes with 11.0.

I checked here openSUSE 11.0 madwifi packages
, and confirmed what you state about the madwifi 0.9.4-1-i586 and madwif-kmp-pae 0.9.4_2.6.25_26-1-i586 version numbering is correct.

I checked here and confirmed what you state about the current kernel version is correct.
OSS rpms for openSUSE-11.0

Are you certain you have all your repositories properly setup? I could understand this error if either:
a. your repositories were not setup properly, or
b. the repository server was down or temporary over taxed because of the mass of people downloading.

If it were me, after quadruple checking my repositories in my package manager, I would then try again many times.

Assume it is not one of the above (and I believe those to be likely causes), then if it were me, and I obtained that error, I would likely download the src file and do an rpm rebuild command (I dont’ have my notes handy so I can’t check/provide the exact syntax). Of course one needs kernel source, kernel-headers, … etc … properly setup.

I have done everything I know how to do, regarding confirmation of the repositories. In fact, none of the repositories were working, after the 11.0 install, so I even removed them all and reinstalled the repositories, after which, all seemed to be working fine. I even installed the repository from the 1-click-install site. I can see the packages in the software list, so am able to check the box to attempt to install, but still get the error. If I attempt to install the specific package from the OpenSUSE 1-click-install website, as an individual package, I still get an error…it will not even install directly.

It’s really a pain, as I’m used to using Mandriva…and two clicks of the mouse and the Atheros wireless just works. I haven’t used OpenSUSE since a couple of versions ago and wasn’t running wireless at the time, but now have all my systems on Atheros wireless, since it’s so easy to do with Mandriva.

Hopefully, someone can figure out what’s wrong with the packages…as I think it must be a package issue.


Well, if its a packager issue, then others will have the same problem. Lets wait and see how many other’s report this hiccup.

I confess I am still suspicious that this is because the openSUSE repository was overloaded. I see something like this sort of thing with every openSUSE release.

I have the same issue with the onboard Atheros in my Thinkpad on OpenSUSE 11. Kernel Personally I don’t think the Madwifi drivers are compatible…yet.

OpenSuse 11 automatically detects my DWL-G510 after the OS installation however, it does not scan for WiFi networks. To resolve the problem I tried installing madwifi & madwifi-kmp-default using Yast but, it won’t allow installing madwifi-kmp-default due to “nothing provides kernel(vmlinux)” conflict, like some here have experienced. I am stuck with wired internet.

Madwifi was working fine in 10.3.

:rolleyes: :rolleyes:

Sorry to read your madwifi is not working, and I sympathsize with your frustration, but after reading your post 3 times, I see no evidence that you tried to adopt a pragmatic approach and checked out the ath5k driver (which is the open driver to replace madwifi) or tried the NDIS wrapper approach. I think some pragmatism is more helpful here.

I’m having the exact same problem with the Madwifi kernel module, so i’m pretty sure this is a general issue that is affecting every Atheros user.

Is there a way to get this module other than the Madwifi repositories?

You can compile it from source or create your own RPM’s using rpmbuild. There are MANY OpenSUSE users out there where this is beyond their capabilities though. The new driver (ath5k) does not work on many Atheros chipsets and the Madwifi rpm’s are out of date and/or incompatible with the latest kernel. So you see, there will be alot of kicking and screaming until it is fixed. I’ll probably create my own rpm’s some day soon. I’ll do a write up then.

I am sure they will get the madwifi repository updated soon.

I don’t need madwifi anymore since it seems the ath5k will work enough for my Thinkpad.

Actually, I did try ath5k and ndiswrapper approaches but with no luck. :frowning:

Has anyone on this thread tried a simple **
rpmbuild --rebuild /path/to/the-rpm/madwifi-package-name.src.rpm **

…note one needs kernel headers and kernel-source installed for that to work

The man page for rpmbuild says this about the rebuild option:
When invoked this way, rpmbuild installs the named source package, and does a prep, compile and install. In addition, --rebuild builds a new binary package. When the build has completed, the build directory is removed (as in --clean) and the the sources and spec file for the package are removed.

oldcpu, tried it on KDE4 and I could not find local networks. I am on KDE 3.59 presently so I will try it again. The other thing is that knetworkmanager is not working presently, so that is adding to the frustration. After we get all the newbies in line to build RPM’s, then we’ll have to explain networking console commands…

OK, I was able to build madwifi rpm’s and bring atheros wireless up on my laptop. It’s a multi-step process, most of which is not intuitive. I’ll post steps later. Links to the rpms also. Check this post.

Right click, save link as …


Congratulations on getting the madwifi to work (via a rebuild). Looking forward to reading your “instructions”.

Are the rpms that you linked to the one’s that you managed to rebuild?

Yes, rebuilt on my machine. It will take me a few hours to post instructions. Will do before EOD today. Hopefully my ISP doesn’t have a coniption over bandwidth :).

Wow, you made my day. It works very well. Thank you. :slight_smile:


I also have the same problem with an Asus laptop I installed the
rpm’s what do I need to do next ?


The guide is here:
Atheros madwifi - openSUSE
Note you have already installed the rpms, so pick up from there.

Don’t forget to open a terminal/xterm/konsole and with root permissions type:
modprobe ath_pci

Then go into yast and configure your card.