Macbook Pro and Grub


First off I have looked through the forms and have not seen a clear answer to this question, and it seems I am not the only one have a problem with this.

I am using a Macbook pro 5,3 500gb hd. I am trying to set up my Macbook Pro 5,3 to dual boot with Suse 11.2. I have followed the guide posted:
Installation on MacBook/MacBook Pro Intel Core 2 Duo (x86) - openSUSE

When it comes to the part on bootloaders is where I am running into problems.
The guide and other guides suggest using LILO, however durring installation 11.2 when selecting to use LILO over Grub I get the following error “Not available at this time” (or something to that effect). I have browsed the install DVD and have seen the LILO rpm file in there so I am not sure why it says that.

So I proceed on to using Grub. I have it installed to my root partion as other guides mention.
Install works, finishes, and puts me into Suse (KDE Desktop) I then do a system reboot.
I am using ReFIT as the guide has mentioned to handle my boot options. When I select the tux icon to boot my suse install I get a black screen with no activity.
WHen I reboot and run the reFIT Partition tool I get the following out put:

Starting gptsync.efi

Current GPT partition table:


1 40 409639 EFI System (FAT)
2 409640 780674240 Mac OS X HFS+
3 780674240 784887705 Basic Data
4 784887706 976773134 EFI System (FAT)

Current MBR partition table:


1 1 409638 EE EFI System (FAT)
2 409640 780674238 AF Mac OS X HFS+
3 780674240 784887704 82 Linux Swap / Solaris
4 784887706 976773133 83 Linux

Status: Analysis inconclusive, will not touch this disk.
Error: Not Found returned from gtpsync.efi

So from this I am guessing that the fact that the GPT sees two EFI systems this may be one of my problems?
Although I have no idea how to correct this. I have looked on reFIT website for this error:
rEFIt - Documentation - Linux partition shows as EFI System

I tried removing the boot flag from my root partition and all this did was still present me with the same output as above, minus the line #4 of GPT stating EFI System (FAT) instead it read Basic DAta (same as line #3). And made the disk totaly unbootable even when run through the suse11.2 install dvd ---->boot from hard drive option.

SO to make a long story short, I can boot into my suse11.2 install only through the boot from harddrive option on the install dvd.

I have went through the grub settings and here is the outputs:
cat /boot/grub/menu.lst

Modified by YaST2. Last modification on Tue Jan 12 21:29:51 EST 2010


Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,3)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
root (hd0,3)
kernel /boot/vmlinuz root=/dev/disk/by-id/ata-FUJITSU_MJA2500BH_FFS_G1_K94FT9A28G72-part4 resume=/dev/disk/by-id/ata-FUJITSU_MJA2500BH_FFS_G quiet showopts
initrd /boot/initrd

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – SUSE LINUX
root (hd0,3)
kernel /boot/vmlinuz root=/dev/disk/by-id/ata-FUJITSU_MJA2500BH_FFS_G1_K94FT9A28G72-part4 showopts apm=off noresume edd=off powersaved=off ncstate=1 x11failsafe
initrd /boot/initrd

cat /etc/grub.conf

setup --stage2=/boot/grub/stage2 --force-lba (hd0,3) (hd0,3)

grub --batch </etc/grub.conf**

GNU GRUB version 0.97 (640K lower / 3072K upper memory)

Minimal BASH-like line editing is supported. For the first word, TAB
lists possible command completions. Anywhere else TAB lists the possible
completions of a device/filename. ]
grub> setup --stage2=/boot/grub/stage2 --force-lba (hd0,3) (hd0,3)
Checking if “/boot/grub/stage1” exists… yes
Checking if “/boot/grub/stage2” exists… yes
Checking if “/boot/grub/e2fs_stage1_5” exists… yes
Running “embed /boot/grub/e2fs_stage1_5 (hd0,3)”… failed (this is not fatal)
Running “embed /boot/grub/e2fs_stage1_5 (hd0,3)”… failed (this is not fatal)
Running "install --force-lba --stage2=/boot/grub/stage2 /boot/grub/stage1 (hd0,3) /boot/grub/stage2 p /boot/grub/menu.lst "… succeeded
grub> quit

To also note I have also tried to update reFIT and I am still not able to boot into my suse install.
So please let me know if you can see anything I have done wrong or am doing wrong. I am very much willing to learn, I just am not sure how to get past this point.

I have done plenty of dual boots on pc (BIOS)systems, and have never ran into anything close to this. And yes I know BIOS and GPT are different… I am just lost on this and any help is greatly appreciated!!

Thank you in advance,

:beat-up:One Lost Penguin:beat-up:

Are you trying to install a ext4 partition?
I heard LILO still has no support for it, try EXT3.
I am not sure on a link to a suitable GUI guide though… yet :smiley:
I know one for Ubuntu though, not like that helps however.

Re: Macbook Pro and Grub
Are you trying to install a ext4 partition?
I heard LILO still has no support for it, try EXT3.

Actually ya I am trying ext4. Hmmmm maybe I will try this again, and try with ext3 and LILO. I will give this 24hrs to see what other responses I get are. Has anyone got grub to work with suse 11.2 and macbook pro 5,3 or around that? Or should I try to redo with ext 3 and LILO?

But TaraIkeda thank you very much for your response! If I dont hear back from anyothers I will try this and let you know.

Have a good one!

:beat-up:One Lost Penguin:beat-up:

Well personally I see no harm with trying out EXT3, really there are no major disadvantages to using it as opposed to EXT4… actually I still use EXT3 a lot as I find EXT4 to have a number of bugs.
Its still new so for newer users EXT3 might be better.
The only major difference is speed, but otherwise EXT4 is not a security update or anything and its not essential to use it.
Heck EXT2 is still about.

I too have this exact same problem, and have not been able to get a clear answer. I am using ext3 file system, and when I try to select LILO as boot loader from the DVD install medium, I get “LILO is not supported?”
Also when I use grub and am not able to get reFIT to boot suse install. The only way I can get in is the same way as discribed above, I need to use install dvd and select boot from DVD.

Anyone able to give me so indication as to what I am doing wrong.

Thank you much

I’m having the same problem. Both GRUB and LILO installations leave me with "
Analysis inconclusive, will not touch this disk" in rEFIt and a boot screen that says “No bootable device – insert boot disk and press any key”.

Anyone got any further with this?

Specially while installing on a Mac, it is important to prevent Grub to touch the MBR (even activate a partition as it does by default), otherwise it will get desynchronized with the GPT. Do not just install Grub in the Linux partition! Also go in the Advanced boot options during setup and uncheck everything there. Forget about LILO! That was yesterday.

With Grub2 (shipped with Ubuntu) it should be possible in theory to boot directly and not use rEFIt at all, since it is supposed to support GTP. Never tried however.

I thought GRUB didn’t work with EFI systems. Either eLILO or rEFIt should work. I wouldn’t partition a Mac with anything other than Disk Utility (to change sizes/number). (Use parted to change types.) I think /boot needs to be ext2/3 for compatibility with most bootloaders.

For GRUB, I know Boot Camp makes an emulated BIOS/MBR. You might be able to leverage that.

OpenSUSE Grub (Legacy Grub) does not. Grub2 should (according to a CT’ article, but I didn’t test myself). You’re right. You should use Disk Utility to create a partition, then boot Linux and install Grub in the boot sector of this partition (an nowhere else!), also not activate this partition either. Grub will be only used to load Linux. The programm used at boot is rEFIt. It will let you choose between Mac OSX and Linux. Once you select Linux, it will pass the control to Grub.

Every Linux distro patchs Legacy Grub its own way and I’ve read in this forum that the one in openSUSE is capable of booting ext4 partitions. In that case, it would work on the Mac too. I personally don’t use ext4 on boot partitions for several compatibility reasons.

I tried this bu no luck, I’m still getting:

No operating system
No bootable device -- insert boot disk and press any key

I did:

# grub
grub> find /boot/grub/stage1
grub> root (hd0,2)
grub> setup (hd0,2)
grub> quit

rEFIt is installed and working but can’t do gptsync cause it still says:

Analysis inconclusive, will not touch this disk

I also tried using parted to sync the partition maps, tried installing without a bootloader at all, tried manually installing lilo (I purposely made my boot partition ext3) to no avail.

Has anyone actually got this working?

Okay all, I got it installed and working fine. The problem is both with the way openSUSE installer formats the partition and with the way it installs grub.

How I did it was to download the Ubuntu Jaunty (9.04) LiveCD and partitioned the drive with that (/dev/sda3 (ext3) as “/” root and /dev/sda4 as swap). I then booted using the openSUSE installation disk (Gnome LiveCD in my case) and installed but made sure not to reformat or modify the partitions and NOT to install a bootloader.

Once installed I rebooted into the Ubuntu LiveCD and from a terminal ran

# grub
grub> root (hd0,2)
grub> setup (hd0,2)
grub> quit
# mount /dev/sda3 /mnt
# vi /mnt/boot/grub/menu.lst

Into that I put:

default 0
timeout 10

title    openSUSE
root     (hd0,2)
kernel   /boot/vmlinuz root=/dev/sda3
initrd   /boot/initrd

I then rebooted the machine and Sync’d the partition tables through rEFIt and booted openSUSE (fails to boot the first time, just reboot).

Now it’s time for this.

Hope this helps others.

I noticed also that once you are booting successfully from the partition you can then use Boot Loader in YaST to install GRUB correctly (i.e. with normal boot options). Just make sure that you do not install it into the MBR (check disable “Install Generic boot code to the MBR” in Boot Loader Options) and only select “Boot from root partition” in the main screen.

Also, other hardware was installed according to this guide.

Like the original poster, I also have a MacBookPro5,3 that now runs OpenSuse 11.2.
I took the advice from this thread to use a live CD (Ubuntu 9.10) from a different distro to format the partitions, and then installed OpenSuse including GRUB legacy on a ext3 partition. However, rEFIt still gave me the “Analysis inconclusive” error, so I went back to the Ubuntu live CD, and removed the boot label from the grub partition with GParted, after that rEFIt synced my partitions without errors.

So my conclusion is that that “Analysis inconclusive” error might come from the installation of the bootloader, adding a weird boot flag to the partition, not the actual process of formating the drive as previously suggested in this thread.

If anyone who reads this thread used the partition tool in the OpenSuse installer and get this rEFIt error, try removing the boot label from your linux boot partition with GParted, and let us know if it works :slight_smile:

However, this wasn’t enough to get everything working. I got a black screen instead of GRUB when trying to boot OpenSuse, untill I had booted from the installation DVD (boot from harddrive option), and unchecked all of the boxes in the Bootloader section in YaST, including the “Boot from root partition” option.

I have spent the last month working on different ways of getting linux onto my macbook pro 1.1 ---- with different types of success— I have never tried to install a linux OS on my internal – I opt for using a USB drive —I use Refit on my computer because I have an XP partition on my internal and many different external clones------ Ubuntu will install --You must choose the USB disk for both the installation of filesystem and the Bootloader (this is described in great detail many places ------Refit will display a Linux icon------ Grub 2 menu shows up quick but the boot into Ubuntu takes a while (though once there it is solid) —

So I tried the same thing with OpenSUSE----- I pre-formated my drive with an MBR MSDOS Partition ---- then in the OpenSUSE installer I chose the USB drive for the install ---- and to Delete what it perceived as a ‘Windows Partition’ on the disk ---- Before install it was obviously key to change the settings on the bootloader — choose to create a Grub based bootloader on the USB drive ---- DIsable booting from MBR, and Root----

OpenSuse boots very fast — right after I choose Linux in the menu I see the Grub stage2 message and then right into the OpenSUSE splash —

My curiosity now is whether I could install Fedora without installing the bootloader and se OpenSUSE to boot other linux OS’s---- just some thoughts on the issue

This worked great for me on my MBP 1.1 — I know our chipsets are very different in someways —

Wow, it worked for me - so far.
The “status: analysis inconclusive…”-message is gone,
the hybrid-partition-table is synchronized again, out of nothing! :slight_smile:


I also got no running system in first place.
So I started my (Triple-Boot!) - System and booted up with the SUSE DVD inside - what happened?
Windows started instead of Linux!
After one or two tries of Windows reparing itself failed it suddenly got working after three new reboots, everytime I chosed Windows again from rEFIt Bootmenue - finally Windows booted up!
Mac OS X also booted up as the first system, didn’t get touched anyway it seems so.

I’ll test booting in Linux later on - I’m curious if it all worked after one week and four days followed by four nights of trying and testing! :slight_smile: