*.m4a files?

Hello everyone,

I wanted to ask which music player I should use to play *.m4a files. Any ideas?

And I can’t find skype for openSUSE anywhere, all the downloads are fawlty or can’t be installed anyway.

Please help. :slight_smile:


That’s not a question of players but rather codecs. When following →the genaral multimedia guide you will be able to play these files within Amarok, Kaffeine, MPlayer, xmms, whatever you want.


The general multimedia guide is worthless. The one-click install is worthless … sometimes it works … more often … it does not work!

It installs the packages, but there is something more fundamentally broken is OpenSuSE, I suspect somewhere in gstreamer, that makes the codecs a hit or miss proposition.

The only reliable method I have found for m4a playback is with mplayer/smplayer/gnome-mplayer with all the codecs (w32all, faac, faad, ad nauseum). Banshee/Rhthmbox/Amorak … they might work … they probably will not. This true of at least the last three OpenSuSE releases.

Anyway, I am going to post a new question along these lines …

oxala, what you write here is just plain wrong - please don’t spread personal experiences as general truths. Enabling restricted formats as described in the guide does work, I have literally done so dozens of times on many different machines and it never failed.


I have had numerous failures and successes on multiple boxes across multiple OpenSUSE releases. Perhaps I am simply disliked by the dieties of restricted formatting … but more likely … my experience is an indication that there is an actual problem.

I will apologize for overstating the issue (venting my frustration) and indirectly insulting the hard work behing the wiki … indeed the quality of documentation is one OpenSUSE’s greatest features.

Well the real issue could be is they are packaged by a third party…
you might also ask your questions on the packman IRC channel?

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 0:19, 2 users, load average: 0.06, 0.08, 0.08
GPU GeForce 8600 GTS Silent - Driver Version: 256.35


The REAL issue is the ludicrous state of patent and copywrite law that exists in the United States … and is slowly being driven onto the rest of the world … which is why Novell, Red Hat and others must rely on third party packaging to get basic features into the OSes.

And I do think gstreamer is foobared in openSUSE … just use FC13 for a few hours to see how gstreamer is supposed to work … to see what I mean … try to use ANY colometer with gnome-color-manager to create a monitor profile. BTW … I did file a bug report.

I use fluendo codec bundle and the dvd player here with openSUSE and
SLED so not an issue for me (two rpms to install and I’m good to go) :wink:

Just tried gcm on my netbook, played with it and it seems to work fine.
Maybe a post on what’s not working and perhaps attach a profile to try?

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 1:56, 3 users, load average: 0.51, 0.18, 0.12
GPU GeForce 8600 GTS Silent - Driver Version: 256.35

(quick for the impatient: yast/zypper may not install the correct versions of the packages selected by “one-click” or zypper. Reinstall ALL required packages (see restricted codec install guide) manually in yast … make SURE/DOUBLESURE/TRIPLESURE you got the LATEST from packman)

Hello Malcom,

Hee hee … I knew I should have posted in the special single topic per thread not allowed forum … Yes … gcm works … the gstreamer/pkgkit backend does NOT! Plug in a colorometer and try to create a profile … the system behaves as if it is going to install the required cms software … but it does not install anything … it pops up runs an install message and drops back to gcm. Then click on “Create Profile for Device”. … the system behaves as if it is going to install the required cms software … … ad nauseum.

Do the same in FC13 … the needed software is installed and the colorometer is reading sample patches in a matter of 2 mins or less … it’s awesome! This is an example of how gstreamer/packagkit are supposed to work together. What I expect from OpenSUSE (assuming the third party repos have been added due to living in a pre-revolutionary political state) … gstreamer should pop a pkgkit window … do u want to install this junkware? … ok … cool … click … Lady Gaga annoying the dogs again … awesome!

And while my rant seems to encompass multiple topics, it is actually one topic … something broken in OpenSUSE that manifests itself across multiple applications … and part of this brokeness falls squarely on the integration (or misintegration) between yast/package-kit/gstreamer. My gcm excercise is simply an example, an easily repeatable example … one manifestation. The inconsistent results obtained by doing something seeming simple … install packages X,Y, and Z so that m4a playback will work in gsteamer based apps may be another example. I just “solved” my problem … ryhthmbox is playing m4a’s.

The solution, I went into Yast, to double check myself yet again … and chose to view by repository … and clicked on packman … clicked the “replace everything with packages from this repo” button. I was shocked, everything I just installed was being installed again … after having installed from zypper twice in the last 24 hours! Did packman update every package in the repo since I had dinner? … It appears that zypper was not installing the same versions of packages as Yast. I definitely had a similar issue with at least one 11.2 installation.

zypper repos --detail

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | download.opensuse.org-standard | Main Repository (Contrib) | Yes | Yes | 99 | rpm-md | Index of /repositories/openSUSE:/11.3:/Contrib/standard |
2 | download.videolan.org-SuSE | VideoLan Repository | Yes | Yes | 110 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.3/ |
3 | packman.inode.at-suse | Packman Repository | Yes | Yes | 90 | rpm-md | Index of /suse/11.3/ |
4 | repo-debug | openSUSE-11.3-Debug | No | Yes | 100 | NONE | Index of /debug/distribution/11.3/repo/oss |
5 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.3/repo/non-oss |
6 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.3/repo/oss |
7 | repo-source | openSUSE-11.3-Source | No | Yes | 100 | NONE | Index of /source/distribution/11.3/repo/oss |
8 | repo-update | openSUSE-11.3-Update | Yes | Yes | 100 | rpm-md | Index of /update/11.3 |

So here is the issue as I understand (or more accurately, don’t understand) it. Go to the multimedia install guide … follow the instructions … it might work … it might not. Go to one-click install … might work … might not. It seems that the codecs were not working for me because I installed only once from Yast instead of twice ??? I used yast and zypper and rpm to verify that the packages were installed. And in the end … I really don’t know what WAS installed …

I know some version of the required packages were installed. I verified the packages one by one with rpm -q. ( I only verified the names as I knew I had yast configured correctly … I assumed yast/zypper would work … I assumed that the correct version of the packages would be installed … e.g. the latest in packman … not 2 years old from packman …)

I know that the installed versions were NOT the versions that should have been installed based on the repostitory priorities I created in Yast.

I know that I have had this problem before … and been surprized to find the versions of software on one box to be very differnt from the next box even though Yast package manager had been configured identically on the 2 systems.

I know that if I add the fusion repo in FC13, I don’t have to look at yast, zypper, yum, rpm, forums like this, package names, package versions, bash shells, crystal balls, or anything else more complicated than a little button with “OK” written in the middle … it’s awesome!

If it ain’t that easy, it’s a BUG!

BTW, I suspect I’m observing the continued fallout from SUSE’s “we have a new package management system” every 3 weeks phase

This really isn’t fun,


If you had actually followed the guide you wouldn’t have VideoLan repo still enabled


I usually install libdvdcss and remove it altogether … :slight_smile:

It’s just you are complaining my guide doesn’t work, but haven’t actually followed the instructions.
I use my own guide to install multi-media and it always works
(Admittedly, depending on ones install there are sometimes issues to work around. Gnome installs may require the removal of transmission-common for Eg,)

Hello Bro,

I wish I had taken an extra minute to read what I had actually written. I sincerely apologize! I really mean no insult to you or the good work you have published. What I meant, and should have written clearly, is that following the guide may not create the desired result. In writting this, I am not denegrating your work. I am trying to identify the variable or variables not addressed by the guide. I am trying to understand why installing package X does not allways yield result Y. If the packages enumerated in your guide are installed, m4a playback should work … 100% of the time.

There is a nasty little bug hiding in here somewhere … just not sure if it’s in gstreamer, zypper, yast or in the integration of these components.

Take care,


Sometimes you will have to manually make selection of Packman for supply this way, particularly for gstreamer
ImageBam - Fast, Free Image Hosting and Photo Sharing

or in gnome
ImageBam - Fast, Free Image Hosting and Photo Sharing