Lutris, Wine and Freetype2

Hello everybody, I was searching the net a whole long time for this issue, even created an issue on the offical github page fro lutris but didn’t got any help there.
Here is the situation:

After an update from lutris 0.4.18 to 0.4.19 and also with 0.4.20 I have the following issue:
Every time I want to launch a winesteam or wine game trough lutris it tells me that freetype2 2.0.5 or higher need to be installed in order to make wine render fonts. (And it really do not render fonts)
The thing is I’m unable to find a freetype2 package for openSUSE is there any one or is it included in some other package?
Further on if I launch wine which is installed in my system there are no font issues nor any message about a missing freetype2 library.
Also if I use the lutris prefixes as wineprefix for my system side installed wine I get no errors and everything seems to be okay.
Further on this issue first appears after an update from 0.4.18 to any newer version of lutris.

Is any body familiar with this issue or know any solution?
Is there any freetype2 package I can install and if yes, where do I find it?
I search also software.opensuse.org for this package and also found repositories which claim to have a freetype2 packed but if I add the repo via One Click Install or manually there is no freetype2 package available.

Thanks in advanced,
Vortex

Hi
It’s there as libfreetype6 at version 2.9, seems lutris has no requirement of libfreetype…?
https://build.opensuse.org/package/binary/games:tools/lutris/openSUSE_Leap_15.0/x86_64/lutris-0.4.20-lp150.1.1.noarch.rpm

Sounds more like a wine issue with the game your using.

The problem persist with any wine version I use via lutris, even 3.7 which is also installed in my system.
And also I played a lot of games with lutris and wine and after the update everything was broken so I’m not sure what this is all about =/
So it seems a problem with lutris launching wine or setting environment variables don’t know.
But as said I asked the lutris dev team for help but didn’t received any help yet.
So I search for this “missing” package and finally wrote this post.

Okay, checked, libfreetype6 was already installed both 64bit and 32bit.

Hi
So what is the game in question? Never used lutris, but happy to try it out…

For me this issue persist with any winesteam game.
If you launch lutris via console and run an installer from the website https://lutris.net/games/
I tried The Turing Test, Space Colony.

Since the latest update of lutris (0.4.20) I’m not even able to run any installer which uses the winesteam runner in lutris. So basically I can not run nor install any windows steam game through lutris. =/

Just right now, for my answer to you, I tried this installer https://lutris.net/games/path-of-exile/ and lutris do not even install it … I’m still not sure if it’s just a lutris problem or if there are any packages missing lutris won’t tell me about. =/
Path of Exile is, as far as I know, Free to Play, that’s why I choose this one to test the current state of lutris.
I tried to ran the “Steam w/ DXVK version” the last one in the list.
Also lutris stuck on downloading the SteamInstall.msi at 4 seconds remaining.
After killing it and rerun the install script lutris stuck at “Installing Game Data”.
The same behavior goes for the 2nd last installer “Steam version”

If I run any of my previous installed winesteam than there is the FreeType issue.
I’m totaly confused and I wonder why I’m the only one complaining about this issue and feel like I’r my the only one expecting this ._.

Fyi the github issue I created: https://github.com/lutris/lutris/issues/1096

Thank you for taking the time helping me :slight_smile:

On Tue 09 Oct 2018 04:36:03 PM CDT, VortexAcherontic wrote:

For me this issue persist with any winesteam game.
If you launch lutris via console and run an installer from the website
https://lutris.net/games/
I tried The Turing Test, Space Colony.

Since the latest update of lutris (0.4.20) I’m not even able to run any
installer which uses the winesteam runner in lutris. So basically I can
not run nor install any windows steam game through lutris. =/

Just right now, for my answer to you, I tried this installer
Path of Exile - Lutris and lutris do not even install
it … I’m still not sure if it’s just a lutris problem or if there are
any packages missing lutris won’t tell me about. =/
Path of Exile is, as far as I know, Free to Play, that’s why I choose
this one to test the current state of lutris.
I tried to ran the “Steam w/ DXVK version” the last one in the list.
Also lutris stuck on downloading the SteamInstall.msi at 4 seconds
remaining.
After killing it and rerun the install script lutris stuck at
“Installing Game Data”.
The same behavior goes for the 2nd last installer “Steam version”

If I run any of my previous installed winesteam than there is the
FreeType issue.
I’m totaly confused and I wonder why I’m the only one complaining about
this issue and feel like I’r my the only one expecting this ._.

Fyi the github issue I created:
FreeType issue with wine after update to 0.4.19 and above · Issue #1096 · lutris/lutris · GitHub

Thank you for taking the time helping me :slight_smile:

Hi
I see the same thing here, it seems to me is something funky with
libfreetype6-32bit rather than the lutris application.

Might get some time over the weekend to investigate more.


Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.19-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Thank you so much!
I nearly gave up in getting any help.
Finally it was a good decision to ask here :smiley:

By the way, the lutris issue can be found here: https://github.com/lutris/lutris/issues/1096

bump

Any news here?

Hi
Not really, There is an update for lutris to 0.4.21 yesterday, have you tried that one from the games:tools repository?

@Vortex : while it’s not a fix there was a workaround to this problem - right click on the app icon in Lutris, go to system options and uncheck “Prefer system libraries”.

Yesterday’s update on Opensuse broken Vulkan detection on my end - now Lutris claims Vulkan loader is not present if I use DXVK. But if I choose to ignore this warning everything works (Vulkan demos and dedicated Vulkan apps work as well).

@malcolmlewis
Yes, alos tried just now version 0.4.21.1-lp150.1.1 and the issue still persist.

  • No Fonts in wine (Still FreeType 2.0.5)
  • Unable to install any wine game or wine steam game through Lutris. (No error message just spinning the loading icon forever)

@Pshemas
Thank you!
This solved the font issue for already installed games but as described above Lutris refuse to install new wine games or wine steam games.

@Vortex : have you tried starting Lutris from the terminal? You could see some extra hints there.

I just wanted to chime in and say that I’m having the exact same issue on Leap 15.

I was trying a few other simple, potential solutions, and I was finally able to install battle.net.

I installed MS truetype fonts from this link: https://software.opensuse.org/package/fetchmsttfonts (I don’t know if this helped, but it can’t hurt)

I then reinstalled Lutris, made sure the “Prefer System Libraries” box was unchecked, and it just worked.

Hey there!

I just tried Lutris today, after a few week.
And the issue was somehow fixed in the past, I don’t know if it was by any openSUSE Update or Lutris.
Currently I’m running Lutris 0.4.21.1.

@Pshemas yes, I did but everything which was written down in the terminal was the FreeType 2.0.5 issue otherwise I would not have even knew about this problem.

So I think this issue is somehow solved?
To anyone else who faceing this issue, try Lutris 0.4.21.1.

Can anybody confirm this to me so I can be sure that there are no other things involved in this?

Can it might be that some NVidia drivers could cause/fixed this issue?
That the only big thing, beside L
utris 0.4.21.1 I remember in the last weeks.
I’m running the proprietary NV driver 410.73.

  • Running Lutris installers works.
  • There are fonts in any wine windows and winesteam.

The strangest thing about this is, that the terminal output still claims “Wine cannot find the FreeType font library. To enable Wine to use TrueType fonts please install a version of FreeType greater than or equal to 2.0.5.” but fonts are there.

Aaaand it seems broken again:

Ran Lutirs (0.4.23) on my notebook:

OS: openSUSE Leap 15.0 (4.12.14-lp150.12.25-default)
CPU: Intel i5-3230M
GPU: Intel HD 4000 and GT 730M (Bumblebee installed with NVidia driver: 410.73)
RAM: 8 GB

And got all issues again, even with a clean Lutris config folder.

Battle.Net dose not have any fonts.
And winesteam games do not even install.

But I’m not sure if this is caused with the latest lutris updates or the software/hardware configuration on my notebook.

Further on I can currently not test it on my main rig to confirm if it is broken again there.

I tested Lutris with and with out optimus/primus with no difference.
(Optimus/Primus is setup correctly and fully working).
Need to check later on my main PC

seems to work again, after running in terminal “export TERM=xterm && lutris” lutris is again able to run its install scripts due to an sub process they running which fails at any warning like terminal color 256 ot something similar.
Exporting xterm fix this.