Lost root password response, then only boots to black screen


I suddenly lost root password access to anything - no matter in what dialog; response was “incorrect password” or some variation of same.
When I tried re-booting, it came back up with a black screen with the cursor in the center and a small white “dash” at the top-left corner.

I tried hitting “Esc” during the boot process to see the messages as they raced by and did see this:

Network Manager is not active
Dependency failed for Network Manager Wait online

The last entry in the list was:

Starting /etc/init.D/boot/local Compatibility…

I have no way to test anything, no gooey, no konsole, no response to keyboard so no Ctl-Alt-F2, nothing. I’m connected to the forum right now by using an opensuse13.2 live disk (Long live the Live Disk! I wish we still had one for the newer opensuse versions).

I have no clue as to what to do next, currently thinking a full re-install, but if there is any other way…

Any suggestions appreciated…


I hope that helps:

What was the last thing that happened before “suddenly lost”? How old is your installation?

Try appending a 1 or an S to Grub’s kernel cmdline after splash=silent or quiet or showopts by first striking the e key when the boot menu appears. That might let you log in in single user mode. If that works, you might next try a normal reboot, but if that fails, try appending a 2 or 3 instead of 1 or S.

Thanks, guys. Going off-line now to try suggestions. Means killing the “live dvd” and if nothing works, re-booting the dvd and re-installing LastPass before I can get back into the forum. So here I go, fingers crossed, etc.

Will be back when I can…

Hi Mr. Mazda:
I’m not exactly sure. System seemed to be “slowing down”, taking longer to process things than usual.
I recently added a 2-TB SATA disk and was having some problems with formatting and mounting - finally got that to work, but don’t see what that might do to affect booting to this degree (no boot at all).
System has been running just fine since several months ago when I went from 13.2 through 42.1 and 42.2 to 42.3. Been a few burps, but I don’t really remember.

Appending the “S” worked, got me to a command prompt - but I haven’t a clue what to do when I’m there.
Can you give me a list of things to try once there? I have only very basic knowledge on the command line - “pwd”, “ls”, etc. and must go through the boot-to-DVD/log-in to LastPass/log-in etc. every time, to get back into the forum.
I did see that the last thing that was listed as it was trying to boot was “started locale service” - nothing after that.

I’m not sure what to tell you to do. Someone more familiar with how the login process works and how it can break may need to supply that if the next thing I suggested and you didn’t respond to doesn’t work (2 or 3 instead of S or 1). If 2 or 3 does allow you to login, then try

zypper ve

to see if some installed package related to logging in is found broken and zypper can fix it. Also, provide the output of

rpm -qa | grep dm

Only one of the following in that output should be relevant: gdm, lightdm, kdm, sddm, kdebase3-kdm or xdm. Whichever is returned might provide a clue. Other clues might be found in output of the following:

# journalctl -b -1 | egrep -i 'failed|error|pam'