Lost HP printer driver after recent on-line update

Hello, everyone. Using SuSE 11.0.

Yesterday I did an update using the software management feature in YaST. As everything was flying by I am pretty certain that I noticed something about “hpijs.” Didn’t pay it much attention until I tried printing today and found that my HP1320n would not print anything – lights did not flash and could not print test pages.

It was as if the printer were no longer installed. So I reinstalled it and found that the driver I had been using was no longer there, and the only available drivers don’t give me the resolution flexibility I need.

The driver that had been installed and worked perfectly for my needs was:
HP LaserJet 1320 Foomatic/hpijs, hpijs 2.8.4.2

With that PPD file I could get 300 and 600 dpi resolution which was great since I do a huge amount of draft printing and the 300 dpi setting used very little toner.

However, now the only drivers I seem to be able to get are:
HP LaserJet 1320 series Postscript
and
HP LaserJet 1320 series Postscript (recommended).

Both of these drivers only offer 600 and 1200 dpi resolution, so they consume way too much toner for my draft needs.

When I look at the software management in YaST I see that I do have the following installed:

hplip-hpijs 2.8.4-28.1-x86_64 from repo-oss

So, after all of that background explanation I am completely stumped as to how to get back that driver that worked for my needs. This should be simple, but what am I overlooking?

Thanks :wink:
socref

Forgive me if you’ve tried these things already, but I would try checking the CUPS config via http://localhost:631/

Is it still reported as present? If so, try a printing a test page. If not, adding the printer back again via ‘Administration’ tab. Also, have a look at this brief HOW TO, which mentions the hp-setup utility (run as root).

This thread may also offer a useful insight:

Open Suse 11.0 HP printers - openSUSE Forums

Any HP printer gurus out there?

deano, thanks for reply. I looked at all the resources you provided, but none helped. me. The problem is NOT with the printer. It is working just fine.

The problem is that I can’t find a driver with less than 600 dpi resolution, so I can’t print drafts. The driver that I had installed prior to the recent YaST update (HP LaserJet 1320 Foomatic/hpijs, hpijs 2.8.4.2) is not in the list of available drivers (in the HP setup utility you reference above) when I try to configure.

Anybody know where I can find that driver or another that will allow 300 dpi resolution?

Thx!
socref

socref,
When I used 11.0 I found it was best to go here:
HP Linux Imaging and Printing
Follow their instructions there are screenshots.

Sagemta, thanks for the reply. I have already been to that HP site. Unless I missed something there I could not find the driver I need. Did you see it there?

Can anyone point me to the specific driver I cited or to any other driver that will give me 300 (draft) dpi resolution using the HP1320n laser printer?

Thanks.
socref

HP LaserJet 1320 driver

OpenPrinting database - Printer: HP LaserJet 1320

Google for “driver HP1320n linux” yields about 4600+ posible links. If it still exists, should be there.

similair problem with the hplib update on a 2175, printer no longer worked, deleted it in cups so all was clean again, added it via the hp tool and it was there and I could print… but only what I think is letter format. deleted it again, added it via cups, printer looks fine, test print however is again only what I think letter format, its exactly one corner of the A4 page.

I did update the paper format to A4 in cups as it was letter by default but made no change, extremly anoying

I went back to a backup of about 2 weeks ago, which still uses hplip 3.9.4b which uses the hlip-hpijs which gets replace by hpcups when you upgrade to hplip 3.9.6. Printer works fine again, now just updating all but hplip. I think I was wrong about it being letter format, it was just 50% of A4.

Not sure if its cups or hplip causing it though.

Xilanaz, unfortunately I only have backups of my home directory, so no saved versions of hplip 3.9.4b :cry:

Do you know of anywhere I can find 3.9.4b?

Thx.
socref

Jrholtg: Thanks for the suggestions. The first link appears to be only Windows drivers. I looked but saw nothing for Linux.

The second link is for downloading hplip 3.9.6, but I already have that on my computer.

I have searched and searched and still cannot find the Foomatic driver that allows 300 dpi (draft) printing.

Gads, this is so frustrating.

socref

Socref,

Packman only seems to have the new one PackMan :: Package details for hplip
Hplip site itself seems to cleanup old downloads also
RPM Search shows a few version, not the 3.9.4 unless you have suse 10.x then its there (RPM Search hplip-3.9.4b-15.pm.11.i586.rpm), might work, might not.

I am not sure but what you could do is go to yast and instead of selecting the 3.9.6 from packman select the 2.x version of the default suse repository, its a big step back but I dunno how else to move backwards.

Hi, again. I did find something on the HP site that says it’s 3.9.4b, but I don’t know if it’s really what I need.

I put this folder (named: hplip-3.9.4b) into /usr/share/doc but now I don’t know how to integrate it with my setup to access whatever drivers might be in there. There are 17 folders and a bunch of miscellaneous files.

If I open the ppd folder and then the hpijs folder I can see what I think are drivers (.gz files). But I don’t see anything that says Foomatic. Same thing if I open the hpcups folder – lots of .gz files but nothing I can see that says Foomatic.

Thoughts? Am I looking in the right place?
socref

sorry am to new to this to answer you that, but I would think that with hpijs uninstalled by hplib 3.9 and hpcups installed it would requiere more then copying of a folder over ?

I would go back to the opensuse repositry 1st and see how that goes, if it fails simply enabled the hlip from the packman repo and you should be back in the current state ?

Soc,
When I did that it was self installing go to the site & read the screenshots. It’ll show you what to expect & give you an idea how it’ll look.
You don’t need it in the folder you have it , I did mine from Desktop. The thing is designed to see your system & do all the hard work for you. That’d include getting the driver for you.

Thanks to everyone for the help. I tried the suggestions but just could not get a driver that served my purpose. Maybe I was doing something wrong, but it just seemed as if I was not getting anywhere close.

However,I did find a solution to my problem, though it seems to be an untraditional way of getting what I wanted. rotfl!

In YaST I tried adding various drivers for an HP Laser Jet 5P printer. Eventually I found one that worked with my Laser Jet 1320n! It is:
HP LaserJet 5p, hpcups 3.9.6.54 (manufacturer-PPDs/hplip/hp-laserjet_5p.ppd.gz).

Using this driver I can get draft quality and best quality, so it solves the problem even if it’s not a driver meant for my model printer.

All’s well in the end. :slight_smile:

Thanks again, everyone.
socref

One of the best things about Linux is there’s more than one way do things. Something you learned & me too. I hope you like & stay with Linux in general, Opensuse in particular.
Hope you enjoy the journey!:wink:

not sure if this helps yo socref, but as its saturday I figured I tinker a bit more with the hplip stuff.

noticed a new update 3.9.6b and also a new version on packman so removed current printer in yast, installed 3.9.6b via packman, started it, came up with a dialog that there was no printer, click the setup button, did that part, entered root login stuff when it asked for it and printer was added.

test page was again 25% of A4, so visited the hplip support site link via the link listed under actions. Here I found:

https://bugs.launchpad.net/hplip/+bug/392040

so in the hp device manager, when to printer settings, general tab, scrolled down, changed quality from normal (which was the default) to draft and fixed.

things are so easy when you don’t rush them :slight_smile:

Have you tried setting it up from the hplip setup?
Open a terminal and run hp-setup as root.
If the printer is connected locally, it will find it immediately.
I find this the most reliable way to set up my jetdirect networked hp printers.
Once setup, you can modify it in yast and cups server.

Hi again. Sorry, but I don’t seem to be able to do what you suggest. By “hp device manager” do you mean the first screen after running <hp-setup> in the console? If yes, I’ve done this repeatedly (as both user and root) without any success. Where is the screen “printer settings” you refer to? I don’t see it, so I can’t get to the “general” tab you reference.

Can you give me step-by-step instructions? Maybe I’m just clicking past something and not realizing it? Or maybe I’m in the wrong place.
Thx
socref

Hi, thanks for reply.

Yes, I’ve tried hp-setup as both user and root. Can’t make any progress. When I get to step 3 I cannot go forward. My only options (lower right corner) are: back, add printer, and cancel.

If I click on add printer as user I get a box that says I don’t have permission to add a printer. I then put “root” and the p/w and the window closes.

If I try hp-setup as root the window also closes as soon as I try to add a printer.

Finally, how do I modify in YaST and the CUPS server? Where do I do this?

Thoughts?
Thx
socref