Lost Chameleon and freezed screens

cheers folks!

I managed to install tumbleweed. Very nice!

But I disliked the desktop environments available at stock.
So I tried installing cinnamon after the KDE Install.
I rebooted and checked and…end of story…I do not like it.

I removed it but two things were to experience:

  1. in the left corner of the screen is a small chameleon picture.
    this was removed by a small gear. even within the boot process the chameleon is gone.
    gears showed up(25th anniversary or something like that) in the screen instead of the light bulb with the chameleon in it.

2)I was able to choose in the login screen between wayland-kde, X11-kde and IceWM… where the heck did wayland and IceWM came from?

Now the big problem.
Every time I logged in…the screen freezed… I had to power off by shutting manually down.
Then …and just then… the login process was possible.
Is this a known bug or related to the desktop environment change mentioned above?

Wayland is supposed to be a replacement for Xorg. For some people it works, mostly Gnome users. For most of the rest of us, it’s broken in one way or others. I don’t think it’s possible to eradicate it. IceWM for most people amounts to a fallback, something to use if your main DE or WM is broken. It takes a rather trivial amount of resources, and is what you get when you ask for a minimal X environment during installation.

Ah OK… Wayland and icewm always have been there… Didn’t see it.

First question remains.
Why did the chameleon dissappear from
the startup screen and from the toolbar or taskbar in the left corner?
Something that could have been fixed manually?

it seems no one knows what happend…

The developers no doubt thought a new look was needed… :wink:

You could modify the existing theme if you were so inclined, then save it as a new theme.


The images in question are:

“bulb.svg” and “busywidget.svgz”

If you wanted to go the whole hog, take a look at:


and from the toolbar or taskbar in the left corner?

The icon used there can be selected. (Configure application menu Alt+D, S)

Thanks 4 the reply! =)

Anyways, why did this dissappear in the first place? I just installed another pattern/desktop environment… Which in fact I deleted shortly after having it installed.
So… Normally the original condition/layout /design or what ever you want to call it
should reappear… But it did not…
What went wrong?

Possibly you inadvertently removed more than you intended to?

sudo cat /var/log/zypp/history | grep -i remove | more

should show you what was removed.

My suggestion is that when you installed an extra pattern to try out another desktop environment and then decide not to use it anymore, to do just that: do not use it anymore. And not try to de-install the pattern.

Remind that a pattern is just a list of packages that are needed for a purpose. That means that that list may well contains packages that are also needed for other purposes. Thus removing all in that list may create havoc.

E.g the patterns KDE and LXDE both have the package MozillaFirefox in the pattern list. Thus when you go and remove all in the pattern LXDE, your KDE will have to live on without Firefox.

Ok a little update on that topic.
I installed a completely new tumbleweed.
Did nothing but installed htop and btop.
Then I did a restart.
The gecko in the left corner disappeared and the loading(?) screen with the gecko light bulb as well

The Pic in the left corner can be re-added by just changing it. Nevertheless I cannot find it.
does anyone know the name of the Picture/logo that comes with the first install?

Secondly the loading (or splash) screen with the light Bulb is not restoreable.
Does anyone got a step by step “how to do” for me?

Still don’t understand why this happens at all…


Secondly the loading (or splash) screen with the light Bulb is not restoreable.
Does anyone got a step by step “how to do” for me?

You’ve not stated your desktop environment…

For KDE: “System Settings -> Startup and Shutdown -> Splash Screen - openSUSE”

For other environments, I’m afraid I don’t know.

Still don’t understand why this happens at all…

You are not alone, I’ve never seen the behavior you describe…

mystery solved!

It all is connected to the change in the theme.

Breeze, Dark Breeze, Breeze Twillight and Opensuse

are the 4 themes available.

Strangely when Choosing dark breeze, the above mentioned effects take place…
changing of left corner icon and splash screen.

Is there a possibility to use the dark breeze theme and not change the splash screen?

it does look a bit different.
I will try to make a screenshot tomorrow

I am very sorry. I think I read over.
I apologize!
You are right. I am using KDE

I have to update again.

It now comes into my mind that this obscure change in
-splash screen
-logo left corner

just appears on one of my laptops.

I remember switching the “normal” Theme to the dark Breeze theme on the other one without having such
changes… Maybe somethings wrong with my laptop.

If anyone has any idea what happened, I would be happy to provide specs