Loss of resolution on Intel DG41RQ onboard video with upgrade to opensuse 11.4

I have a system with the following hardware: Intel DG41RQ motherboard using the onboard video card connected to a Dell E198WFP monitor with a VGA cable. The monitor’s optimum resolution is 1440x900. From the Intel website the motherboard uses the Intel® Graphics Media Accelerator X4500 integrated graphics subsystem
Intel Overview of Motherboard

I had been using opensuse 11.1 for years with this resolution. I recently did a clean install of opensuse 11.4 with the opensuse 11.4 KDE Live CD. After the installation the 1440x900 resolution was achieved. However, I performed an online update and performed a reboot. Now I can’t set the resolution to 1440x900.

From Yast I can tell that I’m using the xorg-x11-driver-video packages for the driver, I’ve also tried the xorg-x11-driver-intel-legacy package too with no luck. In each case of trying out the different drivers, I’ve uninstalled the package for one driver while installing the other. When I used the intellagacy driver the video card put out 1440x900 but would not boot into KDE and only allowed me to use the shell.

Another detail is that when I ran

hwinfo --framebuffer

I get

02: None 00.0: 11001 VESA Framebuffer                           
  [Created at bios.459]
  Unique ID: rdCR.jJ3fwnr3DKA
  Hardware Class: framebuffer
  Model: "Intel(r)Eaglelake Graphics Controller"
  Vendor: "Intel Corporation"
  Device: "Intel(r)Eaglelake Graphics Controller"
  SubVendor: "Intel(r)Eaglelake Graphics Chip Accelerated VGA BIOS"

However, a google search for “Eaglelake Graphics Controller” it suggests that the Eaglelake Graphics Controller is used on Intel Q43/Q45/G43/G45 chipsets. But my motherboard uses the G41 chipset right? Is the wrong chipset being detected?

Also

hwinfo --gfxcard

returns

12: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.318]
  Unique ID: _Znp.+JeAsgunOB3
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel 4 Series Chipset Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x2e32 "4 Series Chipset Integrated Graphics Controller"
  SubVendor: pci 0x8086 "Intel Corporation"
  SubDevice: pci 0xd613 
  Revision: 0x03
  Memory Range: 0xd2400000-0xd27fffff (rw,non-prefetchable)
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  I/O Ports: 0xf140-0xf147 (rw)
  IRQ: 43 (no events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00008086d00002E32sv00008086sd0000D613bc03sc00i00"
  Driver Info #0:
    **Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"**
  Config Status: cfg=no, avail=yes, need=no, active=unknown

Primary display adapter: #12

Is the i915 driver correct for my motherboard’s onboard video?

On 01/08/2012 06:26 PM, speed301 wrote:
>
> I have a system with the following hardware: Intel DG41RQ motherboard
> using the onboard video card

-=WELCOME=- new poster!

i can’t tell from your post if you found this info, or not:
http://tinyurl.com/84sed5s

if you have not seen it before, is it helpful?


DD http://tinyurl.com/DD-Caveat
openSUSE®, the “German Engineered Automobiles” of operating systems!

Yes, I’ve seen that post and I’ve tried installing sax3. When I run sax3 it doesn’t present the 1440x900 resolution that I want. So that’s probably not the solution. That post also references explicitly setting the xorg-x11 driver to “intel” with conf files. I did not try that because I’m pretty sure that that is already set automatically. Are there perhaps more advance options I can put into a conf file to configure the driver for 1440x900?

I couldn’t use sax2 because it is deprecated, however I was able to use

sax2 -r -m 0=intel

to get 1440x900 resolution when I was setting up my system on opensuse 11.1.

One thing I didn’t try was installing an Intel proprietary driver. I’d like to try the iegd driver. But I’m unsure of which driver to download from the Intel website. Also what do I do once I have the correct driver.
Intel® Embedded Graphics Drivers

Can anyone confirm the Intel Q45, G41, G45 Express Chipsets is the correct architecture to use along the driver download for Linux Fedora? There is no download for SUSE. Is there an opensuse repo for the iegd driver?

The i915 driver is likely correct, but I’m not 100% certain on that.

Before providing any suggestions, can you please provide some more information ?

You say you can no longer boot to 1440x900. What resolution do you get ? What desktop are you using ? KDE ? Gnome ? Yes it may make a difference.

Please can you send the following command and post here the output:


xrandr

Also, please can you send this command and post here the output:


/sbin/lspci -nnk | grep VGA -A2

… also, can you please open the file /var/log/Xorg.0.log with a text editor, and copy the contents, and paste the contents into the pastebin site SUSE Paste and press ‘create’ and post here the website that you are given where that paste is now located ? That may provide us some more information as to what is going on.

How did you you configure your system to use the “intellegacy” driver? For example, If you didn’t edit /etc/X11/xorg.conf.d/50-device.conf, you may have ended up using the basic “fbdev” graphics driver that probably only delivers 1024x768 resolution, and perhaps your monitor can’t properly display that resolution.

That shouldn’t be necessary!

Yes, i915 is the kernel module of the “intel” driver, and also of the “intellegacy” driver (which is now a much older version of “intel” driver and only made available by openSUSE).

If you haven’t already, I suggest you read 11.4’s Release Notes (available via YaST). It will explain what happens if kernel mode setting (KMS) fails to properly detect your graphics card and load the “intel” driver, i.e. you will get “fbdev”. You can see what graphics driver is actually being loaded by looking through /var/log/Xorg.0.log, and a new log is written on every reboot.

I’m using KDE and the resolution I am presently using is 1280x1024 24bit.


xrandr

returns


xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1280 x 1024, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024      77.0* 


/sbin/lspci -nnk | grep VGA -A2

returns


00:02.0 VGA compatible controller [0300]: Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e32] (rev 03)
        Subsystem: Intel Corporation Device [8086:d613]
00:1b.0 Audio device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 01)


My /var/log/Xorg.0.log is at SUSE Paste

Ok thanks, I see your PC has 1280x1024 resolution from both your post and the xrandr command, and from the Xorg.0.log file that your PC is using the FBDEV graphic driver NOT using the Intel graphic driver.

Some details, when I look up device 8086:2e32 it tells me this is an Eaglelake Integrated Graphics Controller.

According to this site the 8086:2e32 is supported by the i915.

But according to the /var/log/Xorg.0.log file you pasted, your PC is not using the i915 (Intel driver version), but rather it is using the more basic FBDEV driver.

ie


    18.518] Current Operating System: Linux linux-krbl 2.6.37.6-0.9-default #1 SMP 2011-10-19 22:33:27 +0200 i686
    18.518] Kernel command line: root=/dev/disk/by-id/ata-WDC_WD1600JB-00REA0_WD-WMANM1709154-part5 resume=/dev/disk/by-id/ata-WDC_WD1600JB-00REA0_WD-WMANM1709154-part1 splash=silent quiet nomodeset vga=0x31b
......
    18.704] (II) LoadModule: "intel"
    18.705] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
......
    18.724] (II) LoadModule: "fbdev"
    18.725] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
......
    18.734] (II) LoadModule: "vesa"
    18.734] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
.....
    18.796] (**) FBDEV(0): claimed PCI slot 0@0:2:0
    18.796] (II) FBDEV(0): using default device
    18.796] (WW) Falling back to old probe method for vesa
    18.796] (II) FBDEV(0): Creating default Display subsection in Screen section
        "Default Screen" for depth/fbbpp 24/32
.......
    18.800] (II) UnloadModule: "vesa"
    18.800] (II) Unloading /usr/lib/xorg/modules/drivers/vesa_drv.so

I can see from the above that you specified the boot code ‘nomodeset’. That will force the loading of the FBDEV driver when one has Intel graphics.

Is it absolutely necessary for you to boot with the boot code nomodeset ? What happens if you do not use that boot code and try to boot ?

When I remove the nomodeset boot code the card actually sets the resolution to 1440x900. However, when KDE starts the resolution gets changed to 1024x768.

The vga mode is still set to vga=0x31b. If I set the code to vga=ask, then 1440x900 doesn’t show up as an option.

BTW. Here is the new Xorg.0.log after removing the nomodeset option.

IMHO then it is FAR superior to boot without the ‘nomodeset’ as that gives you the Intel graphic driver which is far superior to the FBDEV graphic driver. Once you have finished booting and are in 1024x768, please type:


xrandr

and post here the output. This should be repairable WITH the Intel driver.

Please, also check to ensure that you do NOT have the 1024x768 forced in KDE, which is over-riding X settings. … ie does a NEW KDE user have this problem ?

Are you certain in KDE > configure desktop > Hardware> Display and Monitor you do not have an inappropriate setting selected ?

Here is the xrandr output

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 408mm x 255mm
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

If I check KDE > configure desktop > Hardware> Display and Monitor 1440x900 is not available. The options that are available match the output of xrandr posted above.

ie does a NEW KDE user have this problem ?

The resolution gets set to 1024x768 before I log into the account that I’m using.

Take a look at /boot/grub/menu.lst with “kdesu kwrite”. On the kernel statement what, if you have a vga= parameter, what is it set to?

For some reason VGA1 is being limited to 1024x768 ans so is the frame buffer (see new Xorg.0.log).

it is set to vga=0x31b

I’ve set it to vga=ask before, but 1440x900 never comes up as an option.

Try removing the vga parameter and reboot. Tell us what happens.

I removed the vga parameter at the GRUB boot menu. The resolution gets set to 1440x900, but once KDE starts it defaults to 1024x786.

It isn’t KDE that is setting the display resolution, it is the X-server

    18.692] (II) intel(0): Printing probed modes for output VGA1
    18.692] (II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
    18.692] (II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
    18.692] (II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
    18.692] (II) intel(0): Modeline "848x480"x60.0   33.75  848 864 976 1088  480 486 494 517 +hsync +vsync (31.0 kHz)
    18.693] (II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 489 492 525 -hsync -vsync (31.5 kHz)
    18.693] (II) intel(0): EDID for output HDMI1
    18.694] (II) intel(0): EDID for output DP1
    18.694] (II) intel(0): Output VGA1 connected
    18.694] (II) intel(0): Output HDMI1 disconnected
    18.694] (II) intel(0): Output DP1 disconnected
    18.694] (II) intel(0): Using fuzzy aspect match for initial modes
    18.694] (II) intel(0): Output VGA1 using initial mode 1024x768

Your monitor’s EDID appears to be read correctly but for some reason a lower resolution is used. Are you connected via a VGA cable? That can limit the resolution available (even when the monitor’s capabilities are known to be higher). Can you connect via a DVI-D cable instead? If not, it may be possible to force a higher display resolution by editing /etc/X11/xorg.conf.d/50-monitor.conf so that the 1440x900 display mode is explicitly listed.

Section "Screen"
  Identifier "Default Screen"

  Device "Default Device"

  ## Doesn't help for radeon/radeonhd drivers; use magic in
  ## 50-device.conf instead
  Monitor "Default Monitor"
SubSection "Display"
                Depth          24
                Modes         "1440x900"
        EndSubSection
EndSection

Once your edit is complete (be careful with any mistakes), then try restarting the X-server with CTRL-ALT-Backspace (twice). You can use xrandr to confirm the current (and available) display resolutions. If X won’t star after the edit, reboot and start in failsafe mode, and remove your changes.

It may also be necessary to edit /etc/X11/xorg.conf.d/50-monitor.conf, so that a modeline for 1440x900 is defined like this

Section "Monitor"
  Identifier "Default Monitor"

  ## If your monitor doesn't support DDC you may override the
  ## defaults here
 HorizSync 28-85
 VertRefresh 50-100

  ## Add your mode lines here, use e.g the cvt tool

Modeline "1440x900"  106.50  1440 1520 1672 1904  900 903 909 934 -hsync +vsync

EndSection

See how that goes.

In earlier days of KMS, the vga parameter had caused problems for some hardware, so it was worth a try. However your problem may be a regression bug after some kernel/xorg update to 11.4. You did mention in your OP:

After the installation the 1440x900 resolution was achieved. However, I performed an online update and performed a reboot. Now I can’t set the resolution to 1440x900.

For some reason the DDC gathered Modeline (see Xorg.0.log at line 211), information supplied by your monitor to the graphics card, is not being used.

First check that you don’t have xorg.conf file at /etc/X11/xorg.conf. Also check that no statements have been added to files 50-monitor.conf and *50-screen.conf *in the directory /etc/X11/xorg.conf.d, that could affect or limit display resolution to 1024x768.

You could then try adding this “1440x900” ModeLine statement to the end of the file 50-monitor.conf, before the EndSection line:

ModeLine "1440x900" 106.50  1440 1520 1672 1904  900 903 909 934 -hsync +vsync

Then add these lines to file 50-screen.conf between the statements Monitor “Default Monitor” and EndSection:

    SubSection "Display"
         Depth 24
         Modes "1440x900" "1024x768"
    EndSubSection

Then reboot your system.

If that doesn’t work, a bug report to openSUSE bugzilla would be the next step. You will also need to attach the Xorg.0.log file to it.

The following /etc/X11/xorg.conf.d/50-monitor.conf did not work. When I restarted the X-server X did not start.

Section "Screen"
  Identifier "Default Screen"

  Device "Default Device"

  ## Doesn't help for radeon/radeonhd drivers; use magic in
  ## 50-device.conf instead
  Monitor "Default Monitor"
SubSection "Display"
                Depth          24
                Modes         "1440x900"
        EndSubSection
EndSection

However, the following /etc/X11/xorg.conf.d/50-monitor.conf worked after restarting the X-server.

Section "Monitor"
  Identifier "Default Monitor"

  ## If your monitor doesn't support DDC you may override the
  ## defaults here
 HorizSync 28-85
 VertRefresh 50-100

  ## Add your mode lines here, use e.g the cvt tool

Modeline "1440x900"  106.50  1440 1520 1672 1904  900 903 909 934 -hsync +vsync

EndSection

So the resolution is set correctly. I need to go into Yast and delete the nomodeset parameter from the Boot Loader. I’ll also set the Vga Mode to “Unspecified”

I’m going to reboot and report back.

The problem is fixed. I was able to reboot and get the the monitor’s optimal resolution of 1440x900 using a VGA cable. Thanks to everyone that offered assistance.

It didn’t work because there was no matching ModeLine information configured/used at that point. It was necessary to add the ModeLine first (as per my post) or at the same time. Then it should work - and did apparently. :slight_smile:

Well done.