Losing Display During Boot

Yes, I’m still on Leap 15.2. I’m waiting for my project to wrap to have a break to install 15.3. Please bear with me.

Within the last couple of weeks, whenever my GNU/Linux box went into screen saver mode (blank screen), it would not wake up from it. The attached monitors would stay in power saving mode. Without any displays and keyboard in operable, the only option was to power down a power up again.

The system would work for hours without much trouble, as long as it never went into screen saver mode. Today, though, the screen went blank while I was working and the screen wouldn’t come back. The keyboard no longer worked too, for CTRL+ALT+DELETE.

Booting up the system is a no go…

  1. Motherboard splash screen
  2. Grub with countdown
  3. First two lines of loading into RAM
  4. Screen shuts off, keyboard stops working

Booting into Recovery mode is a no go…

  1. Motherboard splash screen
  2. Grub with countdown, select Advanced
  3. Select Recovery mode
  4. Rapid scrolling of boot sequence
  5. At some point during boot sequence, screen goes blank and keyboard stops functioning

My first guess was the graphics card, but before, it would work all work day and as long as it didn’t go into screen saver, it would be fine. Now it won’t even boot up properly.

My second guess was the CMOS battery. I replaced it. No change.

My guess is back to the graphics card. Could it be a heat problem? But it’s been working fine for the motherboard splash and Grub, consistently. Could it be something in the boot sequence? Since the system is Leap 15.2, not much has changed in a long while and only apps have been updated. Could it be the AMD GPU graphics driver? But that hasn’t changed in a couple of years on my system.

Any advice on how to debug? Thanks.

Sounds like hardware problem. Can you boot to USB with Linux or installer on it?? Do you get a grub boot screen? If so press esc after start boot to view boot detail any errors??

This may indeed be a hardware failure. Can you boot any kind of bootable USB, CD or DVD? When was the graphics card originally sold? Do you know whether it’s a PCI, PCIe or AGP card? Old (>12-15 years) ATI AGP and PCI cards seem to have a higher than average failure rate in old age.

Does your motherboard provide graphics outputs? Maybe you could remove the GPU card and run on an IGP device.

Now I see OP already posted a similar problem in January here

Are you still running through a KVM? If so, maybe it’s the problem.

Things I’ve tried today…

  1. Redoing the thermal paste to the graphics card since it’s from 2013 and maybe due for a redo. The paste hadn’t dried, but was quite a mess. I removed the old thermal paste, clean everything thoroughly and reapplied thermal paste. Retest and same result as reported initially.
  2. Found my old NVidia GT260 card that I stopped using because NVidia stopped driver support. Swapping it in, the system booted to full graphics mode, only in VGA. So, the system is working, just something wrong with the AMD card.
  3. A friend had an old NVidia Quadro FX580, so I picked that up. Perhaps it uses a supported NVidia driver.
  4. Similarly to the GT260, it booted to VGA full graphics mode.
  5. I installed the NVidia driver the “hard way”. I obtained the driver directly from NVidia, based on selecting Quadro FX580.
  6. Afterward, boot stalled at Locale.
  7. Swapped back in the GT260. It also stalled at Locale. So, installing the NVidia driver caused something to happen, which was to stall boot.
  8. Swapped back the AMD R9 290. Same result as reported for this card… motherboard splash, Grub, first two lines of loading into RAM, screen goes blank.

As far as the KVM, I’m connecting the monitors directly to the card during this testing.


  1. NVidia cards I have on hand, GT260 and FX580, use old drivers no longer supported, so even with installing the “hard way”, they’re not working.
  2. AMD R9 290 seems to have a hardware issue.

It may be time for a new graphics card. I don’t game, so am shocked at the current pricing for graphics cards.

Old NVidia cards don’t need proprietary drivers to work:

inxi -SGayz
  Kernel: 5.3.18-lp152.106-default x86_64 bits: 64 compiler: gcc v: 7.5.0
    parameters: root=LABEL=<filter> ipv6.disable=1 net.ifnames=0 noresume
    mitigations=auto consoleblank=0 
  Desktop: Trinity R14.0.11 tk: Qt 3.5.0 info: kicker wm: Twin 3.0 vt: 7
    dm: TDM Distro: **openSUSE Leap 15.2**
  **Device**-1: NVIDIA GF108 **GeForce GT 630**] vendor: Gigabyte **driver: nouveau**
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 ports:
    **active: DVI-I-1,VGA-1** empty: HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:0f00
    class-ID: 0300
  **Device**-2: NVIDIA G84 **GeForce 8600 GT**] vendor: XFX Pine **driver: nouveau**
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 4 link-max: lanes: 16 ports:
    **active: DVI-I-2,DVI-I-3** empty: none bus-ID: 05:00.0 chip-ID: 10de:0402
    class-ID: 0300
  **Display**: server: X.Org v: 1.20.3 **driver: X: loaded: modesetting**
    unloaded: fbdev,vesa alternate: nouveau,nv,nvidia gpu: nouveau
    display-ID: :0 screens: 1
  **Screen**-1: 0 s-res: **7760x1440** s-dpi: 120 s-size: 1642x304mm (64.6x12.0")
    s-diag: 1670mm (65.7")
  Monitor-1: DVI-I-1 pos: primary,left model: NEC EA243WM serial: <filter>
    built: 2011 res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2
    size: 519x324mm (20.4x12.8") diag: 612mm (24.1") ratio: 16:10 modes:
    max: 1920x1200 min: 640x480
  Monitor-2: DVI-I-1-2 mapped: DVI-I-2 pos: center-r model: Dell P2012H
    serial: <filter> built: 2012 res: 1600x900 hz: 60 dpi: 92 gamma: 1.2
    size: 443x249mm (17.4x9.8") diag: 508mm (20") ratio: 16:9 modes:
    max: 1600x900 min: 720x400
  Monitor-3: DVI-I-1-3 mapped: DVI-I-3 pos: right model: Acer K272HUL
    serial: <filter> built: 2018 res: 2560x1440 hz: 60 dpi: 109 gamma: 1.2
    size: 598x336mm (23.5x13.2") diag: 686mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  Monitor-4: VGA-1 pos: center-l model: Lenovo L2251x Wide serial: <filter>
    built: 2011 res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2
    size: 474x296mm (18.7x11.7") diag: 559mm (22") ratio: 16:10 modes:
    max: 1680x1050 min: 720x400
  OpenGL: renderer: NVC1 v: 4.3 Mesa 19.3.4 direct render: Yes

It’s possible some configuration for the defunct AMD card is/was preventing NVidia GPU drivers from loading, thus producing VGA mode. Whatever was done in January very likely needs to be undone for the FX580 to work with your display’s native mode. The amdgpu and radeon drivers’ output names won’t match NVidia output names. Options added to kernel command line for amdgpu should be removed. Files added or changed for amdgpu or radeon in /etc/X11/xorg.con* need to be reverted and/or removed. For modesetting or nouveau display drivers to work, all traces of proprietary NVidia driver installation must be purged, and nouveau must not be blacklisted.

Thank you for listing all the things I need to check! This is super helpful!

The only extra parameter I added to Grub was amdgpu.dc=0, which I removed and booted from without much luck. I was still stuck on the Locale line. After sidetracking to see if anyone else got stuck at Locale, I found quite a few threads. It seemed the cause was the NVidia driver.

I booted to console with another kernel version in Grub, which thankfully worked. I did the --uninstall with the NVidia driver “hard way” script. It worked! I was able to reboot into the current kernel and be back into VGA full graphics mode.

Now I’ll see about unwinding the AMD GPU driver install and going for nouveau.

Does this mean 640x480 resolution, or something else?

Yes, seems to be this resolution.

Goal, reinstall nouveau after NVidia driver install… graphics card installed NVidia GT260…

After using the NVidia “hard way” script to uninstall with “–uninstall” flag, system would still boot to VGA resolution full graphics mode.

Found this old thread:


Following the checklist at the end of thread…

  1. NVidia driver uninstalled using script with --uninstall. In YaST, no traces of nvidia drivers installed as well.
  2. In YaST, xf86-video-nouveau was installed, but just to be sure update “^” and Accept.
  3. Found nvidia-installer-disable-nouveau.conf in /etc/modprobe.d that was blacklisting nouveau. Left the file, but commented out lines:

generated by nvidia-installer

#blacklist nouveau
#options nouveau modeset=0

  1. No /etc/sysconfig/kernel file to set NO_KMS_IN_INITRD, so didn’t create file.
  2. mkinitrd, just in case
  3. No /etc/X11/xorg.conf file to remove. There were some old backup files (.backup, .bc, .bkup), but no recent ones. There’s a xorg.conf.d/ dir and left alone, even though there was a leftover 10-amdgpu.conf file.

Rebooted a full graphics mode with proper resolutions on all monitors!

Likely, the significant changes was the removal of the nvidia drivers and the removal of the blacklisting of nouveau, as @mrmazda advised.

I think I might still need a new graphics card so I can install manufacturers’ drivers as a 3D software package I occasionally use, SideFX Houdini, crashes without proprietary drivers. All other software I use seem to be fine.

Oh, when my login timeouts and goes into the log in screen, I don’t seem to be able to log in again. It just repeats the login screen after the password is typed in, but that’s probably another issue. It wasn’t a problem when I had AMD GPU or NVidia drivers.

That package provides optional, reverse-engineered, old, “experimental” technology, which none of my NVidia cards use, even though they only use FOSS. For more information, read this driver primer.

It may be this bug or related to it.

All the trouble you’ve had could have caused cache corruption. Remove it:

rm -R ~/.cache/*

It’s only cache.

Thank you for the primer!

Based on my understanding of it, I’m already using the nouveau kernel module, but with the optional nouveau device dependent display driver (DDX), which is currently preempting the device independent display driver (DIX).

I can switch over to DIX by uninstalling xorg-x11-driver-video and xorg-video-nouveau.

If it performs better, then I can use it, or just reinstall those packages to restore what I currently have working.

Does that sound right?

I do have a new graphics card on hand, an NVidia T400 card, ready to go, but wouldn’t mind sidetracking to DIX, to see how it performs. My GT240
(incorrectly identified as GT260 in previous posts in this thread) card is from 2009, so on the cusp of modesetting support, I suppose. It’s an EVGA GT240 (NVidia GT215, Tesla 2.0 architecture).

It does.

I do have a new graphics card on hand, an NVidia T400 card, ready to go, but wouldn’t mind sidetracking to DIX, to see how it performs. My GT240 (incorrectly identified as GT260 in previous posts in this thread) card is from 2009, so on the cusp of modesetting support, I suppose. It’s an EVGA GT240 (NVidia GT215, Tesla 2.0 architecture).
I think all these cards are able to use the modesetting DIX. I know I have at least one Tesla using it.

I uninstalled the two packages and rebooted. DIX works better for VNC than with nouveau. Video plays much smoother through VNC than before.

Thanks again for the help and revelation with DIX!

Nice to hear about good results! :slight_smile: