Looking for Epson WF-7510 printer software

I’m having trouble getting my Epson WF-7510 large format printer going after a fresh install of Opensuse 13.2. Can anyone tell me where I find working Epson drivers for this printer?

And maybe I’ve described it wrong. I have the Gutenprint driver that worked with my old install, and I have it selected.Is there a process I should follow?

Thanks, Bob

I want to add something My old printer drivers that worked under 13.1 are apparently 'broken" under 13.2

See here:


When I go to the Epson site, I can download software and when I attempt to install it with apper, the process asks for authorization, and when I finally get to the end it gives the following error message “A problem that we were not expecting has occurred.Please report this bug with the error description.”

If I download the rpm files separately and try to install them with yast, it tells me the files are “broken”

Can anyone tell me how to fix this?

Install it with zypper as root:

zypper in /path/to/the/download/Name.rpm

Is that really a good idea? openSUSE 13.2 is out of support (which could be a resaon that it is difficult to find things).

Thanks, Henk. I hadn’t realized that, but I don’t much care for the way Leap 42.1 works - it’s very different from Opensuse 13.1, which is what I’m used to.

I guess I can try to install 42.1 and see how that works.

What I want is a desktop that I can use as a server for internal (to me) files, and that I can use KDEPIM3 on. KDEpim3 works (for me) so much better I won’t use kde4pim unless there’s no other way, Normally I just install KDE3 after the rest of the install and it picks up all my old KDE3pim settings.

Do you think I’ll have more luck getting my printer going with 42.2 or 42.1?

Thanks, Bob

I feel with you. Still using KDE PIM 3.5 on KDE 4 on openSUSE 31.1.
Testing Leap 42.2. The system is not the problem, KDE is. >:(

No idea about the printer.

I only wanted to warn you and others reading this thread, that installing 13.2 in today’s world might not be a good idea. The problem with out of support versions is not only that you do not get any security updates anymore (what is what most people will warn you for, but something where one can take a calculated risk knowing what the environment and use of a system are), but also that when you ask help here, not many people will have such a system to re-create your problem. And they may even have forgotten a lot about the details of such an old version. Thus, not only the technical support with respect to updates, but also the friendly support from the forums may be gone.

Thanks for the advice, Henk. I have installed 42.2 and I’m working my way through the install.Thanks, Bob

I managed to get my Epson WF-7510 Printer working under Opensuse 42.2 at last. First, I found thatthe latest Gutenprint drivers included ones for the WF-7510 family. I went to http://download.opensuse.org/repositories/Printing/openSUSE_Leap_42.2/x86_64/ and downloaded the latest driver -
gutenprint-5.2.12-59.1.x86_64.rpm. I installed it and now have drivers for the WF-7510. Then I went to CUPS and modified my printer to use the driver for the WF-7510 and all is well. Now for the scanner…

Good to read of your success, but to provide better context to others I’ll merge it with your original thread about this…


Now merged…