Looking for a compatible WiFi USB dongle. Any recommendations?

I am looking for a good USB WiFi dongle that is compatible with Linux, specifically one that is known to work more or less straight away in openSUSE (Tumbleweed) with very little hassle.

I have seen a TP-Link model (TL-WN725N Nano N150) that is reported to work OK on Linux after installing drivers. But perhaps there are other better models that I am overlooking?

Thanks for any input!

The problem is:
Not the Name is important, only the WIFI-Chip inside is important and you can get Wlan-Dongles with the same name, but different chips…

So I would only say:
Buy some dongle and ask, if you can change it…

Avoid Broadcom chipset - they rarely work without additional drivers. And the addition drivers for 15.3 seem not to work well at all so I suspect they don’t work right in Tumbleweed.

I have had to add wifi dongles to older HP laptops because the Broadcom chipset in them is not supported any more but the laptop with 4 gb is fine for running openSUSE 15.3 with an SSD drive to replace the slow 40GB hard drive that they came with (the DDR2 memory is expensive and it is sometimes cheaper to buy and newer laptop than to replace 2 - 512K memory for 2 - 2GB (the max that those laptops could address).

I look on eBay for dongles that also say linux from dealers that have sold 100’s - most are Linux ready.

Thank you both for your answers. I see now how this goes. Chipset is important but too often left out of the specs without mention and also hard to find.

I will have too look harder and deeper than I previously thought. Will eventually report back I find a good solution.


Is range (and not top-speed) important? If so, I can recommend something like the Asus USB-N14.

I have the USB-N14 running under Tumbleweed nicely but I see it is no longer sold. An alternative seems to be the TP-Link TL-WN8200ND, I see they offer a linux driver and there is one on github, it seems it is not supported in the default kernel.

I have now solved this issue. As always, a bit more complicated than I foresaw. Not too bad though. I write this in case it is useful to someone else.

I found a USB WiFi adapter in a nearby store that explicitly indicated which chipset it is based on. In my case the chipset is: RTL8811AU. The brand of the dongle is “plexgear”, a local brand from that specific store, I guess. The dongle was said to support Linux and there was a little CD with drivers in. The Linux driver was specified for kernels older than 4.X though, so I did not bother with this.

Then I tried first to run the dongle using the rtl8812au driver that is available in the repos. No success. The reason was that the particular vendor and product for the dongle (0bda:a811 Realtek Semiconductor Corp. RTL8811AU 802.11a/b/g/n/ac WLAN Adapter) were not listed in those supported by the driver.

After a couple of hours of research I found that the driver available though the repos is most probably not suitable for this chipset, also it is probably outdated. The github repository from which the driver is taken itself recommends readers to another repository. This new repository is found here: https://github.com/morrownr/8821au
After downloading this driver and following the simple instructions the driver got installed without problems. After reboot the possibility of connecting through WiFi was available in NetworkManager. I wrote this using the WiFi connection.

Good luck and thank you everyone!


This kmp should also work:

You can add that Repo and get a new driver if a new kernel is delivered…

I see. Thanks for this.


But only with secure boot disabled…

Yes, I got that. Thanks.