Logitech Wave keyboard and xmodmap

Hi! I just got a Logitech Wave keyboard, and I’m having problem with some extra keys.

Using xev doesn’t show anything for the Word or Excel keys. Using evtest or showkey shows these keys produce scan codes 256 and 257.

I tried setting up an appropriate XModMap file, but it seems it won’t accept mapping any numbers above 255… so, how do you get these keys to be recognized?

Have a look at How To Utilize Your New Multimedia Keyboard Under Linux | HowtoForge - Linux Howtos and Tutorials or LinEAK project. Either might help more than I can…

Hi! Thanks, but that won’t help – some of the keys do not produce keyboard events and appropriate scan codes, and mapping keys in this way doesn’t work.

hi fkereki. Have you sorted out this problem? What keys do not work?

I’m still waiting this one out… I found a possible solution (HIDPoint) but it doesn’t work with my current kernel. I tried going back to a previous one, and even though the HIDPoint site said it was supported, it refused to work. I’m hoping there will be an OpenSUSE 11.2 version soon, and I’ll try it out.

I found a thread about this which I’m going to try next, even though it’s for Ubuntu; the symptoms match my situation 100% (sucha s XEV not showing keycodes) and I hope I can get OpenSUSE to work…