Logitech G3 gaming mouse, how to lower the speed ( lower then kde allows )

I basically have the same problem under windows, but for windows installing some logitech software to lower the dpi fixed it.

There is no such software for Linux it seems ?

Found this with google, but would like to know if its the right way to fix this:

https://patrickmn.com/aside/lowering-gaming-mouse-sensitivity-in-ubuntu-9-10/

I installed xinput, and my mouse seems to be recognized correctly

guus@linux-0pkp:~> xinput --list --short
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Gaming Mouse                 id=8    [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=9    [slave  keyboard (3)]


This is not a new problem, and its worse in games. ( over sensitive mouse )

I also cant shake the feeling chrome and or firefox are messing with my mouse settings.

Any thoughts on this ?

mouse and Kmouse are being ignored, or I can’t set a value low enough.

If it’s just mouse acceleration that needs adjusting, then start by using the following commands to get the mouse device attributes…

xinput list-props 8

or if you have ‘libinput-tools’ installed

libinput list-devices

It is possible to adjust the acceleration using the advice given here.

Alternatively, if it is the mouse DPI that you want to change, then read

man hwdb

Essentially, a custom mouse configuration is created (eg /usr/lib/udev/hwdb.d/75-logitech.hwdb) with the desired values to help you gain a mouse with the appropriate sensitivity for your needs.

These might be useful to help give you a better idea about this…
https://who-t.blogspot.com/2014/12/building-a-dpi-database-for-mice.html
https://www.reddit.com/r/linux_gaming/comments/6pgl7q/gaming_mouse_high_dpi_fix_for_libinput_debian/

Thank you, looks like you’re answer has all I need. :slight_smile:

I also found a program called Solaar, installed it from official openSUSE repositories, but it shows no devices yet.
I have figured out why though, a normal user can’t access usb devices.

https://pwr.github.io/Solaar/installation.html

Will try arch wiki way first.

And see about that database (in first link) , stumbled on that when looking for solutions too.

Great. Lets us know you get on. :slight_smile:

What I tried, but it seems to do nothing:

guus@linux-0pkp:~> xinput --set-prop 8 'libinput Accel Speed' 0,5
guus@linux-0pkp:~> xinput --set-prop 8 'libinput Accel Speed' 0.25
guus@linux-0pkp:~> xinput --set-prop 8 'libinput Accel Speed' 0,1

And even

guus@linux-0pkp:~> xinput --set-prop 8 'libinput Accel Speed' 1/2

I do not get any errors, but nothing seems to change about the mouse speed.

Am I doing something wrong ?

For info the out put of xinput, which does not seem to change either.

guus@linux-0pkp:~> xinput --list-props 8
Device 'Logitech USB Gaming Mouse':
        Device Enabled (152):   1
        Coordinate Transformation Matrix (154): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
        libinput Accel Speed (311):     1.000000
        libinput Accel Speed Default (312):     0.000000
        libinput Accel Profiles Available (313):        1, 1
        libinput Accel Profile Enabled (314):   1, 0
        libinput Accel Profile Enabled Default (315):   1, 0
        libinput Natural Scrolling Enabled (316):       0
        libinput Natural Scrolling Enabled Default (317):       0
        libinput Send Events Modes Available (296):     1, 0
        libinput Send Events Mode Enabled (297):        0, 0
        libinput Send Events Mode Enabled Default (298):        0, 0
        libinput Left Handed Enabled (318):     0
        libinput Left Handed Enabled Default (319):     0
        libinput Scroll Methods Available (320):        0, 0, 1
        libinput Scroll Method Enabled (321):   0, 0, 0
        libinput Scroll Method Enabled Default (322):   0, 0, 0
        libinput Button Scrolling Button (323): 2
        libinput Button Scrolling Button Default (324): 2
        libinput Middle Emulation Enabled (325):        0
        libinput Middle Emulation Enabled Default (326):        0
        Device Node (299):      "/dev/input/event3"
        Device Product ID (300):        1133, 49218
        libinput Drag Lock Buttons (327):       <no items>
        libinput Horizontal Scroll Enabled (328):       1


Not sure why it’s not working for you. I just changed my touchpad acceleration with

xinput --set-prop 11 'libinput Accel Speed' -1.0

and it worked as expected (too slow for my needs though)…

libinput Accel Speed (291):     -1.000000

I just did:

xinput --set-prop 8 'libinput Accel Speed' -1.0

That’s is huge step forward. Now my monitor is not in mouse movement units, about 1-2 inch wide.

Might have to find something a bit faster though. But for now gonna leave it.

Now my monitor is in mouse movement about 3-4 inch wide :slight_smile:

Maybe now I can hit something in fps games rotfl!

That reads like progress.

Big Progress

Still Need to test it in a game. ( through steam )

But for desktop use, its now good enough. Not constantly over shooting.

For now I have to do this every time I login. I know why though so that not a problem.

Reading back my topic, maybe its the minus sign why it did not seem to work.

Yes, you can use values from -1 (slow) to 1 (fast).

I am using tumbleweed now on my new pc and again have to adjust the mouse. ( beyond what kde can do for me)

Googling learned me one thing, it’s mostly gamers having this issue.
Also the dpi of mouses have gone up allot last 10 years.

Some page also confirmed something I was already wondering.
The DPI of gaming mouses are insane. Many gamers set their mouse to only 800 DPI.
( for games were you need to aim )

I wonder if the KDE devs, don’t use a mouse and or just never game. :stuck_out_tongue:

I thought I was smart, got a new simple logitech mouse, only 1000 DPI, but again will have to go into X input.

Its a bit frustrating, but I am happy I found my topic, because I remembered asking for help here.

Mostly for a laugh but see my struggle, but I am winning:

guus@linux-2ls4:~> xinput --list --short
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Optical Mouse                id=8    [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=9    [slave  keyboard (3)]
guus@linux-2ls4:~> xinput --list-props Logitech
unable to find device Logitech
guus@linux-2ls4:~> xinput --list-props Logitech USB Optical Mouse
unable to find device Logitech
unable to find device USB
unable to find device Optical
unable to find device Mouse
guus@linux-2ls4:~> xinput --list-props LogitechUSBOpticalMouse   
unable to find device LogitechUSBOpticalMouse
guus@linux-2ls4:~> xinput --list-props id=8
unable to find device id=8
guus@linux-2ls4:~> xinput --list-props Mouse
unable to find device Mouse
guus@linux-2ls4:~> xinput list-props 8
Device 'Logitech USB Optical Mouse':
        Device Enabled (148):   1
        Coordinate Transformation Matrix (150): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.0000
        libinput Natural Scrolling Enabled (308):       0
        libinput Natural Scrolling Enabled Default (309):       0
        libinput Scroll Methods Available (310):        0, 0, 1
        libinput Scroll Method Enabled (311):   0, 0, 0
        libinput Scroll Method Enabled Default (312):   0, 0, 0
        libinput Button Scrolling Button (313): 2
        libinput Button Scrolling Button Default (314): 2
        libinput Middle Emulation Enabled (315):        0
        libinput Middle Emulation Enabled Default (316):        0
        libinput Accel Speed (317):     -0.600000
        libinput Accel Speed Default (318):     0.000000
        libinput Accel Profiles Available (319):        1, 1
        libinput Accel Profile Enabled (320):   0, 1
        libinput Accel Profile Enabled Default (321):   1, 0
        libinput Left Handed Enabled (322):     0
        libinput Left Handed Enabled Default (323):     0
        libinput Send Events Modes Available (293):     1, 0
        libinput Send Events Mode Enabled (294):        0, 0
        libinput Send Events Mode Enabled Default (295):        0, 0
        Device Node (296):      "/dev/input/event4"
        Device Product ID (297):        1133, 49271
        libinput Drag Lock Buttons (324):       <no items>
        libinput Horizontal Scroll Enabled (325):

Reading back this topic, I tried xinput list-props 8 and that did work.

I might get a gaming mouse, with buttons were I can on the fly change the dpi.
Been googling allot, there seems to be Linux software for razor gaming mouses. ( not from razor though)

I am getting confused about this:

# A record with a single match and five properties
           mouse:usb:v046dp4041:name:Logitech MX Master:
            MOUSE_DPI=1000@166


I can’t set dpi to 800 ?

https://artifacts-testing-farm.apps.ci.centos.org/409e10e8-ec54-4a33-a7ea-09f19a7014d3/source/hwdb/70-mouse.hwdb

Been reading that too, but I am stuck, don’t understand how to set the dpi, and how to find out if I can change it for my mouse ?

Under Advanced Game Settings, you are not only able to configure X/Y axis separately, but also allowed to preset up to 5 distinct DPI settings; as long as the preset is between 400dpi and 2000dpi. Without Logitech SetPoint installed, the mouse is able to switch between 800dpi and 1600dpi by pressing the DPI toggle button on the mouse itself. With SetPoint installed, you will be able to switch between 400dpi, 800dpi, and 2000dpi by default with possibilities to configure additional DPI settings as you wish.

Thank you right now using an M100 Logitech.

Looking at that site, totally reminds me of using that mouse (G3) on windows, when it was just new.
First thing I did was lower the dpi.

Although I am for now using an M100 I need to find a way to lower the dpi for this one too.

Maybe then Serious Sam 3 gets playable again. :slight_smile:

xinput --set-prop 8 "libinput Accel Speed" -0.9

Seems to help but not enough.

xinput --set-prop 8 "Coordinate Transformation Matrix" 0.6 0 0 0 0.6 0 0 0 2

Seems to work on the desktop but not in the game SS3BFE.

Maybe a programmable mouse is the solution.
I had read somewere of somebody setting the mouse up on windows(buttons) , then he could use the mouse as he wanted on Linux.

For now just gonna try to change the dpi of the mouse, and report back :slight_smile:
Setpoint does not have a Linux version as far as I know ?

Also installed piper…

Yes, that should be entirely possible. I shared some links back in post #2 that should illustrate the process.

Been reading that too, but I am stuck, don’t understand how to set the dpi, and how to find out if I can change it for my mouse ?

Not sure where you are stuck, but assuming the above vendor and product ID are for your particular mouse, then the general idea is to copy to a custom file (eg /usr/lib/udev/hwdb.d/75-logitech.hwdb) and edit as desired. For example

# A record with a single match and five properties
           mouse:usb:v046dp4041:name:Logitech MX Master:
            MOUSE_DPI=*800@166 1000@166

I note that the config file contains the following notes…

#########################################

MOUSE_DPI

#########################################

DPI settings are specified as

MOUSE_DPI=<dpi>@<frequency>]

Where <dpi> is the resolution in dots per inch, and <frequency> the

sampling frequency in Hz (optional). If a device supports dynamic

frequency scaling, the maximum frequency should be used. For devices

supporting multiple fixed frequencies, see below.

The value of MOUSE_DPI is:

- a single integer for single-resolution mice, e.g.

MOUSE_DPI=800

or, if the frequency is known:

MOUSE_DPI=800@120

- a space-separated list of resolutions for multi-resolution mice.

The default resolution must be prefixed by an asterisk, the resolutions

in the database must be as shipped by the manufacturer. e.g.

MOUSE_DPI=400 *800 2000

The order of resolutions is as configured by the HW manufacturer or in

ascending order, whichever appropriate.

The frequency must be given to either none or all resolutions. If the

device supports multiple fixed frequencies, the order of items is

MOUSE_DPI=r1@f1 r2@f1 r3@f1 r1@f2 r2@f2 r3@f2

If the default manufacturer-set resolution is unclear, a resolution of

800 or 1000 should be set as default, if available. If neither is

available, choose the “middle” resolution value of those available.

The list may contain a single item which must be marked with an

asterisk.

Local changes to the a non-default resolution of the mouse (e.g. through

third-party software) must not be entered into this file, use a local

hwdb instead.

This is the first time you’ve mentioned your actual model I think.

The entry in 70-mouse.hwdb for it is

# Logitech M100 Optical Mouse
mouse:usb:v046dpc05a:name:Logitech USB Optical Mouse:

You could try creating 75-mouse.hwdb and add

# Logitech M100 Optical Mouse
mouse:usb:v046dpc05a:name:Logitech USB Optical Mouse:
MOUSE_DPI=800

You’ll need to restart udev after this to take effect, and you could unplug and re-plug the device as well to trigger the appropriate matching rules. The blog also mentions restating the desktop environment (but I’m not ocnvinced that this is required).

https://www.youtube.com/watch?v=i-uLo-AJH34

This is all I want.

But need be able to aim, so I hit something.

Hordes of aliens attacking, and I only have to stay alive. :wink:

BTW, the /dev/input/event* nodes for each input device can be got using

sudo libinput list-devices

From that one can get the current settings. For example if the mosue is associated with /dev/input/event8…

udevadm info /dev/input/event8 | grep MOUSE_DPI

Thank you.

I did not want to start a new topic, maybe I should have ?
When I first posted this problem, I was using a G3 and openSUSE leap, now I am on tumble weed, with an M100.

I had hoped getting a more simple logitech mouse with lower dpi would fix this, but it did not.
What motivated me to try this was a web page about gaming mouses, and to keep it short, gaming mouses have insane dpi.
Insane because also on windows you will have to lower the dpi allot to get a good working mouse.

Optimistic I will get it fixed though, with the info you provided.

To be continued. :slight_smile:

Yes, that would have been a better idea. It makes confusing reading when reading from the beginning, especially since the initial posts are over a year old.

I’ll close this thread out.