Login Failed? Please help

I have a Toshiba notebook running 11.4.
It’s a P4 dual processor 64bit machine.

I installed 11.4 a few days ago and have booted countless times. Just prior to this I had spent the entire day configuring XP within Virtualbox.

Today I boot OpenSuse and my login name is presented on the Left side of the screen with two fields:


I type in the only username I’ve created for the machine, the same one presented on the Left side of the screen and type my root password and login fails. I am certain I’m typing this in correctly and tried several times.

I can enter “root” as the username and enter the password and it seems to begin booting but then the screen goes to black with only the cursor arrow left and remains there indefinetly.
Sometimes the bar along the bottom appears then disappears, almost as if the system is only creeping along at 100th its normal speed.

Previous to this it only prompted for a password without the username.

Is there an easy fix to this?
Thanks in advance

More information:

I’ve tried to log in using failsafe but the booting halts with the message “No space left on device”
Hmm… That doesn’t make any sense.

I have a 250gb HD.
Approx 8gigs are used in the MFG restore partition which will install Win7 if accessed.

These are the things I’ve done on the HD:

  1. Installed 11.4 on a clean machine except for that MFG partition.
  2. Installed Blender
  3. Installed Rosegarden
  4. Installed Virtualbox from the 11.4 repository
  5. Installed XP on a virtual Disk of 45gb
  6. Installed win98 on a virtual disk of 10gb.
  7. Transfered a music folder from a portable HD to 11.4, approx 40gb
  8. Copied much of the music folder onto the XP Virtual disk.
  9. Installed iTunes onto XP within the VM and loaded the music into it.
  10. Shutdown for the night.
  11. Try to reboot and I get this No Space problem.

Any ideas?

On 03/27/2011 02:36 PM, SteveFury61 wrote:

> Is there an easy fix to this?

probably not…(do you know what is broken, i don’t and i’ve seen this
set of symptoms before)

what happens if, at the first green screen you select to boot “Fail

if it will boot in Fail Save please check and report back if any
active Linux partitions are near full (like, 90% or more full)…

CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

On 03/27/2011 03:06 PM, SteveFury61 wrote:
> Any ideas?

NOTE: this reply assumes you are an experienced Linux administrator
and have not put things you wanna keep in /tmp …if that is not the
case (or even if it is), please read my sig caveat prior to proceeding)

  1. boot from a Linux live CD

  2. navigate to the /tmp folder of the 11.4 install and delete its contents

  3. navigate to the /var/log folder and see if there are any logs which
    exceed (say) 1 GB, if so open that log in a file viewer, zip down to
    near the end of that log and report back here with the error repeated
    over and over and over . . .

due to limitations of the openSUSE forum, i may be again post with the
appearance of having not read one of your (which i won’t have access
to prior to my posting…its complicated)

CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

Like DenverD I assume that your root partition is full. This could be in /tmp. Emptying it as explained above might help, but you then should try to find out why this happened.
It could also be done by excesive logging in /var/log. Clean up there, but again look first into that logging to see why this has grown so much in such a short time.

Also I do not completely understand your first post. When you use a useeid at login, you must then use the passwordd of that user, not the password of root.
You should never try to login as root, especialy not in the GUI.

Thank you for the responses.

Denver D:
I’ve been trying OpenSuse Distros since version 9.x and really got into learning console functions when 10.0 came out- a long time ago and need brushing up.
I was so completely impressed with the usefulness of 11.4 that I was excited to use MS products as an exception and no longer as the rule, hence putting it into a VB.

Because my console study was so long ago I’ll have to research how to do what is suggested.

“Also I do not completely understand your first post.”

I apologize for not being clear. However things have changed.
Booting in either regular or safe mode makes no difference, the system freezes when the progress bar is half way and so the userid/password screen is not displayed.

If I boot on the Live CD I choose “Rescue System”.
It boots to a Rescue Login prompt.

When I installed from the Live CD I used “Me Myself” as the user along with a password.

While at this rescue login I’ve tried entering “Me Myself”, “Me” and “(blank)” but login was incorrect.
If I type “root” I am prompted with this:

Rescue:~ #

So I’ll need to relearn how to navigate console.

Rescue:~ #

that means you are loged in now.

fdisk -l

to get a list of your partitions. I hope you can then identify which one is your openSUSE root partition. Mount it on e.g. /mnt

mount /dev/sda2 /mnt

where you have to replace sda2 with the real one of course.
Then do

df -h

to check if that file system is 100%. When yes, we found it! Then do

cd /mnt/tmp
rm -rf *

BE CAREFULL, check that you a realy in /mnt/tmp and not somewhere else before doing the second statement!!!
Then check again with

df -h

When it is now considerably lower then 100%, reboot the system normal.

Report back please.

Thank you for the help.

sda6 seems to be my problem. It reports:
size 20G
used 20G
use% 100%.

I did the commands within the /tmp directory without any reported errors but df -h still reports 100% usage.

System will not boot, message is "Call to lnsusrtemp failed <temporary directories full?>.

I am wondering if I’ve accidently placed a folder within that partition which contains music, if I did I know the folder name but I’m researching commands how to display directory names (vs. just file names).

My research today has been in a google search for linux console commands and I understand “ls” lists files but looking how to locate my erroneous directory in within that partition and how to remove it along with its contents.

Well, it is your ystem and you should know what is where.

Your report is not very elaborate, but I assume that you have sda6 now mounted on /mnt. Then go to /mnt and look there with

cd /mnt
ls -l

I think you must see things you know about there. I now depends on what you see and what you know. You can use

du -sk *

and then make aan intelligent guess what is unusable big. Then cd down to that one and repeat the

du -sk *

until you have identified which file(s) are out of bounds. Then remove them (you may first copy them to aN USB stick of course).

I am one step closer to solving this.

I found this command in my research:

du / -bh | more

I ran that after mounting my sda6 which listed all directories and their disk usage.

Whammo! I was correct. It’s a self-inflicted problem. I’ll kick myself in the backside later.

I’ve located and identified the path to my offending music folder. It’s multi-layered with too many sub-folders to count and the standard “rd” command won’t remove all contents so I’m researching this further …

What is rd? I suppose you mean rm? I refer to my earlier posting. When you stay in a directory (BE SURE IT IS THE CORRECT ONE) do* rm -rf ** to remove everyting in there.

Please let me say I’m very proud of myself and thankful for the help.

I was able to use the rm along with my old DOS friend I recalled, the . to delete all the files in a directory, then remove the directory. I was able to remove enough files for the system to boot.

Now I’m doing a search for the ‘trash can’ because it says I have to empty it manually.

I’ve learned a lot today believe me!

Thanks again, and yes I meant rm. I had tried the -rf switch but it didn’t recognize the command… I guess it’s because I was missing the astrisk.

I’ll try that again in console.

hcvv you’re my hero today.

Yes, I was able to use your command and remove the entire offending folder.

PLEASE have a wonderful day.

You’ve made mine.

I am afraid you or I am missing some points.

  1. I offered you the *rm -rf ** TWO times. How could you still do other (and with your level of knowledge potential dangerous) things? Thouroughly reading, writing down and then typing isn’t that difficult I hope.

  2. when I do an* rm -rf* (no * or whatever) I do not get anything about “not recognizing the command”. Logical, because rm is a command that is normaly available. You must have done more imprecise copying of my offering.

  3. Using . is a stupid thing in a Unix/Linux shell when you do not know what it means. Do never ever again borrow from MS-DOS or friends when using the Linux CLI. The next one may be dangerous.

  4. I am not sure why you mention the “trash can”. In any case, all you removed from the CLI is gone, it is not moved to the trash can, but into a black hole.


I’ve noted my mistakes, and not realizing the full function of the rm -rf * command. I do now.

When I ran it without the astrisk I was refered to --help.

Trash can-
When I was able to boot I went to File Manager SU and tried to move the remaining parts of my offending folder to the trash because I didn’t know the full function of rm -rf * and thought it easier to use the GUI.

I was wrong, and I did as you suggested and returned to console using your command.

Thank you for the warning about the DOS commands. It’s good advice you have. I did a lot of google searches on basic linux terminal commands and the DOS was mentioned. Amazing how much “advice” is out there.

You’re right, I know enough to wreck my system pretty good.

You’re right, I know enough to wreck my system pretty good.

Wishing you all the best. And don’t hesitate to come here for advice first.

On 2011-03-27 21:06, SteveFury61 wrote:

Ok, now prepare for the next time.

First, install “midnight commander”, or “mc” in short. It is a very
powerful text mode file browser.

2nd, learn how to boot in text mode: When grub displays, type “3” and
enter. You should get to a text prompt: log in as root.

Alternatively, boot in normal mode, then type ctrl-alt-f1. Log in.

Then type “mc”, navigate, find the culprit, solve it.

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)