login as root

I’m setting up a new server. On SLES I can login as root. sudo is boring and cumbersome! How to login as root directly?
Beside I experienced a lot of strange behavior! On opening a file with kwriter, the system crashed and restarted! On being logged out after a wile doing anything else, the new login hanged and I had to reboot through SSH!

I’ll just state my practice.

To login as root, I use CTRL-ALT-F1 (or similar) to get a command line session. I login as root there.

In a GUI: I never login as root. If I need to do something as root, I’ll use “su” in a terminal (“xterm” or “konsole”). Or, from a terminal, I will use “ssh root@localhost”. I use public key authentication for ssh login. So I only have to tell “ssh-agent” my authentication information once. I do add the line:

        NoHostAuthenticationForLocalhost yes

to “/etc/ssh/ssh_config”, so that it doesn’t check the host key for localhost. And I can add “-X” to the “ssh” command line if I want to be able to open X applications.


I found a solution by myself now! By Starting the computer by choosing extended possibilities, the login screen presents the possibility to write the username. Hence login as root is possible. I don’t like it, it is cumbersome, but at least it works!
Being logged in as root, I use terminals at most. But I have a lot of them open, which is much harder being logged-in in the command-line session only.
Any way, this problem is resolved!

I don’t understand exactly what you are doing there, but that doesn’t sound like a proper solution to me.
Rather sounds like the system somehow falls back to xdm in this case.

Logging in as root is possible, but the root user might not be displayed on the login screen.
How you’d enable it, depends on which displaymanager you use.

If it’s sddm (the default on a KDE installation), you can configure which users are shown in /etc/sddm.conf or in KDE’s “Configure Desktop”->“Startup and Shutdown”->“Login Screen (SDDM)”.
Or you can switch to a different theme that allows (requires) you to enter the username manually.

Being logged in as root, I use terminals at most.

But the desktop itself is running as root too.

Why don’t you just use su, or the “Terminal - Super User Mode” respectively Konsole’s “Root Shell” profile?

As you talk about kwrite (there is no “kwriter”… :wink: ), it seems you use KDE…