Local access failure

Just UpDated from openSuSE 13.2 to Leap 42.1 — well over the last couple of days anyway.

Problem: I have a copy of my Web Site on my local PC. Normally, with 13.2 and prior, I could run my WebPages on my local PC just like up on HostRocket where my site is: http://www.trcompu.com

Prior to 13.2 the WebPage sources were on a FAT partition. Starting with 13.2, and a new PC, I put them on an NTFS partition. There ‘was’ no problem. I could still edit and execute the pages from within openSuSE 13.2. I am even running VMware and Windows 10 inside it. Inside Win10 I have Homesite which I use to edit the WebPages. I can still edit the WebPages from within the VMware/Win10/Homesite combo… even thought they are on an NTFS partition. Even under Leap 42.1.

I can view -and- edit the files through Dolphin with Kwrite from within Leap 42.1.

What I can not do is execute my WebPages through Firefox under Leap 42.1. I get the:
You don’t have permission to access the requested object. It is either read-protected or not readable by the server.
Error. Permissions on the dirs and the files are: -rwxrwxrwx

I have looked everywhere -but- the right place for an answer. At present the only answer I see is to go back to openSuSE 13.2 which I really don’t want to do cause I don’t believe going back is as clean as UpDating or going forward.

Just a thought, perhaps the ntfs-3g kernel module has hardened up security wise, you would need to look through the kernel changelog. The other observation, permissions are only part of the story, you also need to look at ownership. Just because permission are set to 777 does not mean user a in group a can look at files owned by user b in group b… so check ownership as well.

Interesting observation -and- I wish I had included that info. They are owned by ‘root’ and in the group ‘root’. Seems that is the default for “Windows” partitions that get ‘carried over’ so to speak. They were also owned by ‘root’ under openSuSE 13.2 -but- as I stated, or implied before, it was not a problem.

I followed one example from the Web and made changes to fstab so that they were owned by me and in the users group. Didn’t make any difference. Oh darn!! Forgot to mention that public_html in ‘my’ home dir is a link to the public_html dir out on the NTFS partition. Was that way under 13.2 also.

What are the mount options?

mount |grep ntfs

I normally don’t mount windows partitions, just mount if needed in dual boot via Nautilus, maybe unmount and try that, in your case Dolphin.

Well now, as usual you or one of the others comes up with some good things to look at. They are not labeled NTFS but as such:

/dev/sdb2                 on /windows/F      type fuseblk    (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096)
/dev/sdb3                 on /windows/G      type fuseblk    (rw,nosuid,nodev,noexec,relatime,user_id=0,group_id=0,allow_other,blksize=4096)
/dev/sdb4                 on /windows/H      type fuseblk    (rw,nosuid,nodev,noexec,relatime,user_id=0,group_id=0,allow_other,blksize=4096)

It is a 2 Tera Byte drive that I broke up. the one that I have my WebPages on is /windows/F


So, you use Dolphin to mount them on demand then? If so then it uses fuse. In 13.2 did you auto mount, as in have an fstab entry or use Dolphin?

That ‘was’ my fstab. I just made a change:

UUID=72F20099F2006427 /windows/F           ntfs-3g     rw,relatime,locale=en_US.UTF-8 0 0

-AND- it did NOT work. HOW-SOME-EVER… I copied the whole public_html dir over to my home dir. I CAN access it with Firefox from there. When it was a “link” I could not … in Leap 42.1 … BUT I could when it was ***openSuSE 13.2.

The “main” reason I had it as a link was for ease of access to both WinXP and SuSE when I had my “old” machine. My public_html was on a FAT partition so I could access it with both systems. I was in and out of both a lot. I just did it on this new system … because.:P. Mostly cause I could — or used to be I could. I like all the things you can do with Linux. So the end result is I am back to having my code in my ***home dir ***and not out on an open file system. Perhaps they will fix it so I can again but until then I will just use the home dir. I will be a tester. That is what I was before for VMware. Think I was one of the biggest user/complainers on that one. You see I run a LinWin system. :wink: Windows inside Linux mainly because of Homesite and TopStyle 5. Those two are how I write all my WebPages. I am still an amateur but they are mostly for myself anyway. Thanks for your directions … the subtle hints that you provided.

By the way… my signature needs to change now that I have Leap 42.1 working to my satisfaction. I have a newer machine, :slight_smile:

Take care,


Thank you for your help. You got me to thinking,


By the by… should this be considered to be a bug??

Against the linux filesystem or the ms filesystem? If you have winX then I would suggest switching to a small exfat partition for files wanting to share, else maybe a USB device with the data on? Else look at just mounting when needed?

Hi Malcolm,

Well now, I would say against the Linux file system... OR at least the code that controls it.  Prior to my installation of Leap I could access those WebPages with Firefox on my local machine.  AFTER installing Leap I could not.  Same Windows different Linux.

Did you see my note above that I copied the public_html dir to my home dir and then I could access them with Firefox. Prior to that it was only a link. Firefox is pointing to the same place only now it is actual code and NOT a link.


That’s why I suggested to look through the ntfs-3g or maybe ntfsprogs changelogs, see if there is anything in there first. Also check the system logs (journalctl -x) to see if you can see the errors appearing that would help if a bug was raised.