Loading initial ramdisk ...

Has anyone figured out what causes the “Loading initial ramdisk …” hang? Silly me, 13.2 was running awesome. I got this wild compulsion to just upgrade via USB stick to Leap 42.1. Got three machines now just sitting there hung up on Loading initial ramdisk … . I have both Nvidia, and Radeon graphic cards.

How did you upgrade?

If by zypper dup do all your repo match 42.1?

It’s hard to say what might be problematic with the initial ramdisk. Just a thought thougt - can you boot successfully with ‘nomodeset’ parameter included in boot options?

At the grub2 screen, press ‘e’ and from there, it is possible to change the boot options. (Two potentially useful parameters are ’ nomodeset’ and ‘x11failsafe’)

The following is an Ubuntu thread, but has a nice graphical illustration on how to do this…

Also described here

Nope, nomodeset has no effect. Also tried it with some ucode thing. Still no dice. I mean, what happens when the initial ram loads? Is there a pointer that is not pointing correctly?

Since it happen on several machine of different video and other are not reporting it, it appear to be operator error. So how did you preform the upgrade. It is probably a mixed 13.2 42.2 set of repos you upgraded from This of course leaves a mess. If you can’t boot at all even to terminal I suspect the only option is to reinstall

As gogalthorp mentioned to have the same issue with several machines suggest something unique to your upgrade method. Anyway, your best course of action is to backup any importent data first. You could use the install DVD or a live distro (USB stick or DVD) to mount the required partitions etc. The same approach may be used to recreate the initrd if necessary. (No promises here though as we have no idea as to what else may be broken)

The first steps show how to boot up and and use chroot to gain access to the root environment on a given partition

mount /dev/sdaX /mnt
mount --bind /dev /mnt/dev
chroot /mnt
mount /proc
mount /sys

Here’s a real-life experience shared by nrickert (one of our very helpful users) that may be of help to you

Since 13.1 and later, should that not be:

mount -t proc proc /proc
mount -t sysfs sysfs /sys


… oh, and always be certain to boot with the same version of openSUSE that is installed.