Load USB devices

For a while now (since 10.3) I have a bug that is being investigated on my computer when USB devices are plugged in they are not detected (no hotplug).

It’s an ongoing issue with no resolution in sight.
However, there si a workaround to load hotplugged USB devices.
In Konsole if I run (as superuser)

rmmod ehci_hcd
modprobe ehci_hcd 

my devices are loaded.

What I want to know is . . .
How do I create a shortcut on my desktop to run this without me having to type this code every time?
I’d like to just have an icon on my desktop that will run this for me whenever needed.

Using KDE 3.5.xx on Opensuse 11.0

This may help;

sudo zypper in ivman
sudo /sbin/chkconfig ivman on

Once ivman is installed, have a look at the man page.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1 day 23:27, 2 users, load average: 0.24, 0.17, 0.11
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Trust me . . . have been there and tried that long ago . . .

All I am looking for here is help with setting up a shortcut to run the command I noted above.

Ahh ok :slight_smile: Well if you go to YaST -> Security and Users -> Sudo and add
yourself to the sudo file with the two commands /sbin/rmmod
and /sbin/modprobe (so you don’t have to use a password).

Then create your shortcut with the command;

sudo /sbin/rmmod ehci_hcd && sudo /sbin/modprobe ehci_hcd

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 0:28, 4 users, load average: 0.14, 0.12, 0.18
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80


That’s exactly what I was after.

This has come back to bite me.
it worked for me fine following the instructions above but after a reboot it has starting asking me for a password - first time run only - when clicking on the shortcut.

I’m pretty sure I have set things up correctly.

here is a screengrab of the settings in yast > sudo


and also of my shortcut settings


You’ll notice in the shortcut setting I have selected “run in terminal”
If I do not have this checked the shortcut doesn’t work.

Any idea how I can avoid the password prompt in the terminal screen that pops up?