Load HELP!

I am running the 64 bit of openSUSE 11.1 on my computer here. This computer is running the 8800 gtx video card from NVIDIA. This is where my problem arises at is the installation of the drivers to run dual monitor on my system. I was told to download the updates and run them the problem is that after I reboot my computer I goes straight into tty1 mode and I CANNOT get back into the tty7 mode. Can some one please tell me why and how to fix this problem?? plz and thanks

So did you actually install the nvidia driver? If so how? (Manually with the installer from nvidia - or from the repo’s?)

I do believe I did it both ways. After doing the repo I then went and did the manual then rebooted my system where the grub menu loader brought up another version of suse the first version went straight to tty1 so I tried the second one. From here the screens were rotated 90 degrees to the right and I tried everything to rerotate. Then another update sign came up so I tried a new update of the system where it brought me back to the website and I downloaded the driver, rebooted and chose second option. Also went in to tty1 and also can not enter tty7

Another version of suse:\ - I think you are confused.
Look for the default boot (eg; NOT Failsafe)
move your selector to it and

now press backspace, it should delete any text where you can see VGA=.
Remove all text and now type just the number:
and hit enter
at the login type your user name and then password
now type:
then the root password
now type this:
sax2 -r -m 0=vesa
(N.B. the 0 is a zero not a letter)
now reboot
if you don’t get a gui login
login as user and try this at the cli

This should get you back to a proper login UI, though only in vesa (basic graphics)
But from here you can use yast to re-install the nvidia driver.

This should work for you, but not knowing exactly what you have done… we never know.

well after relooking at my computer I realized I said the wrong video card in this computer here I am actually running the Palit GeForce 8600 GT Super Video Card do you think that that will matter. Also I am not entering the failsafe mode that version does work I mean there is actually 2 diff openSUSE options there for some reason

The video card should be fine
describe the options you have at boot.

If you can boot to failsafe do that and post back here when your logged in to the desktop

when I turn on the computer and it loads the grub menu this is what I see

Trace – openSUSE 11.1 -
Xen – openSUSE 11.1 -
openSUSE 11.1 -
Failsafe – openSUSE 11.1 -
Ubuntu 8.10, kernal 2.6.27-7 - generic (/dev/sdb1)
Windows 1
Windows 2

the openSUSE 11.1 - is where is starts at. Now the top 3 options all load straight into tty1 mode and I cannot enter tty7 mode. All I get is a flashing underscore key on a black screen


It looks like you pulled in the Xen and Trace kernels somehow. The reason those will not boot into a graphical display is because you do not have your graphic drivers compiled against them.

Now let me get this correct. You said that you did both methods of install? So does that mean you added the Nvidia repository in Yast and then installed the drivers; THEN you went to the NVIDIA website and compiled your driver using something similar to NVIDIA-Linux-x86_64-180.51-pkg2.run ?

What exactly did you do?


I started yast up, I do believe, it has been about 2 weeks, and went into the system repository and added something to it, I do not remember what the line was. I was then brought to some window that asked me to check some boxes where I selected all that did not bring up a warning msg box. Then after this was done I went to the web site and downloaded the driver from there. Then ran the driver was told to reboot and did. Upon the reboot I saw some more options added to the grub menu. The Trace – openSUSE 11.1 - and the Xen – openSUSE 11.1 - I first tried the original and it went to tty1, also the xen went to tty1. I then tried the trace which went to graphics but only one monitor was working and it was rotated 90 degrees to the right. I tried to rerotate but couldn’t. Then I saw there was a new upgrade so I clikced it. Dled and rebooted, now no GUI was avilable and was loaded into tty1 mode. All of the tty7 modes are not working.

There is your problem. Just randomly clicking things isn’t the best way to go. Usually you have to research what you must install in order for things to install correctly. If you have added the Nvidia Repository then you have the nvidia drivers already installed. You then installed the proprietary Nvidia drivers which caused a mismatch in the kernel for the proprietary driver and the community kernel. So now it’s just a question of which driver do you want to use? The community one or the proprietary one? I think you’ll have less problems with the community repository. Also you’ll need to get rid of the xen and trace kernels unless you need them for a specific reason? The nvidia driver works perfectly fine with the default kernel (the regular openSUSE 11.1 boot option). I’ll tell you how to get rid of those as well once you tell me which driver you want to use.


Reinstall, but before that, print out any HOWTO on NVidia cards for openSUSE. Just follow the standard install, get to know what you have installed and then start expanding.

By reinstall what are you referring too? Are you talking about openSUSE or just the drivers?

He means start from scratch. Full re-install.

Can we try a different way first. I used to fix my windows problems like that and it also took me too long to get my quad boot to work. I have asked my prof and he told me to try starting the xserver and if that does not work to then try to run yast while in tty1 mode and change the settings of the graphics and monitor. I am a newbie to the Linux world so I am trying to learn how to fix the problem other than to just do a fresh reinstall.

I believe I already told you what you did wrong. And then asked you which driver you wanted to use. So until I get a response from that I won’t know what to tell you.


Ok so I am back to square one with the monitors. I ran yast and then uninstalled all of the nvidia drives on my system. So now I have 2 monitors that are mirroring. How do I install the drivers and afterward, if need to, how to I rotate the screens?

Alright, first you must open up Yast Software Repositories. Click Add, then choose Community Repositories. Find Nvidia and put a check next to it and then click Ok. It will add the Nvidia Repository for you. Then open up Yast Software Management search for Nvidia and make sure Yast has your card’s drivers checked to download (it should automatically check the correct drivers for your card). Then choose accept.

Once it’s done downloading restart your computer and boot into failsafe mode. Wait for everything to load then login as root. Type this to set up your Nvidia driver

sax2 -r

Once that’s done then type these commands one by one:

nvidia-xconfig --composite
nvidia-xconfig --render-accel
nvidia-xconfig --add-argb-glx-visuals -d 24

You should be good to go now. Restart with this command

Shutdown -r now

Choose the regular login option at boot and hopefully you’ll have a working Nvidia card and driver. You’ll know if it worked if you see the Nvidia logo when you login.

Good Luck,


Ok well there is no Nvidia repository there. I see a video lan but no Nvidia. What should I do now?

Use the one-click installer from here


Then proceed with reboot, failsafe mode…etc.

Good Luck,


Ok that method did not work. It brought me back to where the init 5 did not work. Is there some other way I can get dual monitors to work.