Hi, opensusers. I’m new in this subjects and I 'd want to try Tumbleweed for the first time.

I’ve tried Ventoy (is an open source tool to create bootable USB drive) to prove Tumbleweed with persistence. It’s create an .dat file. But, in a new session the changes are not saved. Is it possible to create a liveusb of Tumbleweed with persistence?
Many distros (like Ubuntu/MX/LinuxMint …) provide feature for persistence and Tmbleweed is not in the tested list, but i’ve tried.
I know that they are others tools like Rufus, Etcher, mkusb, but I think that Ventoy can work better.
My pendrive is Data Traveller 128 G and i’ve followed all the instructions with Ventoy
Thanks for your attention, saludos a todos, Adiós!

Just get a live image.These helper tools generally do not work with openSUSE

I’m guessing that’s a limitation of the ISO file you likely used for your image running in Ventoy.
First, I’d recommend you verify what options you have by talking to the Ventoy developers (ie submit an issue at the Ventoy github project) but I notice that Ventoy supports a number of formats… If for instance you download the Tumbleweed on VMware Appliance image and run it in ventoy, I’d guess that you’ll have a writable “live” instance.


I have not tried recently. But openSUSE live isos have always had persistence when written to a USB in the recommended way. Maybe you are trying too hard.

Please stop posting this kind of nonsense. Or ask around before you post.

@OP: When you use Etcher or plain linux dd to write the image to raw USB device ( NOT A PARTITION !!! ), it is persistent, i.e. expands the overlay filesystem to the size of the USB device. But … due to how these images are build you’re stuck on the kernel that comes with the live image. Of course there are ways to manually adapt your /boot partition and GRUB, but one should know what they’re doing.

So is. I have verified that it is persistent. In other distros, the partition was limited to 3.6 Gigs, on the other hand with Leap 15.2 3 partitions are created: one for the ISO, another for the MBR and the third occupies the remaining space on the pendrive. I have changed small settings such as the language, the keyboard, I have saved a small text file or passwords in web pages and when starting a new session, the configuration is saved. I have not tried with updates, but I guess as well.

When you first create the iso (assuming you follow the recommended method), only two partitions are created – the iso itself and a small EFI partition for UEFI booting. The third partition (hybrid partition) is created on first use of that USB – first successful boot.

And yes, updating mostly works. But updating kernel or bootloader won’t work because those are used in the early stages of booting before the hybrid partition setup is configured for use.

Don’t use those fancy tools. Use a proven procedure: Changes to the system get saved on the stick.

I don’t know how to rate the thread as fixed. I finally did what is stated in the guide and it worked without having to use any extra tools. I recorded the pendrive (16gb SanDisk Cruzer Blade USB 2.0) as if I were going to install Leap 15.2 and I am going to save all the changes (updates, configurations, documents …). Rebooting keeps the changes. Cheers

Hey, what I posted is entirely based on what is expected.

Have you ever mounted an ISO and then tried to write to it?
Ordinarily it’s mounted an an unwritable ISO-9660…
And it’s the easiest supposition for a utility like ventoy which does not copy the ISO to dis, just mounts the ISO and runs it “as-is.”

And, that is why I recommended deploying an appliance image which is not an ISO, it would be mounted differently and likely read/write.

So, criticism accepted where warranted but not here…


Write a Live image to USB with Etcher or dd and check for yourself:

  1. After boot the overlay fs will expand in the space left on the device
  2. That fs is read-write
  3. FWIW I use this on a 32GB external SSD, which has some basic stuff in my homedir, and allows me to sync some things from my Nextcloud. This works fine, apart from updating the kernel.

So much BS in so little space…

If you download an .ISO file, you download a compressed format, originally targeted at CD/DVD burning.
Hence the a ISO 9660 filesystem is read-only according to its specification.

Typically a separate persistent storage space (persistent overlay) is used in conjunction with a compressed Live OS,
to provide the ability to store data across reboots.

This basically boils down to basic partitioning of the USB drive you’ll be using.
You don’t need any special tools to get this working, but several exist to make life easier.

Here is a pretty thourough explanation of various scenarios:

Actually ISO file itself has no compression as it is a sector-by-sector copy of the original data and this has nothing to do with whether it’s RO or RW.