Live usb stick doesn't work, I/O errors.

Hi all,

I’ve been trying to figure out how to run/install openSUSE from a usb stick for several days. I downloaded the 11.4 .iso from distrowatch & used the following command in Linux Mint to put it on the usb stick.

sudo dd if=openSUSE-11.4-KDE-LiveCD-x86_64.iso of=/dev/sdc

It gets to the loading screen and get stuck. It has a small bar going across, that never finishes. I’ve hit escape to try and get some info, but don’t know what I’m looking for and it’s too much to write down. I did notice there were several I/O errors. I did check the usb for defects and it returned ok, and the md5sum was correct.

I’ve also tried safe settings which takes me to a blueish/black screen and stays there.
No ACPI starts to load and then drops to a shell.

Will someone please advise me how to get this accomplished? I’ve installed many Linux OS’s and I’ve never had this much trouble.

ps. I"ve read the “please read” pre installation page on here, and things just don’t make a whole lot of sense to me.

Hello I do not know if linux Mint has image writer. But with a fast search I found something on mint community usb-imagewriter - Linux Mint Community

Yes I’ve tried that, it doesn’t recognize the .ISO’s. Have a quick look at this thread if you will, there are a few people having this problem.