Live option not showing up in GRUB (on USB)


I’ve been attempting to try out OpenSUSE via the Live option on the ISO. I’ve tried Tumbleweed, Leap, and the specific (much smaller) live iso of Tumbleweed, as well. I’ve also tied multiple snapshots on Tumbleweed. I’ve created multiple live usb disks that have worked fine with other distros. Currently using Rufus on my old laptop for that.

I was told by another OpenSUSE user that Live should be an option and they showed me a screenshot of this. But in place of where it should say live, my GRUB (across all versions) says “Boot from Hard Drive” instead but that doesn’t work either. I just want to be sure it works on my system without a lot of tweaking and that I can get video/audio working. I’ve even tried it in a VM but can’t fully get that sorted either to be able to test it out.

Any info would be brilliant. I’m stuck and just can’t figure out where that GRUB live option is. Thanks so much in advance!
(If you need a screenshot, please let me know.)

Welcome to the openSUSE Forums!
Not clear to me what you are really trying to do.
If you downloaded the full iso (about 4GB image), that image has no “live” option and is only useful for install or upgrade; if you see “Boot from Hard Drive” on the first menu option I guess that you are using the full installer iso.
The Live images are either in Gnome or KDE flavor, are about 900 MB in size and should show “openSUSE Tumbleweed GNOME Live” (or KDE Live) on the first menu option.
If you are using one of those and it doesn’t work, maybe you used an incorrect method to burn the USB image. Please see here for more details.
Please provide more details about what you are trying to do if the above is not enough.

Thanks so much for this info. I’ve received conflicting info about what options are available on which image.

Having said that, I have tried the specific Live iso in multiple DE flavors. Still, there was no option to boot into the live environment, which I found odd. While I’m not ruling out that I messed something up the multiple times I created a USB drive out of that iso, it does boot into grub with no problem and I’ve successfully created live USBs for at least 5-6 other distros that all work perfectly. So, I don’t understand what might be happening on the disc creation that would affect just the OpenSUSE live usb.

Can you think of any reason that I’m not seeing the Live option on the grub menu of the Live iso for OpSE? I’m so frustrated about this. I just want to know how well it works on my system before installing and wondering how much manual setup I’ll have to do for video, sound, networking, etc. I’d also love to get a feel for the distro itself. I do wish that the full DVD size iso (4-5gb) would offer a live option but I know they can put in so many more drivers and other software to get more knowledge of how it will work on one’s system. But, I’m sure there’s a reason they’ve not opted to offer that.

Thanks again for responding. If you have any thoughts on why I’m still not finding a live boot option on the Live iso grub, please let me know. :slight_smile:

Assuming that the live image was downloaded without errors (please check here if in doubt), maybe using Rufus on Win* is not a good idea, as shown by the warning here.
openSUSE images have a special hybrid structure that should be copied to disk or USB bit-for-bit, unlike some other distributions that you may have checked.
That is best done from Linux, even a Live image from another distro, but if Win* is all you have at the moment, there are alternatives to Rufus as shown in the linked support page above.
I cannot think of anything else at the moment, but if you still face problems feel free to ask here.