Lightdm wallpaper changer

Hi,

Sorry if this has been asked before, but how can I activate the wallpaper change feature in Lightdm? I am using openSUSE tumbleweed

Cheers

On 02/14/2012 07:56 PM, megamaced wrote:
>
> Sorry if this has been asked before, but how can I activate the
> wallpaper change feature in Lightdm? I am using openSUSE tumbleweed

-=WELCOME=- new user, but two things:

-i doubt most folks here have even heard of Lightdm (i had not), much
less know how to move wallpaper around in it, so i suggest this is a
question not for the openSUSE forum but rather for a Lightdm forum (at
least there you might find folks who know about wallpaper therein…

-if the question answer had anything to do with openSUSE then you would
need to ask it in the Tumbleweed forum: http://tinyurl.com/3ljwanm

oh, third thing: are you saying that the documention for Lightdm is so
incomplete that it does not even explain something so simple?

again, welcome!!


DD http://tinyurl.com/DD-Caveat
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

If you want to change the background
Look in /etc/lightdm/lightdm-gtk-greeter.conf

And change the value of the “background” key to the full path of your image. But I guess it was already obvious at this point.
The greeter used is specified in the “greeter-session” key in /etc/lightdm/lightdm.conf.

It has replaced gdm in Ubuntu since 11.10.

The op might be looking for the simple lightDM manager
I think openSUSE does not have that app.
Hopefully someone can package it for oenSUSE.

It is available … and to my big surprise, it was installed on my system (I looked in Ubuntu before posting #4). It must have been installed together with xfce or lxde desktop. One can change the background, as you previously mentioned, by editing /etc/lightdm/lightdm-gtk-greeter.conf.

  • I’m not using tumbleweed though.

On 02/14/2012 10:06 PM, please try again wrote:
>> -i doubt most folks here have even heard of Lightdm (i had not)
> It has replaced gdm in Ubuntu since 11.10.

what is Ubuntu?


DD:)
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

Click on the link in your signature! There is a text box at the upper left corner. Enter “Ubuntu” and click “Go” …or select “Ubuntu” in the drop down list and click “Go”. Or go to Wikipedia! Do you see the address bar in your browser? Do you know what a web browser is? Must be on your desktop somewhere … Don’t look in the fridge! It’s not in the fridge…

Thanks, it’s good to know.
Maybe you have an additional repo that I don’t have.
I am using the oss, non-oss, update, packman (all) and xfce repositories.

$ zypper info lightdm
Loading repository data...
Reading installed packages...


Information for package lightdm:

Repository: **Updates for openSUSE 12.1 12.1-1.4**](http://download.opensuse.org/update/12.1/)
Name: lightdm
Version: 1.0.6-1.3.1
Arch: x86_64
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 266.0 KiB
Summary: Lightweight, Cross-desktop Display Manager
...

I have that and I used to use the lightdm displaymanager but I replaced it with kdm due to the bug that I guess is not yet fixed.
I had the problem using lightdm with systemd going to init 3 from int 5 and vice-versa.
What I was referring was the Simple lightDM Manager, a gui to change the lightDM background image.
It is launch via command simple.

On 02/15/2012 12:16 AM, please try again wrote:
> Do you know what a web browser is? Must be
> on your desktop somewhere … Don’t look in the fridge!

looking for chocolate cake in the fridge is more fun than looking for
‘Ubuntu’…

OH, i found it (at
http://www.urbandictionary.com/define.php?term=ubuntu) and we all know
the Internet knows all and never lies, so it must be true:

Ubuntu is an ancient african word, meaning “I can’t configure Debian”


DD Have a lot of fun…
http://tinyurl.com/SUSEonDW

I added the lightdm-kde-greeter (grabbed it from OBS) and it sets up similar functionality as Simple LightDM Manager* in System Settings > System Administration > Login Screen (LightDM) … (i.e. kcmshell4 kcm_lightdm).

Unfortunately, lightdm-kde-greeter (or at least the build I grabbed) is a little too buggy … (I had fair warning that it was going to be).

I also added lightdm-webkit-greeter** and then the “pretty” theme***. Its neat. Would work well with the exceptions that I didn’t see any way to change user session (kde, gnome,…) and also the splash image didn’t seem to work mulitiple monitors (garbled images) … so, IOW, out of the box, it looks like it would only work well for a single X Display, single session type and single monitor. Perhaps with some tweaking is required to expand its functionality…

** Nothing available for openSUSE. Grabbed the source from https://launchpad.net/lightdm-webkit-greeter, tried to build but ran into a number of missing dependencies (some of which I do have). Didn’t feel like messing around with the build config, so googled for an rpm. Found one lightdm-webkit-greeter-0.1.2-2-mdv2012.0.x86_64.rpm Mandriva Cooker Download, inspected it and it was sane, so installed it via rpm.

*** Grabbed it from here: https://github.com/jfbrazeau/lightdm-webkit-pretty-greeter Follow simple (though not very well described) steps to install and then configure.

On the lightdm m/l I came across a link to this greeter: Ubuntu Mac Osx login - YouTube
That’s okay I guess. But it was the follow up post that grabbed my attention:

Pretty nice … makes KDM and GDM look very much like legacy software

Primary Source: ([LightDM] Cool OSX style greeter](http://lists.freedesktop.org/archives/lightdm/2012-September/000303.html)) & [LightDM] Cool OSX style greeter](http://lists.freedesktop.org/archives/lightdm/2012-September/000305.html) ]

Yeah that pantheon greeter in you tube is pretty cool.
I used to prefer lightdm but with systemd
there is a problem switching thru runlevels.

yep. I think I’ll test it out on the w/e

I used to prefer lightdm but with systemd
there is a problem switching thru runlevels.
Can you provide an example, I’d like to test / try to reproduce … while I’ve found other bugs, I don’t have any show stoppers.

At present, running:

rpm -qa lightdm
lightdm-1.4.0-5.1.x86_64

Let’s say I just downloaded the proprietary nvidia graphic card driver
and then i am in runlevel 5, I don’t want to reboot my machine instead
just go straight to init 3, going to init 3 I only see a blank screen with a cursor
blinking instead of the login prompt. I have to reboot my machine every time I want
to use the run level 3. I posted a thread here before, I just don’t know if it is fine now.
Another member told me it was a well known bug.

I use kdm now it is easier, I can go straight to init 3 or i can logout then choose
login in from the console.:slight_smile:

Just press any of Alt-F1 … Alt-F6 to switch to tty1 … tty6. When you go to init 3 from init 5, you are left on tty7 without anything running on it (X server is stopped, and tty7 is not used for text logins).

yep. I know I’m using the -novtswtich, which should prevent the switch back to vt1 (from whence the beast X was spawned! lol! ), so not sure if the essentially blank (other then the stale messages from the prior session) vt is the default behaviour (if not using the -novtswitch) … but in any regard, a full console login is but a Alt-F1-6 away.

The last time I use lightdm, if memory serves those keys respond but falls to the blank screen with a blinking cursor in openSUSE 12.1 atleast on my machine.
A click of a mouse is better IMHO than 2- fingers clicking the keyboard keys, sometimes you are tired of it specially if you always do
it in some blender commands and sometimes need 3-fingers.:wink: