Libvirtd.service could not be found

I installed the KVM hypervisor server and tools through yast successfully.

My AMD cpu is verified to support virtualization.

lscpu:

Virtualization features: 
  Virtualization:        AMD-V

sudo modprobe kvm-amd
lsmod | grep kvm
kvm_amd               200704  0
kvm                  1298432  1 kvm_amd
irqbypass              16384  1 kvm
ccp                   139264  1 kvm_amd
sudo systemctl enable libvirtd
[sudo] password for root: 
Failed to enable unit: Unit file libvirtd.service does not exist.
sudo systemctl status libvirtd
Unit libvirtd.service could not be found.

I tried rebooting my machine but no luck.

Shouldn’t this have been installed when I installed the KVM server and tools? Can’t seem to find any answers on this searching documentation. thanks

https://forums.opensuse.org/t/error-message-failed-to-enable-unit-unit-file-libvirtd-service-does-not-exist/164937

1 Like

Thank you, that worked after installing libvirt which installed a few additional libvirt packages.

2 Likes

Great info, but a little hard to read. Has anyone summarized or created a Knowledge base for these types of errors and Fixes?

Problem: When installing from GUI virt-manager gives the following error:

The libvirtd service does not appear to be installed. Install and run the libvirtd service to manage virtualization on this host.

A virtualization connection can be manually added via File->Add Connection

Fix: Install libvirt

sudo zypper install libvirt

reboot

Hope this makes it easier on the next person!

@offhand well is it really an error, the likes virt-manager can be used to connect to a remote machine running libvirtd for management, then there is virt-viewer for the user to run to connect to a remote instance. In those instances libvirtd is not required…