I have 11 qemu/libvirt vm. Every one has lost internet capabilities. Each had functioning internet.
Each one says connection established during their startup. Each has an internet connection as ip command gives a network (ethernet) name and an ip address. None will ping anything. None will go to any website. Vivaldi browser is on each of them and is not giving any notifications f any problem.
After putting in a search string into browser each one just stalls with cursor circling as waiting for connection to a site but never connects.
At least two had functioning internet yesterday as I used them. libvirtd service is running on host. The issue must be with host as all are not functioning. Did do a zypper dup today. I will look at what was updated…
I am a networking dummy.
Any suggestions? thanks, tom Kosvic
I just noticed these messages from yesterday when viewing logwatch file. They are related to virtnetworkd. Would that be the culprit that caused the vm to lose internet?
If so does message regarding virtnetworkd not shutting give a clue to the cause?
--------------------- Systemd Begin ------------------------
Configuration errors:
PIDFile= references a path below legacy directory /var/run/: 2 Time(s)
Standard output type syslog is obsolete, automatically updating to journal: 12 Time(s)
ERROR: Failed state:
pured.service: 7 Time(s)
xdg-desktop-portal.service: 16 Time(s)
Warning: Found left-over process in control group while starting unit:
virtnetworkd.service(dnsmasq): 2 Time(s)
Warning: Remained running after unit stopped:
virtnetworkd.service(dnsmasq): 4 Time(s)
libvirt Xen daemon admin socket skipped, unmet condition check ConditionPathExists=/proc/xen/capabilities: 1 Time(s)
libvirt Xen daemon read-only socket skipped, unmet condition check ConditionPathExists=/proc/xen/capabilities: 1 Time(s)
libvirt Xen daemon socket skipped, unmet condition check ConditionPathExists=/proc/xen/capabilities: 1 Time(s)
machine-qemu\x2d3\x2dgentoo.scope: Failed to kill control group /machine.slice/machine-qemu\x2d3\x2dgentoo.scope, ignoring: Operation not supported: 2 Time(s)
machine-qemu\x2d5\x2dpopos20.04.scope: Failed to kill control group /machine.slice/machine-qemu\x2d5\x2dpopos20.04.scope, ignoring: Operation not supported: 2 Time(s)
virt-secret-init-encryption.service skipped, unmet condition check ConditionPathExists=!/var/lib/libvirt/secrets/secrets-encryption-key: 2 Time(s)
virtnetworkd.service: This usually indicates unclean termination of a previous run, or service implementation deficiencies.: 2 Time(s)
I ran into this this morning. All running VMs showed “Limited Connectivity”. What I wrote earlier did not work, @tckosvic . Neither did rebooting the VMs. What did work was shutting them down, then starting them again. Wish I could force the behaviour, but have not succeeded. In my case it happened after the laptop was in suspend for ~8 hrs.
Did you mean shutting down (power off) the vm distro from internal processes of the distro or did you mean “forcing off” the vm from vm manager using virtual machine → shutdown → force off?
A bridge device is a physical interface on the hosts system, so the virtual machine is using that and not NAT… I have a couple, sometimes even four bridges running depending on my needs.
ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eno1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000
link/ether 18:60:24:94:ed:f2 brd ff:ff:ff:ff:ff:ff
altname enp0s25
altname enx18602494edf2
3: enp12s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br0 state UP mode DEFAULT group default qlen 1000
link/ether 00:0a:cd:24:d2:d2 brd ff:ff:ff:ff:ff:ff
altname enx000acd24d2d2
4: enp13s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
link/ether 00:0a:cd:24:d2:d3 brd ff:ff:ff:ff:ff:ff
altname enx000acd24d2d3
5: ens4f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000
link/ether 1a:4b:24:c7:fe:fd brd ff:ff:ff:ff:ff:ff
altname enp1s0f0
altname enx1a4b24c7fefd
6: ens4f1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
link/ether 1a:4b:24:c7:fe:fe brd ff:ff:ff:ff:ff:ff
altname enp1s0f1
altname enx1a4b24c7fefe
7: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default qlen 1000
link/ether f2:e6:df:3d:3a:ab brd ff:ff:ff:ff:ff:ff
11: vnet3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br0 state UNKNOWN mode DEFAULT group default qlen 1000
link/ether fe:54:00:3c:d0:a9 brd ff:ff:ff:ff:ff:ff
The default one is /usr/lib/systemd/user/xdg-desktop-portal.service you need to create the admin one in /etc…