libuuid-devel : Yast reporting wrong digest (checksums don't match)

Hi, I have libuuid previously installed, and have decided to install libuuid-devel. However Yast complains of a wrong digest when I attempt the install, saying that the checksum in /var/temp/…/x86_64/libuuid-devel-2.31.1-lp150.7.6.1.x86_64.rpm is not the same as the current checksum. Tells me it’s a big risk to use the file. Not sure if it’s a problem at my end or in the software repo. Can anyone point me in the right direction please. bazzar.

There was a problem with the mirrors yesterday. That seems to be solved (the warning that was up here at the top of the pages is gone). And I just did a YaST > Software > Online Update without problems.

Another member did also report a “wrong digest”. Maybe a hangover from the earlier problem.

Henk, thanks. I hadn’t noticed the mirrors issue. I’m guessing I just need to wait for a day or so, and the Yast error will disappear. bazzar.

I hope that waiting helps. In the meantime, I try to watch how many of these reports are coming. Tha main problem is probably that it is weekend and that going upstream will not help much today.

As I said above, YOU did work, but that only uses the Update repos.

To test, I now installed a package (a font) from the OSS repo. No problem here.

Yes, that’s what I would do.

I just tried to install libuuid-devel.

I don’t need that package. But I tried to install as a check. And I got that same checksum error.

It’s possible that we are both using the same bad mirror. Or it’s possible that something has gone awry.

I will try again after a few hours. In the meantime, I am seeing reports of problems on the various mailing lists.

I saw this as an invitation to install libuuid-devel (after I succeeded to install another package).

I do get the error also. Thus it isn’t just the repo. but certain packages.
I say packages and not just “this” package, because there is another member reporting in another thread (the thread about the broken Update repo) and he wants to update, not to install libuuid-devel.

There’s an open bug report on problems with the update repo.

Bug 1130281: Wrong digest: Installation of update package fails due to checksum mismatches

The original report was for “libapparmor1”. I have the latest version installed since January. I attempted a forced update (update unconditionally in Yast) and I got the digest verification error. So I downloaded the rpm over the web. And it is identical to the rpm that I have saved from when I updated in January. So it looks as if the repo metadata is broken.

I checked for libuuid-devel and the recent one is from the Update repo.

Thus my testing of a package that came from the OSS repo did not reveil much :(.

OTOH, I did a YOU, which installed a list of packages from the Update repo without problems.

I assume we can not solve this from here and have to wait. But a resurrection of a banner message on top of the forum pages might be a good idea.

I had a same problem with updating some packages glibc2-devel and few more with zypper up get stuck on wrong digest checksum. I changed the url to another mirror and solved.

I’m having the same issue on the JeOS image for rPi3: Running zypper up as root after a fresh install I got the same errors reported above. IS there a way to disable these check temporarily? It’s a fresh install and I don’t mind messing it up. Just want to try and get rolling along.

I’ve just tried the libuuid-devel package install [in Yast] again, and this time it’s successful :), there was no checksum difference error.

Maybe the mirror has now synchronised completely, or someone has rapidly fixed the specific files, I don’t know. Either way, thanks to all for your help, without it I might have been tempted to disregard the Yast warnings.


I tried a few hours ago without success, but now it is OK like you found out.

Joy at last. Updating a new Leap 15 install at this moment. It’s slow, as I guess many others are doing the same. Many thanks to whomever sorted out the repositories.

All’s well that ends well. rotfl!