LibreOffice windows always minimized

Hello,

After the next upgrade for Tumbleweed, LibreOffice (version 7.4.1.1) opens with a minimized window.
I have to check the “maximize” box to show the window.
Is it a libreoffice’s bug or Tumbleweed’s bug ?
I can solve this ?
Thank you.

Operating System: openSUSE Tumbleweed 20220914
KDE Plasma Version: 5.25.5
KDE Frameworks Version: 5.98.0
Qt Version: 5.15.5
Kernel Version: 5.19.8-1-default (64-bit)
Graphics Platform: Wayland
Processors: 8 × 11th Gen Intel® Core™ i7-1165G7 @ 2.80GHz
Memory: 7.5 Gio of RAM
Graphics Processor: Mesa Intel® Xe Graphics
Manufacturer: Micro-Star International Co., Ltd.
Product Name: Modern 15 A11M
System Version: REV:1.0

I updated two TW machines earlier today which brought in that version of LO, I’m not seeing the behaviour you describe on either of those systems.

You could create a “Window Rule” to force the window to always open maximised.

(KDE) System Settings -> Window Management -> Window Rules - Add New

I note you’re running Wayland, I’m using X11, don’t know if that’s significant.

Dear all,

I have the same issue with 7.4.1.1.
When starting an odt… document, LibreOffice is starting, but no window is opening (it’s only small in the kicker, but I can’t maximize it). I have to close LibreOffice (right click on the tab in the kicker…), then starting LibreOffice in general, now it is half open, then I have to maximize it and I can choose my last file from the recent files menu. I also can’t open two documents in parallel!
Short: working with LibreOffice is currently hard (and impossible when you normally work with more than one document).
I think this also happened some years ago.

I’m using KDE with X11 and not Wayland.

Best,

Michael

I’m not too sure that’s the same issue as the OP, but until he clarifies the issue…

And again, I’m not seeing that issue either. *.odt documents opened from Dolphin cause LO to launch correctly.

TW:
20220914

LO:
Version: 7.4.1.1 / LibreOffice Community
Build ID: 40(Build:1)
CPU threads: 2; OS: Linux 5.19; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-GB (en_GB.UTF-8); UI: en-GB
Calc: threaded

Have you tried with a new user to see if the issue is some way connected with your user profile?

This issue only appears under special hardware/DE combinations. It won’t dissapear with a freshly created user (but the TO should still try it). In Mageia 8 an other user had same problems: https://bugs.mageia.org/show_bug.cgi?id=30152

I know that there was also an upstream bug filed, but i can’t find it anymore…

P.S.: There are several bugs regarding window size issues at LibreOffice…as example https://bugs.documentfoundation.org/show_bug.cgi?id=151004 This one is for Ubuntu. The issue is indepentend from linux distribution.

It’s the same thing with x11.
How many time have you run librewriter ?
before the last upgrade, i don’t have this bug

You mean Version: 7.4.1.1? Several times today, on two different TW installs, both as real use and as a test case for your reported bug.

before the last upgrade, i don’t have this bug

I don’t dispute that. As I said I’m not seeing the issue, and as@hui wrote in post #5 it appears that “This issue only appears under special hardware/DE combinations.

You have the option of course of downloading an older version of LO directly from:
https://downloadarchive.documentfoundation.org/libreoffice/old/
if you so wish.

@chalu

Apologies :slight_smile:

I am able to replicate this issue, but only if LO is maximized when it is closed. (I don’t normally have LO maximized when I use it, hence I wasn’t seeing the bug).

It seems to be this bug reported at KDE: https://bugs.kde.org/show_bug.cgi?id=459107

Comment #11 of that report states:

This is a LibreOffice bug, fixed in LibreOffice 7.4.2, s. https://bugs.documentfoundation.org/show_bug.cgi?id=150856

I have seen this as I do normally have LO maximised. I have been able to bypass the issue by setting up Special Windows Settings to force the size to maximum until they fix it.

Stuart

I have a version of this problem with my TW laptop. Not only does LO fail to open in full window, it remains as a minimised app in the Task Bar but cannot be opened. Very annoying as I am trying to work, made more difficult now as I have a kernel panic problem on my workstation.

I am trying to install an older version but never done this before.

There is a suggestion in the bug report that this has been fixed in the daily build but no idea how to get this and don’t have a great deal of time to work on it.

@Budgie2

The easiest temporary “fix” would be a window rule, as suggested by myself in post #2 and by @broadstairs in post #9

Thank you for the links. We just have to wait for version 7.4.2 :slight_smile:
With version 7.4.1, i run libreoffice centre –> maximize (it’s quick) and then i run writer or calc.

7.4.1.2 is now in TW snapshot 20220922

Revert changes that cause problems with the libreoffice window in KDE, bsc#1203502