LibreOffice paste issue

Hi,

I can’t seem to paste anything and keep the formatting : when pasting, it just paste unformatted text, which is the only option when I open the window from menu “paste special” ?

How can I rid of that behaviour ? I already tried to start with a new profile, deleting the libreoffice directory in .config (Im on linux Suse, the loff version is 5.0.2.2).

Is anybody have the same issue ? Is this a misconfiguration or a bug ?

Thanks

I’ve had numerous issues with copy/paste when using LO …

When copying the source, if you select and then use ctrl-C to copy, it invariably works OK when pasting into LO. (At least that’s what seems to work for me…)

Everything OK here, just pasted your message in Writer, it offers “plain text” and “HTML” in Paste-special.
Then changed formatting and copy-paste to Writer, Impress and Calc are all OK.
I too used Ctrl+C to copy, if it does matter.

BTW, the current LO version is 5.0.4.2, you may update your system.

If it is a special copy-paste that doesn’t work for you, please add the relevant details.

Ctrl+C does change one thing only : it keeps the justify format… That’s all. Bold text, exponants and everything else is gone.

The issue was there before and did remain after the update.

The paste-special window offers only unformatted paste, which at least is coherent. I don’t know why I can’t have any other option.

What would you like as relevant details ?

I made a few other tests and I can reproduce your finding only when copying from a .pdf file displayed by Evince document viewer in Gnome. Apparently Evince only copies unformatted text to the clipboard and that is what LO-Writer offers to paste.

When copying from a .pdf file displayed by Okular in KDE, I have the choice to copy as text or graphics and LO-Writer offers to paste accordingly.
When copying from Firefox or Evolution I’m offered to paste HTML or unformatted text.
When copying from Apache OpenOffice I’m offered to paste a full spectrum of options.
And the same is true when copying from other apps (Calc, Impress, Draw…) from both LibreOffice and OpenOffice.

So, if you need further help, please specify:

  1. what document format you are copying from;
  2. what application you are using to display that document;
  3. what you are actually copying (formatted text, HTML, image …);
  4. what document format you are pasting into and/or what LO application you are using to paste;
  5. possibly, what Desktop environment you are using (KDE, Gnome or whatever).

Hope this helps.

Thanks Orso for all the effort. :slight_smile:
But actually this is an internal issue, within the application : when I copy/paste a paragraph from a document inside the same document but somewhere else. The same issue remains from document to a new or existing one. All in LibreOffice.

It’s really too bad because I really like the easy tweaky thing of opensuse but I have to many strange bugs with it. I already had to remove it from one of my other computers and it seems that I will have to do the same with this one… :frowning:

Just for information… I’m not seeing the behaviour you describe.

Take a look at this screenshot:

http://paste.opensuse.org/view/raw/bf389681If you believe you’ve found a reproducible bug in LO then I’d file a report at:

https://bugs.documentfoundation.org

Hi Paul, you are actually using a newer version (5.1.0.3) on Tumbleweed, but I can’t reproduce here either with 5.0.4 on Leap Gnome.
Even tried with older .sxw documents from OpenOffice 1.0… NOPE, not reproducible!

@sussu_dio
Is the problem still visible with a fresh, simple document?
Was the problem document originally saved by another version or application? Is it very large, does it contain large graphics or is it in any way “unusual”?

Sorry we can’t help with what we cannot see…

I join a picture to show you : http://hpics.li/8a53c82

This is a new document that I formatted, not even yet saved. The formatted text is at top and the paste at bottom… Ctrl+C and Ctrl+V as usual…

And I 'm not sure it is a bug if I’m the only one on earth… :\

I’m going to try to uninstall all libreoffice packages and reinstall them and if after that it still remains, I guess I will have to go back to fedora…

Just one more possibility… if you are using Gnome.

libreoffice-gtk3 at times does odd things: check that it is NOT installed.

Other desktop integration packages (libreoffice-gnome or libreoffice-kde4) are safe as I see here and should generally be installed according to the desktop environment in use.

Hmmm… :frowning:

I’ve just tried again using LO Versions 4.4.3.2 and 5.1.0.3 - Ctrl-C/Ctrl-V copies and pastes without loss of formatting.

And I 'm not sure it is a bug if I’m the only one on earth…

Interestingly if you Google “libre writer copy paste special” there are hits on problems that are quite similar to that you’re experiencing.

These two for example:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/554183
https://bugzilla.redhat.com/show_bug.cgi?id=1099927
although the latter is claimed to be fixed.

I’m going to try to uninstall all libreoffice packages and reinstall them and if after that it still remains, I guess I will have to go back to fedora…

May be worth a try, but it has been my experience that on linux an ‘uninstall/reinstall’ seldom fixes anything.

I’m sorry, there is nothing constructive I can suggest, other than a bug report to LO.

@OrsoBruno Actually they were all installed : libreoffice-gtk3, libreoffice-gnome and libreoffice-kde4 and as I write this they still are. But after rethinking, I really wonder why it does install all of them by default as one should be enough… gnome or gtk3 as I run gnome desktop.

Anyway I did remove one package during the reinstall which was hunspell-32bit and it does function properly now. It is a spell checker which may did conflict with something else.

@tannington So it was definetely a bug but a bug during installation. Either the installer misbehaved or didn’t noticed : I run a 64 bit and it installed the 2 hunspell packages available - hunspell and hunspell-32bit, it looks like that wasn’t a good idea…
So I dearly thank you all for your support and I can at last marked this thread as SOLVED. :slight_smile:

Nice to know your problem is solved :slight_smile:

As to the root cause, I doubt that it is an installer bug, at least not a “clean standard install” bug in the Leap install DVD.
The DVD does NOT have hunspell-32bit, and it is not automatically called in during update.
I did a clean Gnome install and neither libreoffice-gnome nor libreoffice-gtk3 were automatically installed.
BTW libreoffice-gtk3 is no replacement for libreoffice-gnome, but a (troublesome) addon AFAIK.
I did a clean KDE install in a VM and libreoffice-kde4 WAS automatically installed.
Both installs called in hunspell (the 64bit flavour).

So your setup with all three libreoffice-gnome, libreoffice-gtk3 and libreoffice-kde4 appears to be “non-standard” in a way or another; maybe your system was upgraded from a prior version or install attempt?

Anyway, we learned something in this journey.

Very strange… Because it is a clean install. I just installed postgresql, mariadb, apache2 and haven’t even finished the whole configuration. Maybe hunspell-32bit came along with some small packages I installed. If I recall : nemo, parcellite (which keyboard shorcut does not work by the way…) and http-yast2-server and … That’s all.

I didn’t try to tweak (and did not put my head into) libreoffice yet with all latex stuff. So I really don’t know why I had all those libreoffice-(gnome/gtk3/kde4) checked… :sarcastic:

Yes indeed… :wink:

Tek Ma’te…