LibreOffice crash with "invalid pointer" message

Since I “zypper dup” into 15.0, LibreOffice crash on almost any action: opening an existing file, going to Tools → Options, etcetera. Starting it from konsole I only get messages of the kind

*** Error in `/usr/lib64/libreoffice/program/soffice.bin': free(): invalid pointer: 0x00007f0ec3819d78 ***

with only the “pointer” number changing.

What I’ve tried:

  • Clean the user profile so the program generates a new one
  • Started the program on “safe mode”
  • Test with a different (newly created) user
  • Uninstall and reinstall the program
  • Change to the LibreOffice:/6.0/ repo
  • Install/uninstall the kde4/gtk2/gtk3 integration packages

and still crash, even on “safe mode”. It’s completely unusable. For now I’m using the rpms from LibreOffice’s website, but I’d prefer to use openSUSE binaries.

It seems I’ve solved it!

Somehow, several files from previous installs remained in place, messing up the whole package. In fact, after uninstalling the whole thing (once more) I run “whereis libreoffice” on konsole, and it gave me two addresses! /usr/lib64/libreoffice and /usr/share/libreoffice where still there were with several files, even after uninstalling the the whole package. I just deleted the folders, reinstalled LibO and now everything works!

Thank you for posting the solution :slight_smile: