LibreOffice corrupted after kernel update

Accepted the daily update, this time to kernel 4.4.126-48 plus several other updates on 18.04.2018

Starting LibreOffice shows it to be corrupted, blinking back and forth, menus going round and round, etc. All LibreOffice applications are affected.

This on a AMD Ryzen 7 system, any similar experiences ??

Sounds like a graphics driver issue.

Try to uninstall drm-kmp-default and see if it helps. I think I read there are some (known) problems with the latest one.

First tried unconditional update of all LibreOffice files in Yast, no change, still corrupted

uninstall drm-kmp-default … not a good idea, after uninstall LibreOffice still corrupted, reboot, black screen with a big mouse pointer, game over.

re-install system, with all updates via repositories … libreOffice corrupted and system hangs when mouse pointer touches something not to its liking, I had this particular hanging up problem when first installed 42.3 but updates seemed to mitigate the issue.

LibreOffice is the only one displaying these problems so far …

And what desktop are you using?

You shouldn’t have had to reinstall the system. You probably should have been able to login to IceWM (press Ctrl+Alt+Backspace twice to get back to the login screen) or text mode (Ctrl+Alt+F1), or you could have tried booting with “nomodeset” to use a generic driver…
Just installing drm-kmp-default again should have fixed your system.

Anyway, try to uninstall libreoffice’s GNOME and/or KDE integration depending on what’s installed:

Looks as though we can close this thread as LibreOffice is again working as it should, why it stopped or started working is a mystery though …