LibreOffice 6.0 on Leap 42.3

Is there a repository for upgrading Leap 42.3 to LibreOffice 6.0? Or should we download the source rpm from LibreOffice?


There is a version 6.0 for Tumbleweed in the repos.

For 42.3, you should probably go to here to get it, as there is an RPM available. Therefore, you do not need to download the source:

I cannot vouch for its suitability for 42.3, but I do not see why not, IMHO.

Good luck, come back and let us know.

there is a LO 6.0 repo in the works for 42.3
unfortunately it isn’t complete
it’s been build for the upcoming LEAP 15
so I’d wait a few days to see if the maintainers update packages for 42.3
while the LEAP 15 and the TW repo might work but it is more probobly it will break your system as TW (and leap 15) is way ahead of LEAP it uses newer QT and GTK packages
if you’d really want to use LO 6 and don’t want to wait for the repo to come online get the rpm’s from the document foundation
apparently the build for LEAP 42.3 (and 15) have failed
I’d wait for the maintainers to fix the build rather then using 3rd party repo’s

Thanks to all who tried to help. Guess I need to work on my patience again.

Or, you could install the flatpak version of LO6:


Install flatpak, add flathub repo, search for libreoffice pacakge and install via flatpak command. That’s it :slight_smile:

Does the sandboxed version of LibreOffice really run happily within the flatpak environment without any dependency issues arising?

I had briefly tested it on TW, it worked fine there.

LO6 flatpak depends on the GNOME runtime, which is why you need to install this flatpak first, before installing LO flatpak. It still worked fine in KDE as far as I can tell. As far as I remember it will auomatically ask you to install the runtime when you install LO6 flatpak.

There is also KDE runtime available, but since LO needs Gnome they won’t do much in this case.

I installed from this repository yesterday. is up and working fine here.