Libre Office - Writer - Ask LibreOffice Toolbar disappears when viewed on second screen

I have the same problem described in the this post: # [Toolbar disappears when viewed on second screen](

The menu bar disappears when I open Writer and move it to another screen on a three screen setup. The menu is only there when Writer is displayed on the primary screen.

Cannot find a fix on the net. Anyone think this is a Suse issue or an Libre Office Issue?

System info below.

Linux localhost.localdomain 5.14.21-150500.55.65-default #1 SMP PREEMPT_DYNAMIC Thu May 23 04:57:11 UTC 2024 (a46829d) x86_64 x86_64 x86_64 GNU/Linux

Operating System: openSUSE Leap 15.5
KDE Plasma Version: 5.27.9
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8
Kernel Version: 5.14.21-150500.55.65-default (64-bit)
Graphics Platform: X11
Processors: 12 × Intel® Core™ i7-8750H CPU @ 2.20GHz
Memory: 31.1 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630
Manufacturer: HP
Product Name: OMEN by HP Laptop 15-dc0xxx

Version: (X86_64) / LibreOffice Community
Build ID: 420(Build:2)
CPU threads: 12; OS: Linux 5.14; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-GB (en_BW.UTF-8); UI: en-US
Calc: threaded

Now you see it. Primary screen.

Now you don’t . Secondary screen.


May be similar to this KDE Discuss forums issue – <Some windows don’t show up on the taskbar>

  • And no, we didn’t find a solution there apart from narrowing the issue down to Wayland + KDE Plasma + LibreOffice …

  • And, AFAIK, a Bug Report hasn’t been raised to date – neither by KDE nor, by LibreOffice …

This first came to light with the Menu-bar missing in LibreOffice I then found the Menu-bar missing in quit a few other applications.

I found the cause was the KDE Application menus daemon

To fix the issue you need to go to System Settings → Startup and Shutdown → Background Services, and uncheck Application menus daemon Apply and reboot.`