Libre Office startet nicht mehr!

Bein Start von der “Console” kommt folgende Fehlermeldung:

The application cannot be started.
The component manager is not available.
(“InvalidRegistryException: file:///usr/lib64/libreoffice/program/services/postgresql-sdbc.rdb: unexpected attribute “environment” in <component>”)
terminate called after throwing an instance of ‘com::sun::star::uno::DeploymentException’

Hat jemand eine Idee, wie ich den Fehler beheben kann?

Welche openSUSE Version verwendest du?
Welche Version von LibreOffice hast du von wo installiert?

Und welche Pakete genau?

rpm -qa | grep -i libreoffice

Eine Liste deiner Repos könnte evtl. auch hilfreich sein:

zypper lr -d

Dein Fehler scheint zumindest mit dem postgresql Plugin zusammenzuhängen.
Entweder du hast eine inkompatible Version von libreoffice-base-drivers-postgresql installiert, oder da ist was kaputt, würde ich sagen.

Probier also mal das Paket neu zu installieren (rechts-klick in YaST darauf und “Unbedingt aktualisieren” auswählen).
Oder, wenn du sowieso zu keinen postgresql Datenbanken verbinden willst, kannst du es auch komplett deinstallieren.

Hallo wolfi323,

libreoffice-base-drivers-postgresql und libreoffice-base-extensions sind in Yast als installiert markiert aber ohne Größenangabe. Mit unbedingt aktualisieren komme ich auch nicht weiter. Die Größenangabe bleibt leer. Ich benutze OS 13.1, 64 bit. Macht es Sinn Libreoffice zu deinstallieren und neu zu installieren? Die Libreoffice-Version ist 4.1.5.3-17.1; die neuere 4.3.0.1-177.2, wird auch angezeigt. Wenn ich sie installieren will, kommt eine Fehlermeldung

YaST2 conflicts list - generated 2014-06-25 09:52:04

libicuuc.so.52.1()(64bit), benötigt von libreoffice-4.3.0.1-177.2.x86_64, wird von keinem Repository angeboten

 ] libreoffice-4.3.0.1-177.2.x86_64 beschädigen durch Ignorieren einiger Abhängigkeiten


 ] libreoffice-4.3.0.1-177.2.x86_64 nicht installieren

YaST2 conflicts list END

Wahrscheinlich weil die Pakete so klein sind.

Die Libreoffice-Version ist 4.1.5.3-17.1; die neuere 4.3.0.1-177.2, wird auch angezeigt. Wenn ich sie installieren will, kommt eine Fehlermeldung

Scheinbar hast du das LibreOffice:Factory repo eingebunden, das enthält nämlich seit gestern 4.3.0.1. Außerdem scheinst du das Repo für Factory zu haben, denn libicuuc.so.52.1 gibt es nicht in 13.1 wie ja die Fehlermeldung sagt.
Also entferne das bitte unbedingt. Und installiere das Paket libreoffice-base-drivers-postgresql in der Version 4.1.5.3 neu. Bzw. sollten alle libreoffice Pakete die selbe Version haben!

Falls es dann immer noch nicht geht, poste bitte die Sachen um die ich gebeten habe.

Falls du LO 4.3 verwenden willst, musst du auch alle 4.3 Pakete installieren. 4.3 ist aber noch nicht stabil.
Falls du LO 4.2.4 haben willst, gibt es seit gestern ein eigenes Repo dafür, LibreOffice:42.

Hallo wolfi323,
das LibreOffice:Factory repo war der Störenfried. Jetzt läuft wieder alles, nachdem ich libreoffice-base-drivers-postgresql wieder auf 4.1.5.3 downgradet habe, läuft alles wieder. Danke für Deine Hilfe!