"libqtdbus.so.4: undefined symbol", after kde update

I salute the openSUSE community!

After a kde update (i don’t remember exactly the updated packages) I try to open the Comsol Multiphysics software (it is a fluid dynamics code) and I am encountering an error message:

“symbol lookup error: usr/lib64/libqtdbus.so.4: undefined symbol”

Next, the program closes unexpectedly soon after it loads the graphical interface.
Note that I did not encountered any of such errors before this kde update!

After a quick search at the forums, I found similar errors when starting Skype or other QT applications:

My configuration is openSUSE 13.1. I even tried to reinstall Comsol Multiphysics, but it did not solve the problem.

Hope you have some inspiring ideas!

Please post the output of the following command and encase it in code blocks (# in the toolbar when you reply to this post):

zypper lr -d

Hello Miuku.
Here is the output:

zypper lr -d 
#  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                               | Service
 1 | Packman Repository        | Packman Repository                 | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/                          |        
 2 | games:tools               | games:tools                        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/games:/tools/openSUSE_13.1/             |        
 3 | google-earth              | google-earth                       | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/earth/rpm/stable/x86_64                                |        
 4 | home:frispete:acroread    | home:frispete:acroread             | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/frispete:/acroread/openSUSE_13.1/ |        
 5 | libdvdcss repository      | libdvdcss repository               | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.1/                                              |        
 6 | nVidia Graphics Drivers   | nVidia Graphics Drivers            | Yes     | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/13.1/                                         |        
 7 | repo-debug                | openSUSE-13.1-Debug                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/                    |        
 8 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1/                                   |        
 9 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/                           |        
10 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/                      |        
11 | repo-oss                  | openSUSE-13.1-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                          |        
12 | repo-source               | openSUSE-13.1-Source               | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.1/repo/oss/                   |        
13 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                                         |        
14 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/                                 |        
15 | science                   | science                            | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/science/openSUSE_13.1/                  |  

Furthermore I post the exact error message from the Comsol Multiphysics:

This is the error message when I initialize the program:

kde4-config: symbol lookup error: /usr/lib64/libQtDBus.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv
kde4-config: symbol lookup error: /usr/lib64/libQtDBus.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv

And when it crashes (soon after the graphical interface is loaded) it says:

# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007f84965bd6b8, pid=6356, tid=140209381099264
# JRE version: 6.0_20-b02
# Java VM: Java HotSpot(TM) 64-Bit Server VM (16.3-b01 mixed mode linux-amd64 )
# Problematic frame:
# C  [libgobject-2.0.so.0+0x1a6b8]  g_object_get_qdata+0x18
# An error report file with more information is saved as:
# /usr/local/comsol44/bin/hs_err_pid6356.log
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
./comsol: line 1519:  6356 Aborted                 ${MPICMD} ${FLROOT}/bin/${ARCH}/comsollauncher --launcher.ini ${LAUNCHERINIFILE} ${LAUNCHERARGS} ${MPILAUNCHERARGS}



I guess you can ignore that, it seems not related to your crash.
Apparently it comes with its own libqt4 libraries (in a different version than your system’s), and then calls the system’s kde4-config which would need the system’s libqt4 instead.

And when it crashes (soon after the graphical interface is loaded) it says:

# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007f84965bd6b8, pid=6356, tid=140209381099264
# JRE version: 6.0_20-b02
# Java VM: Java HotSpot(TM) 64-Bit Server VM (16.3-b01 mixed mode linux-amd64 )
# Problematic frame:
# C  [libgobject-2.0.so.0+0x1a6b8]  g_object_get_qdata+0x18

This looks familiar.
Try to set a different (than oxygen) GTK2 and/or GTK3 theme in Configure Desktop->Application Appearance->GTK.
Does this help?

I tried different combinations of GTK2 (e.g. Clearlooks, Redmond, Adwaita) and GTK3 (Adwaita, emacs) themes , however the problem insists.

Ok then.
Just to verify: can you run “kde4-config” manually? Or do you get the same undefined symbol error?
Try e.g. “kde4-config --prefix”.

As I said this doesn’t look related, but a failing “kde4-config” could probably cause a crash some time later (because some variable is uninitialized or similar).

OTOH, I remember now where I’ve seen this crash exactly:
E.g. Bug #1241532 “fatal error on eclipse Problematic frame: C [lib...” : Bugs : openjdk-7 package : Ubuntu
(that’s the first one I found right now, there are quite some threads about this here in the forums as well)

So is your program based on Eclipse?
AFAIR this crash was caused by an incompatibility with WebKit. If you tell Eclipse to use mozilla instead, it should not crash.
See here: java - Eclipse continue crashing - Stack Overflow

Or, according to an Ubuntu bug report I just read, this might help as well:

export SWT_GTK3=0

Here is the output from kde4-config --prefix

nikoscham@attis:~> kde4-config --prefix

Is it normal?
I don’t get any error messages here.

I think Comsol is not based on Eclipse.
I also tried the following:

export SWT_GTK3=0


as you said. However it doesn’t solve the problem…

And what’s more important, it doesn’t crash.

Preloading the system’s libQtCore and/or libQDBus might help with that kde4-config problem then.

LD_PRELOAD="/usr/lib64/libQtDBus.so.4 /usr/lib64/libQtCore.so.4" xxx

But it might cause other problems as well.

I think Comsol is not based on Eclipse.

Hm, but it might do something similar, or use the same classes.
The crash at least is the same as in Eclipse. I did findtwo of the threads in our forum now:

At least for some people, just changing the theme helped, for others changing the browser to mozilla helped.
If it is not eclipse-based, I don’t know how you would do that though. I don’t know Comsol MultiPhysics at all and googling doesn’t find anything either.
Do you have any eclipse.ini in your home directory (in some subfolder)? Or something similar, comsol.ini e.g.
Maybe try to specify “-Dorg.eclipse.swt.browser.DefaultType=mozilla” as command line option.

Other than that, I have no idea, sorry.
As this is apparently is commercial software, you might try to contact the vendor/publisher for help.

Ok, It seems that I am wrong.
Comsol is probably eclipse based - I found the comsol.ini in the comsol directory:

# Settings for COMSOL desktop on glnxa64
-install ../..

It seems that it calls some eclipse libraries.
The solution, however, reported at the other threads in the forum (e.g. change GTK2 theme to Raleigh) does not solve the problem.
Where should I specify the option “Dorg.eclipse.swt.browser.DefaultType=mozilla” ?

Thank’s for your help up to now!

In this file AFAIK.
It is already in there (but commented out), so just remove the comment sign (the ‘#’ at the beginning of the line) with a text editor, i.e. change the line marked in red to just:


I’m not completely sure that this will help you. IIRC at least one of the users having problems could not fix crashes completely by doing that.
In most cases it helped though.

One other source of crashes seems to be a Google Hangout plugin for eclipse. Not sure if that would even possibly apply to you though in the case of Comsol.

It doesn’t help:(,
and as far as I remember, I have never installed Google Hangout.
Nevertheless, thank you for your help and your time…