Hi to all,
I have a fresh install of 64bit TUMBLEWEED (im new in opensuse) and tried to install a program and this error came up:

“ cannot open shared object file: No such file or directory”.
I tried : ln -s /lib/ /lib/ but that didnt work. I got the same error.
I cant find in /usr/lib. Maybe im missing a library, I tried to search ncurses library through YAST without luck. How can I solve this problem?


PS: Move this thread to the correct forum

zypper se curses gives:

S  | Name                     | Summary                                                     | Type   
   | gambas3-gb-ncurses       | The ncurses component for Gambas                            | package
   | libncurses5              | Terminal control library                                    | package
i+ | libncurses5-32bit        | Terminal control library                                    | package
i  | libncurses6              | Terminal control library                                    | package
   | libncurses6-32bit        | Terminal control library                                    | package
   | libyui-ncurses-devel     | Libyui-ncurses header files                                 | package
   | libyui-ncurses-doc       | Libyui-ncurses documentation                                | package
   | libyui-ncurses-pkg-devel | Libyui-ncurses-pkg header files                             | package
   | libyui-ncurses-pkg-doc   | Libyui-ncurses-pkg documentation                            | package
i  | libyui-ncurses-pkg9      | Libyui - yast2 package selector widget for the ncurses UI   | package
   | libyui-ncurses-tools     | Libyui-ncurses tools                                        | package
i  | libyui-ncurses9          | Libyui - Character Based User Interface                     | package
   | ncurses-devel            | Development files for the ncurses6 terminal control library | package
   | ncurses-devel-32bit      | Development files for the ncurses6 terminal control library | package
i  | ncurses-utils            | Tools using the new curses libraries                        | package
   | ncurses5-devel           | Development files for the ncurses5 terminal control library | package
   | ncurses5-devel-32bit     | Development files for the ncurses5 terminal control library | package
   | ocaml-curses             | OCaml bindings for ncurses                                  | package
   | ocaml-curses-devel       | Development files for ocaml-curses                          | package
   | perl-Curses              | Terminal screen handling and optimization                   | package
   | perl-CursesWidgets       | CursesWidgets Perl module                                   | package
i  | python-curses            | Python Interface to the (N)Curses Library                   | package
i  | python3-curses           | Python Interface to the (N)Curses Library                   | package
i  | qemu-ui-curses           | Curses based UI support for QEMU                            | package


The best help can only be given by people that are informed about the problem with the maximum available information. Please, please, please, why those secrets? Simply tell what you tried to install and how instead of this very vague remark. When that installing was done using the CLI, please copy/paste what you did and got in the post.

I tried to install Xilinx ISE, but running the xsetup in konsole (installer) the libncurses error shows up. This program is for 64bit but add a 32bit programs to work it. Im new to opensuse and this is a fresh install.

As you can see in the list you provided ncurses5 is available in openSUSE TW, and a small test shows me it can be alongside ncurses6 and it does provide the missing lib.
So try

sudo zypper in libncurses5

EDIT: the package also contains the missing
EDIT2: remove the symlinks you created before doing so, and never again link a library file to another one :).

Hi Knurpht, thanks for your answer, it works. How can you tell that library in the list was not installed? for future references.Thanks.

The first column, i means installed.

From this command:

knurpht@Knurpht-HP:~> zypper se --provides libtinfo
Gegevens van opslagruimte laden...
Lezen van geïnstalleerde pakketten...

S  | Naam              | Samenvatting             | Type  
i+ | libncurses5       | Terminal control library | pakket
   | libncurses5-32bit | Terminal control library | pakket
i+ | libncurses6       | Terminal control library | pakket
i+ | libncurses6-32bit | Terminal control library | pakket