libc.so(GLIBC_2.14)(64bit)

From the first time that i tryed suse on the 64bit version i have a conflict problem,after i install a few applications
Yast, zypper and so on they are asking for the “libc.so(GLIBC_2.14)(64bit)”,does anybody know where to find it and install it
Any help its welcomed

Don’t install that, you will break your system.

What openSUSE version are you using, btw?
OpenSUSE 13.1 comes with glibc 2.18, which should of course also be good enough for applications needing glibc 2.14.

Which applications are this?
Probably they are for a different distribution and therefore have wrong (for openSUSE at least) dependencies.
Or maybe they are for a different openSUSE version.

Try to tell zypper/YaST to ignore that missing dependency.
Or, even better, try to find suitable packages for your openSUSE version.

I am using 13.1, i have the probolem since i installed 9.3 ages ago,I am using linux part time and most of the times a suse version probably i resolved the problem in the past(even if i broke the OS…sorry).Now i dont want to reinstall the system fron scatch,but i would like to have the multimedia apliccations like gsteamer or a KDE multimedia app

Just install the corresponding packages for your openSUSE version from Packman, you do not need a different libc.

See here f.e.:
http://packages.opensuse-community.org/

For KDE multimedia apps, Kaffeine and Amarok should be installed by default.
After you installed all codecs, they should also be able to play all multimedia files.

If you still get dependency problems, please post your repo list:

zypper lr -d

And please post the exact error message.

Thanks, I will do it more comlicated,i hope not impossible
Lets live the multimedia a part, i think its all ready too late.
I am working with a readyNAS device running debian something,trying to install owncloud-client (repository no 2 on zypper list ) its coming up the problem with the dependencies
Any help its welcomed

zypper

zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

—±-------------------------------------±-------------------------------------±--------±--------±---------±-------±----------------------------------------------------------------------------------------------------------±-------
1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/11.3/ |
2 | isv:ownCloud:desktop | isv:ownCloud:desktop | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/isv:/ownCloud:/desktop/openSUSE_13.1/ |
3 | nvidia | nvidia | Yes | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/13.1/ |
4 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/usb-HL-DT-ST_DVDRAM_GSA-E40L_P01070320063518-0:0,/dev/sr0,/dev/sr1 |
5 | openSUSE-13.1-Language-Add-on_13.1-0 | openSUSE-13.1-Language-Add-on 13.1-0 | Yes | No | 99 | yast2 | iso:///?iso=openSUSE-13.1-Addon-Lang-i586.iso&url=file:///media/disk/home-nikh/Downloads/ |
6 | openSUSE-13.1-NonOSS-Add-on_13.1-0 | openSUSE-13.1-NonOSS-Add-on 13.1-0 | Yes | No | 99 | yast2 | iso:///?iso=openSUSE-13.1-Addon-NonOss-BiArch-i586-x86_64.iso&url=file:///media/disk/home-nikh/Downloads/ |
7 | openSUSE:13.1:NonFree | openSUSE:13.1:NonFree | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/13.1/repo/non-oss/ |
8 | openSUSE:13.1:Update | openSUSE:13.1:Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/ports/update/13.1/ |
9 | openSUSE_13.1 | openSUSE_13.1 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_13.1/ |
10 | openSUSE_Tumbleweed | openSUSE_Tumbleweed | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_Tumbleweed/ |
11 | packman-essentials_ | packman-essentials | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_12.3/Essentials/ |
12 | packman-multimedia_ | packman-multimedia | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/Multimedia/ |
13 | repo-debug | openSUSE-11.3-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/distribution/11.3/repo/oss/ |
14 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/11.3/repo/non-oss/ |
15 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/11.3/repo/oss/ |
16 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | http://download.opensuse.org/source/distribution/11.3/repo/oss/ |
17 | wine | wine | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_13.1/ |

Sorry, but that is a complete mess! No wonder that you have problems…

You have some 11.3 and 12.3 repos in there, and Tumbleweed. They likely cause problems, so remove them.
In particular those:

1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/11.3/ | 
10 | openSUSE_Tumbleweed | openSUSE_Tumbleweed | Yes | Yes | 99 | rpm-md | [http://download.opensuse.org/reposit...SE_Tumbleweed/](http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_Tumbleweed/) | 
11 | packman-essentials_ | packman-essentials | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_12.3/Essentials/ | 
13 | repo-debug | openSUSE-11.3-Debug | No | Yes | 99 | NONE | [http://download.opensuse.org/debug/d...11.3/repo/oss/](http://download.opensuse.org/debug/distribution/11.3/repo/oss/) | 
14 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | yast2 | [http://download.opensuse.org/distrib.../repo/non-oss/](http://download.opensuse.org/distribution/11.3/repo/non-oss/) | 
15 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | [http://download.opensuse.org/distrib...11.3/repo/oss/](http://download.opensuse.org/distribution/11.3/repo/oss/) | 
16 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | [http://download.opensuse.org/source/...11.3/repo/oss/](http://download.opensuse.org/source/distribution/11.3/repo/oss/) | 

And you could remove that one as well, and add the full Packman repo instead (as done by that guide I linked to):

12 | packman-multimedia_ | packman-multimedia | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/Multimedia/ | 

Either use YaST->Software Repositories, or run:

sudo zypper rr 1 10 11 12 13 14 15 16

Then your update repo (8) has a completely wrong URL: http://download.opensuse.org/ports/update/13.1/
It should be http://download.opensuse.org/update/13.1/, so change that in YaST->Software Repositories.

And you miss the non-oss-updates repo. This shouldn’t cause the problem you have, but better add it anyway.
The URL is: http://download.opensuse.org/update/13.1-non-oss/

After you cleaned up the repos, you should probably run “sudo zypper dup” to get your system to a clean 13.1 state.
You probably have some mixture of 11.3, 12.3, 13.1 and Tumbleweed installed at the moment.

You are right this is a giant mess,
new list by zypper of repos
zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

–±-------------------------------------±-------------------------------------±--------±--------±---------±-------±----------------------------------------------------------------------------------------------------------±-------
1 | isv:ownCloud:desktop | isv:ownCloud:desktop | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/isv:/ownCloud:/desktop/openSUSE_13.1/ |
2 | nvidia | nvidia | Yes | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/13.1/ |
3 | openSUSE-13.1-Language-Add-on_13.1-0 | openSUSE-13.1-Language-Add-on 13.1-0 | Yes | No | 99 | yast2 | iso:///?iso=openSUSE-13.1-Addon-Lang-i586.iso&url=file:///media/disk/home-nikh/Downloads/ |
4 | openSUSE-13.1-NonOSS-Add-on_13.1-0 | openSUSE-13.1-NonOSS-Add-on 13.1-0 | Yes | No | 99 | yast2 | iso:///?iso=openSUSE-13.1-Addon-NonOss-BiArch-i586-x86_64.iso&url=file:///media/disk/home-nikh/Downloads/ |
5 | openSUSE:13.1:Update | openSUSE:13.1:Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/ports/update/13.1/ |
6 | openSUSE_13.1 | openSUSE_13.1 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_13.1/ |
7 | wine | wine | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_13.1/ |
l

MESSAGE OF CONFLICTS:

zypper dup
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See ‘man zypper’ for more information about this command.
Loading repository data…
Reading installed packages…
Computing distribution upgrade…
83 Problems:
Problem: nothing provides systemd needed by SuSEfirewall2-3.6.305-2.4.1.noarch
Problem: nothing provides avahi = 0.6.31 needed by avahi-lang-0.6.31-16.6.1.noarch
Problem: nothing provides p11-kit needed by ca-certificates-1_201312011643-4.1.noarch
Problem: nothing provides empathy = 3.10.2 needed by empathy-lang-3.10.2-12.3.noarch
Problem: nothing provides evolution = 3.10.2 needed by evolution-lang-3.10.2-9.1.noarch
Problem: nothing provides file-roller = 3.10.2 needed by file-roller-lang-3.10.2-8.3.noarch
Problem: nothing provides gdm = 3.10.0.1 needed by gdm-lang-3.10.0.1-5.1.noarch
Problem: nothing provides gedit = 3.10.2 needed by gedit-lang-3.10.2-9.3.noarch
Problem: nothing provides libc.so.6(GLIBC_2.17) needed by gettext-runtime-32bit-0.18.3.2-5.1.x86_64
Problem: nothing provides gnome-desktop = 3.10.2 needed by gnome-desktop-lang-3.10.2-5.1.noarch
Problem: nothing provides gnome-keyring = 3.10.1 needed by gnome-keyring-lang-3.10.1-6.1.noarch
Problem: nothing provides gnome-sudoku = 3.10.2 needed by gnome-sudoku-lang-3.10.2-4.1.noarch
Problem: nothing provides gnome-system-monitor = 3.10.2 needed by gnome-system-monitor-lang-3.10.2-4.2.noarch
Problem: nothing provides gnome-terminal = 3.10.2 needed by gnome-terminal-lang-3.10.2-6.1.noarch
Problem: nothing provides gnome-vfs2 = 2.24.4 needed by gnome-vfs2-lang-2.24.4-19.4.1.noarch
Problem: nothing provides gnumeric = 1.12.7 needed by gnumeric-lang-1.12.7-2.5.4.noarch
Problem: nothing provides gucharmap = 3.10.1 needed by gucharmap-lang-3.10.1-4.1.noarch
Problem: nothing provides gvfs = 1.18.3 needed by gvfs-lang-1.18.3-5.1.noarch
Problem: nothing provides p11-kit needed by ca-certificates-1_201312011643-4.1.noarch
Problem: nothing provides libQtXmlPatterns.so.4 needed by apper-0.8.0-11.4.1.i586
Problem: nothing provides libc.so.6(GLIBC_2.15) needed by libcurl4-32bit-7.32.0-2.1.2.x86_64
Problem: nothing provides libpurple = 2.10.9 needed by libpurple-lang-2.10.9-4.18.1.noarch
Problem: nothing provides libqt4-devel-doc = 4.8.5 needed by libqt4-devel-doc-data-4.8.5-5.9.4.noarch
Problem: nothing provides libc.so.6(GLIBC_2.15) needed by mozilla-nspr-32bit-4.10.6-1.1.x86_64
Problem: nothing provides nautilus = 3.10.1 needed by nautilus-lang-3.10.1-4.1.noarch
Problem: nothing provides orca = 3.10.2 needed by orca-lang-3.10.2-4.5.noarch
Problem: nothing provides parted = 2.4 needed by parted-lang-2.4-34.5.1.noarch
Problem: nothing provides pulseaudio = 4.0.git.270.g9490a needed by pulseaudio-lang-4.0.git.270.g9490a-8.1.noarch
Problem: nothing provides typelib(Gtk) needed by python-cupshelpers-1.4.2-2.4.1.noarch
Problem: nothing provides quadrapassel = 3.10.2 needed by quadrapassel-lang-3.10.2-4.1.noarch
Problem: nothing provides seahorse = 3.10.1 needed by seahorse-lang-3.10.1-4.1.noarch
Problem: nothing provides tar = 1.26 needed by tar-lang-1.26-19.4.1.noarch
Problem: nothing provides texlive-texconfig >= 2013 needed by texlive-collection-basic-2013.74.svn30372-11.4.1.noarch
Problem: nothing provides texlive-seetexk >= 2013 needed by texlive-collection-binextra-2013.74.svn30307-11.4.1.noarch
Problem: nothing provides texlive-tex4ht >= 2013 needed by texlive-collection-htmlxml-2013.74.svn30307-11.4.1.noarch
Problem: nothing provides totem-pl-parser = 3.10.0 needed by totem-pl-parser-lang-3.10.0-4.1.noarch
Problem: nothing provides upower = 0.9.23 needed by upower-lang-0.9.23-2.4.1.noarch
Problem: nothing provides vinagre = 3.10.2 needed by vinagre-lang-3.10.2-4.1.noarch
Problem: nothing provides libOSMesa.so.8 needed by wine-32bit-1.7.21-350.1.x86_64
Problem: nothing provides yast2-ruby-bindings >= 1.0.0 needed by yast2-add-on-3.0.3-4.1.noarch
Problem: nothing provides yast2-ruby-bindings >= 1.0.0 needed by yast2-iscsi-client-3.0.1-2.4.1.noarch
Problem: nothing provides yast2-ruby-bindings >= 1.0.0 needed by yast2-ldap-client-3.0.2-2.4.1.noarch
Problem: nothing provides yast2-ruby-bindings >= 1.0.0 needed by yast2-slp-server-3.0.1-2.4.1.noarch
Problem: nothing provides libOSMesa.so.8 needed by wine-1.7.21-350.1.i586
Problem: nothing provides libc.so.6(GLIBC_2.14)(64bit) needed by gettext-tools-0.18.3.2-5.1.x86_64
Problem: nothing provides libc.so.6(GLIBC_2.17) needed by gettext-runtime-0.18.3.2-5.1.i586
Problem: nothing provides libc.so.6(GLIBC_2.14)(64bit) needed by mozilla-nss-certs-3.16.1-1.2.x86_64
Problem: nothing provides libc.so.6(GLIBC_2.14)(64bit) needed by mozilla-nss-3.16.1-1.2.x86_64
Problem: nothing provides libc.so.6(GLIBC_2.15) needed by mozilla-nspr-4.10.6-1.1.i586
Problem: nothing provides kdebase4-runtime >= 4.11 needed by mozilla-kde4-integration-0.6.4-38.3.i586
Problem: nothing provides libc.so.6(GLIBC_2.14)(64bit) needed by libsoftokn3-3.16.1-1.2.x86_64
Problem: nothing provides libc.so.6(GLIBC_2.14)(64bit) needed by libnsssharedhelper0-1.0.10-1.3.x86_64
Problem: nothing provides libc.so.6(GLIBC_2.14)(64bit) needed by libfreebl3-3.16.1-1.2.x86_64
Problem: nothing provides libstdc++.so.6(GLIBCXX_3.4.15) needed by MozillaFirefox-30.0-3.1.i586
Problem: nothing provides gpg2 = 2.0.22 needed by gpg2-lang-2.0.22-4.1.noarch
Problem: nothing provides tracker = 0.16.3 needed by tracker-lang-0.16.3-2.5.1.noarch
Problem: nothing provides texlive-pdftex-def >= 2013 needed by texlive-collection-latex-2013.74.svn30308-11.4.1.noarch
Problem: nothing provides marble = 4.11.3 needed by marble-data-4.11.3-22.2.noarch
Problem: nothing provides liferea = 1.10.4 needed by liferea-lang-1.10.4-2.4.1.noarch
Problem: nothing provides kdebase4-openSUSE = 13.1 needed by kdebase4-openSUSE-lang-13.1-6.5.1.noarch
Problem: nothing provides gnome-user-share = 3.10.1 needed by gnome-user-share-lang-3.10.1-4.2.noarch
Problem: nothing provides gnome-settings-daemon = 3.10.2 needed by gnome-settings-daemon-lang-3.10.2-14.2.noarch
Problem: nothing provides gnome-control-center = 3.10.2 needed by gnome-control-center-lang-3.10.2-12.2.noarch
Problem: nothing provides glib2 = 2.38.2 needed by glib2-lang-2.38.2-8.1.noarch
Problem: nothing provides wallpaper-branding-openSUSE needed by gio-branding-openSUSE-13.1-2.13.1.noarch
Problem: nothing provides evolution-data-server = 3.10.2 needed by evolution-data-server-lang-3.10.2-10.13.noarch
Problem: nothing provides evince = 3.10.0 needed by evince-lang-3.10.0-18.2.noarch
Problem: nothing provides eog = 3.10.2 needed by eog-lang-3.10.2-12.1.noarch
Problem: nothing provides devhelp = 3.10.2 needed by devhelp-lang-3.10.2-12.1.noarch
Problem: nothing provides coreutils = 8.21 needed by coreutils-lang-8.21-7.12.1.noarch
Problem: nothing provides cheese = 3.10.2 needed by cheese-lang-3.10.2-12.1.noarch
Problem: nothing provides python(abi) = 2.7 needed by apparmor-utils-2.8.2-4.13.1.noarch
Problem: nothing provides apparmor-parser(CAP_SYSLOG) needed by apparmor-profiles-2.8.2-4.13.1.noarch
Problem: nothing provides anjuta = 3.10.2 needed by anjuta-lang-3.10.2-14.11.noarch
Problem: nothing provides aisleriot = 3.10.1 needed by aisleriot-lang-3.10.1-17.6.noarch
Problem: nothing provides libc.so.6(GLIBC_2.14)(64bit) needed by unrar-5.0.11-2.1.6.x86_64
Problem: nothing provides libc.so.6(GLIBC_2.17) needed by libmysqlclient18-32bit-5.5.33-2.2.x86_64
Problem: nothing provides libstdc++.so.6(GLIBCXX_3.4.15)(64bit) needed by MozillaFirefox-30.0-3.1.x86_64
Problem: nothing provides libstdc++.so.6(GLIBCXX_3.4.15)(64bit) needed by MozillaFirefox-30.0-3.1.x86_64
Problem: nothing provides libc.so.6(GLIBC_2.15)(64bit) needed by mozilla-nspr-4.10.6-1.1.x86_64
Problem: nothing provides libc.so.6(GLIBC_2.15)(64bit) needed by mozilla-nspr-4.10.6-1.1.x86_64
Problem: kernel-desktop-devel-2.6.34.10-0.6.1.x86_64 requires kernel-devel = 2.6.34.10-0.6, but this requirement cannot be provided
Problem: kernel-source-3.11.10-17.1.noarch requires kernel-devel = 3.11.10-17.1, but this requirement cannot be provided

ANY IDEAS…

Yes, you miss the standard 13.1 repo, so add that: (sorry, I missed that)

sudo zypper ar http://download.opensuse.org/distribution/13.1/repo/oss/ openSUSE:13.1

And you haven’t corrected the URL of the update repo (#5 now) yet. Do that.

And you removed the non-oss repos completely now. That’s fine if you don’t want stuff like flash-player.
If you do need that, add them:

sudo zypper ar http://download.opensuse.org/distribution/13.1/repo/non-oss/ repo-non-oss
sudo zypper ar -f http://download.opensuse.org/update/13.1-non-oss/ repo-update-non-oss

You do have the non-oss Addon-CD which contains the same, but at the moment you won’t get any updates.

Then the “zypper dup” should work.

Thank you very much, i will do what you say
meanwhile i just put the zypper working,hopping for the best,i don’t like very much what its saying
Here in Athens its midnight,max i will do a clean installation early in the morning
I hope you don’t mind to bookmark your id
Thanks for everything,sorry for my english,my keyboard and so on…