is "missing"--but it is on my system

I did a zypper dup and I got the following:

edward@nohostname:~> sudo zypper dup                                                                                                                                    
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' fo
r more information about this command.                                                                                                                                  
Loading repository data...                                                                                                                                              
Reading installed packages...                                                                                                                                           
Computing distribution upgrade...
3 Problems:
Problem: xf86-video-amdgpu-0.0.01~git.1446607417.92e7c93-1.1.x86_64 requires, but this requirement cannot be provided
Problem: rekonq-2.4.2-5.1.x86_64 requires, but this requirement cannot be provided
Problem: python3-pycurl- requires, but this requirement cannot be provided

Problem: xf86-video-amdgpu-0.0.01~git.1446607417.92e7c93-1.1.x86_64 requires, but this requirement cannot be provided
 Solution 1: Following actions will be done:
  deinstallation of ipset-kmp-desktop-6.25.1_k4.1.6_3-1.19.x86_64
  deinstallation of hdjmod-kmp-desktop-1.28_k4.1.6_3-20.80.x86_64
  deinstallation of ipset-kmp-desktop-6.25.1_k4.2.1_1-1.22.x86_64
  deinstallation of hdjmod-kmp-desktop-1.28_k4.2.1_1-20.82.x86_64
 Solution 2: keep obsolete kernel-desktop-4.1.6-3.1.x86_64
 Solution 3: break xf86-video-amdgpu-0.0.01~git.1446607417.92e7c93-1.1.x86_64 by ignoring some of its dependencies

**Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c): **

I looked, and indeed is in the /lib64 directory as a link to

Since this file is already there, I have no idea how to resolve this. Any ideas?

Output of zypper lr -u:

#                   | Alias              | Name                        | Enabled               | GPG Check                  | Refresh | URI                            
1 | Google             | Google                      | Yes | (r ) Yes | Yes     |                                   
2 | google-chrome      | google-chrome               | Yes | (r ) Yes | Yes     |                            
3 | packman-essentials | packman-essentials          | Yes | (r ) Yes | Yes     |
4 | repo-non-oss       | openSUSE-Tumbleweed-Non-Oss | Yes | (r ) Yes | Yes     |                          
5 | repo-oss           | openSUSE-Tumbleweed-Oss     | Yes | (r ) Yes | Yes     |                              
6 | repo-update        | openSUSE-Tumbleweed-Update  | Yes | (r ) Yes | Yes     |                               

I can’t replicate.

Because I’m not running KDE on my TW, I don’t have your first 2 packages already installed but I do have the same version python3-pycurl already installed.

When I ran “zypper dup” (and tried again with “zypper up” with no diff) your incompatibility warning did not come up.

If no one else is seeing your problem, maybe choose the option to “break” the dependency and continue?
You can prepare beforehand for rolling back this update either using YAST or a full backup (or if you’re on BTRFS you can just use snapper)

You can check later that the issue isn’t real and launch rekonq


This rather looks like a conflict of the kernel packages.
kernel-desktop has been dropped in favor of kernel-default, which wants to replace kernel-desktop.
But the packages ipset-kmp-desktop and hdjmod-kmp-desktop prevent the removal of kernel-desktop.
And xf86-video-amdgpu (the new AMD driver) likely requires the latest kernel because of the amdgpu kernel module.

So choose Solution 1, and the upgrade will hopefully work.

Why it complains about I don’t know, but maybe the latest version depends on kernel 4.3.0, so the problem would actually be that glibc cannot be upgraded but is required by some other packages…

That worked. Thanks!

Any idea why they moved to kernel-default?

They “merged” kernel-desktop and kernel-default, so to say, to not have to maintain two separate kernel packages.

They were nearly identical meanwhile anyway.

Here’s the relevant mailinglist discussion: