LG S1 EXPRESS DUAL

Hello,I’m a first timer with linux and now I’m thinking that maybe trying it out on the laptop wasn’t such a good idea…

The laptop is an LG S1 EXPRESS DUAL
Intel core duo T2500 2Ghz
ATI x1600
1Gb RAM
realtek audio (don’t know exactly which model)
and a DVD recorded suposedly called super multi DVD drive or something alike.

The problem is that neither the sound or the DVD drive work, and I don’t know exactly why.

I was wondering if anyone has managed to get suse 11 working
on this model or any similar lg ones, and if they could lend me a hand.

Thank you

Here is the full system information, in case it´s of any help.

System
Model : LG Electronics S1-P333B

Processor
Model : Genuine Intel(R) CPU T2500 @ 2.00GHz
Speed : 2GHz
Cores per Processor : 2 Unit(s)
Threads per Core : 1 Unit(s)
Type : Mobile, Dual-Core
Integrated Data Cache : 2x 32kB, Synchronous, Write-Thru, 8-way, 64 byte line size
L2 On-board Cache : 2MB, ECC, Synchronous, ATC, 8-way, 64 byte line size, 2 threads sharing

System
Platform Compliance : Intel Centrino Mobile Technology
Mainboard : LG Electronics ROCKY
BIOS : Phoenix Technologies LTD RKYWSF13 (06/07/2006)
Bus(es) : ISA X-Bus PCI PCIe IMB PCMCIA CardBus USB FireWire/1394 i2c/SMBus
Multi-Processor (MP) Support : No
Multi-Processor Advanced PIC (APIC) : Yes
Total Memory : 1GB DDR2 SO-DIMM

Chipset
Model : LG Electronics 955XM/945GM/PM/GMS/940GML Express Processor to DRAM Controller
Front Side Bus Speed : 4x 166MHz (664MHz)
Total Memory : 1GB DDR2 SO-DIMM
Memory Bus Speed : 2x 332MHz (664MHz)

Memory Module(s)
Memory Module : Samsung M4 70T6554CZ3-CE6 512MB DDR2 SO-DIMM PC2-5300U DDR2-666 (5-5-5-13 3-18-5-3)
Memory Module : Samsung M4 70T6554CZ3-CE6 512MB DDR2 SO-DIMM PC2-5300U DDR2-666 (5-5-5-13 3-18-5-3)

Video System
Adapter : ATI Mobility Radeon X1600 (PS3.0, VS3.0 418MHz, 256MB 468MHz Integrated Graphics)

Storage Devices
FUJITSU MHV2100BH 100GB (SATA150, NCQ, 8MB Cache) : 93GB (C:) (D:)
HL-DT-ST DVDRAM GSA-4082N (ATA33, DVD±RW, CD-RW, 2MB Cache) : N/A (G:)

Peripherals
LPC Hub Controller 1 : LG Electronics 82801GBM (ICH7-M) LPC Interface Controller
LPC Legacy Controller 1 : T1 15-00h
Audio Device : LG Electronics 82801G (ICH7) High Definition Audio
Audio Codec : Realtek Semiconductor 880 High Definition Audio
Audio Codec : Lucent/Agere Systems (Was: AT&T MicroElectronics) TOSHIBA Software Modem
Serial Port(s) : 8
Parallel Port(s) : 1
Disk Controller : LG Electronics 82801GBM/GHM (ICH7-M) Serial ATA Storage Controller
USB Controller 1 : LG Electronics 82801G (ICH7) USB Universal Host Controller
USB Controller 2 : LG Electronics 82801G (ICH7) USB Universal Host Controller
USB Controller 3 : LG Electronics 82801G (ICH7) USB Universal Host Controller
USB Controller 4 : LG Electronics 82801G (ICH7) USB Universal Host Controller
USB Controller 5 : LG Electronics 82801G (ICH7) USB 2.0 Enhanced Host Controller
FireWire/1394 Controller 1 : LG Electronics PCIxx12 OHCI IEEE 1394 Host Controller
CardBus/PCMCIA Controller 1 : TI PCIxx12 Cardbus Controller
SMBus/i2c Controller 1 : Intel 801xx/63xx SMBus

Network Services
Network Adapter : Intel(R) PRO/Wireless 3945ABG Network Connection - Minipuerto del administrador de paquetes (Ethernet, 54Mbps)

It may be possible to get sound working … but I am puzzling over your Linux version.

Is that openSUSE-11.0 ? or is it SLED-11 or SLES-11 ?

There is a guide here for openSUSE (not for SLED/SLES, although some of that might help): SDB:AudioTroubleshooting - openSUSE

Note the criteria for functioning sound sound be the speaker test in that guide, where only 1 of those 3 tests need to function to prove your sound functions.