Leap scanner recognition. Can I make my scanner recognisable?

Leap will not recognise my scanner.

The CanoScan LiDE 220, completely supported by Sane, would not work on 13.1 because the backend version with 13.1 was 1.0.23 so I downloaded the latest sane backends from the sane project and the latest xsane package. I compiled these and installed them to get the support required. The compiled backend was 1.0.24 and it worked.

I now find that the backend package supplied with Leap is 1.0.24 but the scanner is not recognised. The /etc/udev/rules.d/56-sane-backends-autoconfig.rules file has the LiDE 210 but not the 220 (by USB code, 0x04a9/0x190a but not 0x04a9/0x190f). /etc/udev/rules.d/55-libsane.rules also has the 210 but not the 220. Also the /etc/sane.d/gensys.conf file has the 210 but not the 220.

If I were to edit these three files to include the 220 would the device be recognised. I am assuming that because the 1.0.24 backend package that I downloaded and compiled worked with the 220, the package shipped with Leap will also work.

Are there any further files to edit?

My /etc/udev/rules.d/55-libsane.rules from the compiled packages has:

Canon CanoScan LiDE 210

ATTRS{idVendor}==“04a9”, ATTRS{idProduct}==“190a”, MODE=“0664”, GROUP=“scanner”, ENV{libsane_matched}=“yes”

Canon CanoScan LiDE 220

ATTRS{idVendor}==“04a9”, ATTRS{idProduct}==“190f”, MODE=“0664”, GROUP=“scanner”, ENV{libsane_matched}=“yes”

I hope that someone can help or I may just have to dive in!

Hi pblewis

Have you got the CanoScan Lide 220 running on Leap 42?

I am on 13.2 and have bought a 220 scanner too. And I am ended up in the same situation as you. I have also read your other post of when you where on 13.1 and upgraded to the developversion of sane-backends. On 13.2 the sane-backends version is also 1.0.24, but the 220 scanner is not included.

I have added usb ID 04a9:190f in the 3 files:

My system can see the scanner:


found USB scanner (vendor=0x04a9 [Canon], product=0x190f [CanoScan], chip=GL848+) at libusb:001:002

But scanimage don’t work:

scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

The 220 scanner is mentioned in the man-page of sane-genesys, but the chip GL848+ is not. Could it be a newer version of CanoScan Lide 220 with a newer chip that we have bought?


Hi janoleholm I have had to restore my sane installation so here are a few things to consider.

  1. If you install the Google Chrome browser it will pull in the openSuse packages and kill your hard work. If you have already installed Chrome it will work fine but any browser update will kill your scanner operation.

  2. You have to have a group called “scanner” and any user wishing to use the scanner must be a member of that group.

  3. When you have completed the ./configure, make, make install on the sane backends package you have to copy the tools/udev/libsane.rules file to /etc/udev/rules.d/ so assuming you are at the base of the sane-backends on your file system (in my case this is ~/development/sane-backends-git20151127) do the following:

sudo cp tools/udev/libsane.rules /etc/udev/rules.d/55-libsane.rules
  1. Compile and install the xsane package if you wish to use it. NOTE that I had to perform the following edit before I could compile the xsane package:
sed -i -e 's/png_ptr->jmpbuf/png_jmpbuf(png_ptr)/' src/xsane-save.c

and also install the gimp-devel package.

I hope that this helps you get your 220 scanning.

One day the openSuse package will catch up with the sane backends and all this will be unnecessary.

Hello, I am using Lide 210 on 3 Laptops ( 2 with oS 13.2 32-bit, 1 13.2 64-bit) I encountered no problems w ith recognition. However recognition failed with Leap 42.1 on Oracle VM latest version. Ebkr