Leap network installation: Trying to cnnect to wifi

I downloaded then booted the Leap network installation iso file. Firstly, I’m asked to choose authentication method, which is WPA-PSK in the router configuration. Then I was asked to enter the ESSID. I enter the network name and the router MAC address (Numbers wre separated with “:”) in the second try. Both failed. At last, I choose passphrase then entered the network password.
The error I got is DHCP configuration failed.

I suggest you make a simple interface to choose the wireless network from a list of available networks then enter password like other distributions installers in the next version. This way doesn't seem user-friendly.

Note: This bug existed in OpenSUSE 13.2 network installation. I avoided it by using an Ethernet cable, which was configured automatically.

Yes, this has been a problem.

It seems to be fixed in Tumbleweed. But I guess the fix was too late for 42.1.

I should add:

I am prompted for ESSID. I enter the network name (SSID).
I am then prompted for the authentication type. I select WPA-PSK.
I am next prompted for key. I enter that.

Then I’m told the IP address and the installer begins to download.

Are you sure it’s asking for the ESSD?
Although I haven’t run the install as you’ve described, I’m pretty sure it wants the SSD.

Also, if this is a private access point, maybe you can just drop security for an hour (approx the time to install. Actually, most of my LEAP installs finished downloading in approx 30 minutes).

Yes, use a wired network cable as another option.


I’m not clear when in the process you did this but I recently installed Leap 42.1 on a new machine with a WiFi connection through a router and it was simplicity itself to connect before the installation; the machine being replaced was a Windows machine and there was already a WiFi printer on the network. This was picked up and installed without any problems. My friend was really impressed at how easy it all was.