LEAP 42.3: installing Broadcom driver in a MacBook

Running openSUSE 4.23 on a MacBook, and I want to set up wifi. This MacBook uses a proprietary Broadcom chipset (BCM4322).

I downloaded broadcom-wl-6.30.223.271-9.7.src.rpm driver (called the Linux STA 64-bit driver), and then got stuck. I’m a new user, and I can’t figure out how to install this proprietary driver. It’s just sitting in my download folder. I tried to get YaST to install it, but I was really just fumbling around. Any suggestions on using the command line or YaST to install this driver would be very appreciated.

There should be no need to compile the drivers. You’ll want the broadcom-wl-kmp-default and broadcom-wl packages.

Download from here…
https://software.opensuse.org/search?utf8=✓&q=broadcom
…and install with the package manager (kernel package first).

I would install broadcom-wl and broadcom-wl-kmp-default from Packman:
http://packman.links2linux.org/package/broadcom-wl

But before, i would update my System per LAN-Cable…
Than you can enable the Packman Repo and install it with (as root):

zypper in broadcom-wl broadcom-wl-kmp-default

Thank you very much for your suggestion! I was able to get wifi running!

Thank you!!! It works now!!rotfl!

Whoops…I replied in the wrong place! :stuck_out_tongue:

Thanks very much for your help! It works now!