Leap 42.2, Asus and Nvidia

Hi there opensuse team and users

I recently got a new laptop to replace my ancient Asus A7k. Its a lovely ASUS ROG GL752VW-DH71.

I’ve tried to install Leap 42.2 several times without much success. I understand that it is an optimus platform. Accordingly I’ve following the bumblee instructions. I’ve tried both btrfs and ext4 filesystems for both home and root partitions. Neither has changed the end result.

During my latest install attempt, I got to the point where the NVIDA drivers (easy way) were installing but encountered soft-locks (this has been typical of every attempt thus far…very annoying) that wouldn’t go away for the last two rpms. I rebooted, and wasn’t able to login with my stated user id, and default kernel (hung at text login). Zo I thought I’d resume using debug kernel. I finished installing the rest of the rpms, and finished the bumblebee config steps (Perhaps not the best idea, but it was late, I was frustrated, and had little sleep). Now for debug and regular kernel and regular safemode, I boot, get to text login. This looks alive long enough for me to type 4 characters (i.e. root) as login credentials, then it hangs.

The only way I can login to linux at this point is debug, safe mode. By some small miracle I get a graphical login and can get into plasma.

When I run optirun --status, it tells me that X is inactive and discrete video is likely on. optirun glxgears tells me that secondary GPU driver could not be loaded.

Any suggestions would be helpful (please tell me I don’t need to reinstall again!). I’ve also tried ‘intel_pstate=disable’ and ‘nomodeset’ or ‘nouveau.modprobe=0’ after doing research within the forums. Unfortunately this hasn’t moved me any further.

I know I should be including various diagnostics, but its been awhile since I had to build drivers so bear with me. Let me know what is needed so I don’t waste anyones time


Do these machines initially ship with Microsoft Windows environments? Was everything functioning normally when you bought the laptop?

My Acer device is also an Nvidia optimus platform. In general, both openSUSE Leap and Tumbleweed has installed correctly and fine this while. Had blanked out the entire harddisk including the recovery partitions before I proceeded with installing openSUSE from recordable optical disc media. What I am suggesting at, is that the base installation of openSUSE is not really different from most Linux operating systems: the kernel and core system files go in, GRUB2 and the master boot record is written, as far as X and most desktop environments are concerned the standard openSUSE x86_64 installation media comes with the standard choices. In other words, what baffles me is that you seem like you are using some openSUSE derivative or openBuild ISO image hence the installation process seems quite “advanced” in a way.

I could be wrong, but imho the mentioned setup process simply seems too complicated from the successes I have had with Leap 42.2 this while.

DO NOT USE the regular NVIDIA drivers with bumblebee you must use the nvidia-bumblebee driver but you first must remove any regular NVIDIA drivers you have installed

Nope standard install from DVD of downloaded ISO image. Yes it had windows 10 installed and that seemed to work ok but I didn’t spend much time in that ecosystem.

I did try to leave setup as dual boot so that may have messed up things. I’m hoping not.

So I followed these instructions.

They suggest using bumblebee install followed by easy way regular nvidia. Is this not the right instruction set ? Sounds like it’s not…

Hmmmm they have changed the instruction perhaps the NVIDIA driver has been modified. I don’t have Optimus so need to see if an Optimus user picks up the thread. In the past it was a definite no no to use the regular driver there was a special nvidia-bumblebee package

OK, well hopefully an NVIDIA user picks up. Seems like Optimus is a bit of a headache.

Yes it is I use NVIDIA but not Optimus .

If me I’d follow the instruction to the letter. If it does not work then just uninstall what you installed. You may also want to look at prime


An alternative to bumblebee

I’ve tried but the CPU soft lock generally screws things up duing the last two packages of the nvidia install. Unfortunately don’t get much with regular intel chip. I believe it’s known that it’s not supported well. I guess that would
Be something I could post in the installation forum.

Thanks for the experimental suggestion I had seen that but figured it was leap 42.1’only. Guess it can’t hurt to try.

Just a quick note that I’ve had some traction with people on NVIDIAs board. While they typically don’t supply bumblebee support on that board, individuals will at least look at it to see if its actually an NVIDIA problem or a bug related to bumblebee itself. If I get a solution to my problem, I’ll be certain to share it here.