Leap 42.1 with XEN Hypervisor boots but logging out or runlevel 3 crashes X / Desktop

Hello, Still new to Linux so please bear with me.

**Issue: **openSuSE Leap 42.1 with XEN Hypervisor boots properly but when logging out or accessing runlevel 3 shows a black screen. **
Hardware: **Motherboard: ASUS z10pe-d16 ws - (video: ASPEED AST2400 32MB).

From here on, “Server” is this machine with above hardware running openSUSE Leap 42.1.

Here is the full story:

  1. Download openSuSE Leap 42.1 from official link. & Prep Server Hardware.
  2. Partition/format Clean install openSUSE selecting KDE desktop. --success
  3. Boot > select default grub menu item > boot. --success
  4. Login with different users > logout. --success
  5. Login > Yast2 > Virtualization > Install Xen Hypervisor {Xen server, Xen tools} --success
  6. Reboot > select "openSUSE Leap 42.1 with Xen hypervisor
    " > boot. --success 1. Login > Logout --FAIL
  • Presented with black screen (sometimes with cursor blinking top left). At this point, the entire X windows crashes.

  • No response to CTRL + F1 or CTRL + Fxx or any keys including CTRL + ALT + DEL.

  1. Hard Reset! > select default grub menu item (without Xen) > boot > Login > Logout --success
  2. $
    systemctl set-default multi-user.target --success 1. Reboot > select "openSUSE Leap 42.1 with Xen hypervisor
    " > boot > runlevel 3. --success 1. Using laptop > PuTTY ssh > login root > $
    startx > KDE Logon screen comes up on server. --success 1. On server, Login > Logout or CTRL+Fx --FAIL
  3. Try again: Hard Reset! > "openSUSE Leap 42.1 with Xen hypervisor
    " > boot > runlevel 3. --success 1. $
    startx > KDE Logon screen comes up > Logout or CTRL+Fx --FAIL

a) Let’s try it all over again. --FAIL
b) Let’s try it all over again. --FAIL
c) Let’s try it all over againAt step 5, this time, set the Repositories to Update Only (disable others incl. install source) and download the latest versions of Xen Server & tools… --FAIL

d) Try again: Repeat steps from 2 but this time, select LXDE, continue to step 5, set the Repositories to Update Only (disable others incl. install source) and download the latest versions of Xen Server & tools and continue to other steps. --FAIL

e) Try again: Repeat steps from 2 but this time, select GNOME, continue to step 5, set the Repositories to Standard & Update Only (disable others incl. install source) and download the latest versions of Xen Server & tools and continue to other steps. --FAIL

Also tried at Grub menu selecting:
“Advanced Options for openSUSE Leap 42.1 (with Xen hypervisor)”
> Xen hypervisor, version 4.5.2_04-9 > openSUSE Leap 42.1, with Xen 4.5.2_04-9 and Linux 4.1.15-8-xen --(first time) --FAIL
>openSUSE Leap 42.1, with Xen 4.5.2_04-9 and Linux 4.1.12-1-xen --(second time) --FAIL

In other words, selecting any opion with Xen in Grub will reproduce the same result.

- In case you are wondering if I actually did this, rest assured that over 3 days are spent trying to get this going, searching forums, bugzilla messages etc., and finally created account here to post this!

  • When at Step 11, saw that X server crashes: Here is the PuTTy Terminal output:*login as: root
    Using keyboard-interactive authentication.
    Last login: Sun Feb 28 20:27:53 2016 from
    Have a lot of fun…
    asus:~ # startx
    xauth: file /root/.serverauth.2018 does not exist

X.Org X Server 1.17.2
Release Date: 2015-06-16
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux asus 4.1.15-8-xen #1 SMP Wed Jan 20 16:41:00 UTC 2016 (0e3b3ab) x86_64
Kernel command line: root=UUID=e96c3fac-33fe-4cb9-9f56-556d971685b4 resume=/dev/sda2 splash=silent quiet showopts
Build Date: 25 October 2015 12:36:08PM

Current version of pixman: 0.32.6
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Sun Feb 28 20:32:48 2016
(==) Using config directory: “/etc/X11/xorg.conf.d”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
(WW) AST: More than one matching Device section found: Autoconfigured Video Device ast
pci id for fd 11: 1a03:2000, driver (null)
EGL_MESA_drm_image required.
/etc/X11/xim: Checking whether an input method should be started.
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale en_US.UTF-8 …
There is no default input method for the current locale.
Dummy input method “none” (do not use any fancy input method by default)
** Message: main.vala:99: Session is LXDE
** Message: main.vala:100: DE is LXDE
** Message: main.vala:131: log directory: /root/.cache/lxsession/LXDE
** Message: main.vala:132: log path: /root/.cache/lxsession/LXDE/run.log
xinit: connection to X server lost

waiting for X server to shut down …
xinit: X server slow to shut down, sending KILL signal

waiting for server to die

…it doesn’t matter which Desktop Environment, it gets here and hangs forever (let it sit for 6 hours!) until a hard reset.

On the bright side, I learned a lot! but, the problem is still there.

Thanks for reading this long exhaustive post!
Any ideas? :slight_smile:

For a smoother experience, you should have updated your system before installing virtualization and again afterwards for good measure to verify all components and components versions are latest.

After 3 or 4, you should have executed your first

zypper update

And, again after installation (preferably after virtualization install and before reboot, but can be anytime before you do more)

The above <might> resolve practically all problems that you describe that come later.

From your current system, I’d recommend you just run the “zypper up” and see if your system functions properly (and creating a Guest works).

If not, since this is a brand new system and the initial LEAP install is so quick (typically about 20 minutes for me), I’d just recommend you wipe clean and start over, doing the system updates as I described… Unlike “normal” installs, when a system is to be used as a virtualization HostOS, I place an extremely high priority on everything working as perfectly as possible from the beginning on the HostOS before I build even one Guest.

Also, I don’t know if you have a particular preference for Xen, but there will be a number of issues you might run into (search this Forum for various Xen related threads, evaluate which may or may be relevant today). KVM in general would be a less complicated experience. Because KVM is built into the kernel, you won’t have to boot into a special kernel for virtualization. You can always install a Xen kernel later if you decide to do so.


Thank you for the reply and suggestion. I guess I was hoping that updates and/or their dependencies would be updated appropriately and as needed. But, there is no harm in trying out your suggestion.

It seems like multiple sources(online) suggest that Xen is a better performing VM than KVM…??. Not sure. Most of my VM experience is with VMWare only; based on Internet tabloids, started courting Xen. :slight_smile:

I don’t know if there is any performance advantage of one virtualization technology over another.
Recent articles I’ve read say that when comparing all virtualizations that rely on CPU hardware extensions (paravirtualiztions), the difference is miniscule and unlikely to be noticeable.

So, then other factors are ordinarily used to select a virtualization technology.
One of the most important are the User tools to manage your Guests… How easy are they to use? How featured are they? If you prefer command line over GUI, how easy are those to use and what can they do?
Another important factor to consider is if you intend to set up a public/private cloud at some time. So, for instance AWS is a modified version of Xen. You’d find a lot easier to modify and export a Xen Guest to AWS than some other virtualization.
Know your own “required” feature list. So, for example one relatively new feature(years old now) that’s not available in all technologies is to do a live replication/migration from one hardware Host to another. VMware does this best, and may be available to varying degree by others.

If all things are equal to you for now, I’d recommend just trying each. Spend a week or two on each, then settle on one for the long run.