Leap 42.1 upgrade error

When attempting to do the System upgrade from 13.2 to Leap 42.1 I followed all the steps at https://en.opensuse.org/SDB:System_upgrade. Everything went smoothly until I executed ‘zypper dup --download in-advance’ from within runlevel 3 as root. Once the system attempted to download the files for 42.1 I received a curl error that the download.opensuse.org domain was not available. Is there a solution to this problem or was it just a bad time to try to upgrade ( Sunday 12pm EST ).

I have a backup of my OS 13.2 partitions I can easily restore but maybe I can just attempt the ‘zypper dup --download in-advance’ command again later if I can understand why it was not previously working.

I’m pretty sure that’s a network error. Maybe you tried at a time when the site was down for maintenance.

So, sure, try again. If you are doing download-in-advance, then there’s no harm done.

Maybe do a quick check for any spelling errors on the urls for the repos. A problem there could cause the issue that you saw.

I waited over 5 hours and then tried again.

The actual error messages are:

‘Download (curl) error ‘http://download.opensuse.org/update/leap/42.1/oss/repodata/repomd.xml
Error code: Connection failed
Error message: Could not resolve host: download.opensuse.org

I then ‘init 5’ to return to graphical mode, login, and try

‘ping http://download.opensuse.org

and receive:

‘unknown host http://download.opensuse.org

Nonetheless I can connect to the Internet without any problems.
Do you think this is because http://download.opensuse.org is down or could there be some other fundamental reason ?

What’s the output from:

cat /etc/resolv.conf

cat /etc/resolv.conf
### /etc/resolv.conf file autogenerated by netconfig!
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
# or disable DNS configuration updates via netconfig by setting:
# See also the netconfig(8) manual page and other documentation.
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
### Please remove (at least) this line when you modify the file!

That’s presumably your router. It seems that your router is not resolving download.opensuse.org.

You might need to configure a different resolver – say one or two of the google public dns servers. Or add an entry to “/etc/hosts”.

I’m currently using (in “/etc/hosts”): download.opensuse.org

I don’t actually have a resolver problem. I’m using that, because otherwise I connect to the repos with IPv6, and then I am referred to really slow mirrors (the geolocation stuff isn’t working well for ipv6).

What I discovered is that pinging download.opensuse.org works fine from a console window after the normal graphical login, but when I switch to runlevel 3, which the System Upgrade documentation strongly recommends for upgrading the system before the ‘zypper dup --download in-advance’ command, then pinging download.opensuse.org returns the “unknown host download.opensuse.org” message. I am following the documentation at https://en.opensuse.org/SDB:Switch_runlevel to switch to runlevel 3 in virtual terminal 2. So either the documentation for the System Upgrade is wrong or there is something wrong with my setup when running at runlevel 3.

Using Network Manager or Wicked?

If Netmanager you must check “All user may connect to this network” to get to get it to load at boot rather then at GUI log in

I am logging starting with the GUI login, then switching to runlevel 3 after having been logged into the GUI.

I suspect that gogalthorp is right about that. When you switch to runlevel 3, the NetworkManager connection goes unless you have shared the connection with all users.

Instead of switching to run level 3, just use CTRL-ALT-F2 to get a console terminal session. Or, better, share the connection with all users. Or switch to “wicked” at least during the upgrade – you can switch back later.

I try:

systemctl status network
NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled)
   Active: active (running) since Mon 2016-04-25 12:13:34 EDT; 10min ago
 Main PID: 831 (NetworkManager)
   CGroup: /system.slice/NetworkManager.service
           ├─ 831 /usr/sbin/NetworkManager --no-daemon
           └─1304 /sbin/dhclient -d -sf /usr/lib/nm-dhcp-helper -pf /var/run/dhclient-wlp0s19f5u8.pid -lf /var/lib/NetworkManager/dhclient-...

As I understand it this tells me that Network Manager is running and not ‘wicked’.

When I launch Yast | Network Devices | Network Settings I get:


Network is currently handled by NetworkManager or completely disabled. YaST is unable to configure some options.

and then I see nothing in the Global Options tag that allows me to share the connection with all users. So how do I do that ?


Yes, NetworkManager is running, but has disconnected. Unless you have a shared connection, then it is disconnected when you logout. And switching to run level 3 is a forced logout.

An ethernet connection is, by default, shared.

Otherwise, from the desktop, you can edit the connection and set it to be shared by all users. This does require the root password.

Or, from Yast, you can switch to using “wicked” instead of “NetworkManager” (on the global tab). You will have to configure the WiFi password there. That’s a connection that will continue at run level 3.

It’s a Wifi connection, not an Ethernet connection.

Are you saying that at run level 3 only “wicked” will work to maintain a connection for root ? If not
I can ‘su -’ to root or login as root. How do I edit the NetworkManager connection so it will be shared by all users so I can upgrade as root, which is what the SystemUpgrade wants me to do ?

No just set NM too “All user may connect to this network”

In the GUI click the network icon then the wrench select the device and edit you will see under general configuration tab

What “network icon” ? Am I supposed to have a network icon in my system tray ? If so it is not there. Where would it be ?

It will be the one you originally used to setup the WiFi connection.

What desktop are you using?

I am using KDE. I don’t remember what I originally did to setup the WiFi connection. I think something popped up with a list of nearby WiFis, I chose the one that was mine, filled in the WiFi WPA2 password, and everything just worked after that.

There’s an icon in the tray that you must have clicked. Move your mouse point over the various tray icons, one at a time, till you find one that mentions your network connection. Then click on that, and click the tool (wrench) to make changes. You need to edit your connection. And one of the choices is to share the connection with all users. That’s the change that keeps you connected even after logout from your desktop session.

I find the icon for the WiFi connection and was able to set it to allow all user to use the Wifi. Afterwards when I switched to virtual terminal 2 via Ctrl-Alt-F2, logged in as root, then changed the runlevel to 3, and relogged in as root I was able to access download.opensuse.org successfully and do the upgrade using ‘zypper dup --download in-advance’ successfully.

Thanks for your help !

I’m glad you got it all working.